15:59:55 <skitt> #startmeeting tsc
15:59:55 <odl_meetbot> Meeting started Thu Aug 16 15:59:55 2018 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:55 <odl_meetbot> The meeting name has been set to 'tsc'
16:00:25 <skitt> #topic Rollcall and agenda-bashing
16:00:37 <skitt> #link agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:00:48 <skitt> #info TSC members, please #info in
16:00:55 <rovarga> #info rovarga
16:01:04 <skitt> #info Project representatives, please #project in
16:01:06 <skitt> #info skitt
16:01:30 <zxiiro> #info Thanh Ha
16:01:37 <skitt> #project odlparent
16:01:42 <abelur> #project autorelease releng/builder
16:01:50 <rovarga> #project odlparent yangtools mdsal controller infrautils coretutorials bgpcep honeycomb/vbd
16:02:17 <skitt> #info abhijit
16:02:18 <jhershbe> #info jhershbe
16:02:25 <jhershbe> #project neutron
16:02:48 <skitt> jhershbe, are you proxying?
16:02:58 <jhershbe> skitt, proxying for who?
16:03:05 <skitt> jhershbe, that's my question
16:03:12 <jamoluhrsen> #info jamoluhrsen
16:03:46 <abhijitkumbhare> #info abhijitkumbhare
16:04:01 <LuisGomez> #info LuisGomez
16:04:16 <shague> #info shague
16:05:00 <skitt> #topic Fluorine release candidate discussion
16:05:09 <shague> #info #project netvirt serviceutils ovsdb genius
16:06:27 <skitt> #info there's been discussion on the mailing list about when to cut the release candidate
16:06:36 <faseelak> #project coe genius serviceutils
16:07:39 <skitt> #info we already have an autorelease build since autorelease has been stable for a long time
16:08:01 <skitt> #info since we have no blocking bugs, there should be no changes in the release candidate except for self-managed projects
16:09:16 <aadam_> I'm in, praise the lord :-)
16:09:19 <skitt> #info we're currently leaning towards an RC date of August 23rd
16:09:31 <skitt> #info which leaves a week for projects to test and sign off
16:09:46 <skitt> #info any change would require a new autorelease build and new sign-offs
16:10:05 <pantelis> I was finally able to make it in too :)
16:10:18 <skitt> #info if a self-managed project finds a blocking bug, the fix will have to wait until the next SR
16:10:54 <skitt> #info adding self-managed projects doesn't change the base artifact
16:12:05 <skitt> #info self-managed projects have a week to test against autorelease
16:12:23 <skitt> #info anything found after the 23rd would require discussion: do we slip the release, or do we fix in the first SR
16:14:28 <skitt> #info with a strong preference for postponing since projects have had time to test
16:15:32 <skitt> #startvote The first Fluorine release candidate will be signed off by August 23rd? -1, 0, +1
16:15:32 <odl_meetbot> Begin voting on: The first Fluorine release candidate will be signed off by August 23rd? Valid vote options are -1, 0, +1.
16:15:32 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:16:39 <rovarga> #vote +1
16:19:20 <abhijitkumbhare> #vote +1
16:19:33 <pantelis> #vote +1
16:19:57 <skitt> #vote +1
16:20:05 <skitt> #info we need a release candidate build with artifacts now
16:20:10 <skitt> #info then projects sign off on that
16:20:18 <skitt> #info then we release it (August 23rd or earlier)
16:20:28 <skitt> #info then self-managed projects bump their dependencies to use it
16:20:45 <skitt> #info then they release, and we build the full distribution
16:21:04 <zxiiro> #vote +1
16:21:19 <shague> #vote +1
16:21:22 <LuisGomez> #vote +1
16:22:20 <skitt> #action LuisGomez to check the managed project documentation to make sure it documents these steps
16:22:33 <skitt> #undo
16:22:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2c36850>
16:22:40 <jamoluhrsen> #vote +1
16:22:41 <skitt> #action LuisGomez to check the managed project documentation to make sure it documents the steps involved in a release
16:23:05 <skitt> #endvote
16:23:05 <odl_meetbot> Voted on "The first Fluorine release candidate will be signed off by August 23rd?" Results are
16:23:05 <odl_meetbot> +1 (8): rovarga, pantelis, skitt, LuisGomez, shague, abhijitkumbhare, zxiiro, jamoluhrsen
16:23:11 <skitt> #chair abhijitkumbhare
16:23:11 <odl_meetbot> Current chairs: abhijitkumbhare skitt
16:24:07 <abhijitkumbhare> https://docs.google.com/document/d/18DNhtuX0673l2yHhbNNkfEGWmZxDC8JxPo1Nyp-X17M/edit#heading=h.mlqhpi9q6t8r
16:24:45 * dfarrell07 is having audio issues
16:24:57 <skitt> #info all projects need to document the improvements that are going into Fluorine
16:25:09 <skitt> #info and flag those which users should care about
16:25:31 <skitt> #link document listing the changes: https://docs.google.com/document/d/18DNhtuX0673l2yHhbNNkfEGWmZxDC8JxPo1Nyp-X17M/edit#heading=h.mlqhpi9q6t8r
16:30:14 <skitt> #info there will be a TWS session around marketing soon
16:33:11 <skitt> #action CaseyLF to follow up with Lisa about marketing concerns (how to gather data, what's relevant etc.)
16:34:43 <skitt> #info the marketing group are looking for people to help them
16:34:53 <skitt> #topic Release dashboard
16:35:29 <skitt> #info the overall trend is positive, autorelease is stable
16:35:45 <skitt> #info aadam_ manually added milestones for the next three months
16:36:08 <skitt> #info two blocker bugs currently
16:36:19 <skitt> #info MDSAL-362 is 70% done according to rovarga
16:36:59 <skitt> #info rovarga will need someone to run CSIT with the candidate fix, jamoluhrsen agreed to take care of that
16:37:15 <skitt> #info abhijitkumbhare thanks aadam_ for all his work herding people to get the release done
16:37:56 <skitt> #info OPNFLWPLUG-1028 is ready to go, already merged on Oxygen, waiting for a +2 on Fluorine
16:40:02 <abhijitkumbhare> #topic Clustering
16:40:33 <skitt> #info CONTROLLER-1742 waiting for jamoluhrsen to dig up some logs and give them to rovarga
16:41:13 <skitt> #info CONTROLLER-1858 has no update, there have been attempts to get more debugging info but the job doesn't fail when run with extra output (so far)
16:41:28 <skitt> #info CONTROLLER-1849 is waiting for jamoluhrsen to look into Artery
16:41:42 <skitt> #info CONTROLLER-1790 might be a duplicate of 1849, jamoluhrsen needs to check
16:42:05 <skitt> #info NETVIRT-1324 is waiting for shague to get better logs
16:42:30 <skitt> #info NETVIRT-1015 might be a duplicate of 1849 again, jamoluhrsen needs to check
16:42:49 <skitt> #info OPNFLWPLUG-1022 needs action from vishnoianil
16:43:08 <skitt> #action LuisGomez to prod Anil regarding OPNFLWPLUG-1022
16:43:35 <skitt> #info CONTROLLER-1788 is waiting for shague to check whether it still happens
16:44:03 <skitt> #info NETVIRT-1027 is an issue in IPv6 land, waiting for more info
16:44:36 <skitt> #info NETVIRT-1395 has patches in progress, might be fixed in a week or so
16:48:03 <skitt> #topic Neon calendar
16:48:22 <skitt> #info dfarrell07 has submitted a patch to duplicate the Fluorine release plan as the Neon release plan
16:48:25 <dfarrell07> https://git.opendaylight.org/gerrit/#/c/75111/
16:48:45 <skitt> #link Neon release plan: https://git.opendaylight.org/gerrit/75111
16:48:48 <skitt> #undo
16:48:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2d5c650>
16:48:54 <skitt> #link candidate Neon release plan: https://git.opendaylight.org/gerrit/75111
16:50:41 <anipbu> #info anipbu
16:50:56 <anipbu> #info gzhao (proxy)
16:50:59 <anipbu> #project usc
16:51:11 <skitt> #info all interested parties should vote on Gerrit
16:51:31 <skitt> #info (after dfarrell07 updates the patch and sends an email requesting reviews)
16:52:35 <skitt> #topic Marketing
16:54:04 <skitt> #info abhijitkumbhare invites all project reps and PTLs to attend next Monday's TWS
16:54:22 <skitt> #info the session will address release planning as well as developer onboarding etc.
16:54:41 <aadam_> skitt, aren't you on vacation :-)
16:54:49 <skitt> aadam_, back this morning
16:55:01 <aadam_> skitt, welcome back
16:55:06 <skitt> aadam_, thanks ;-)
16:55:24 <abhijitkumbhare> aadam_: skitt is back and in full form !
16:55:26 <abhijitkumbhare> :)
16:56:21 <skitt> #info for 2H18 the marketing group is working on determining our primary market/audience
16:56:39 <skitt> #info measuring traction in primary markets
16:57:05 <skitt> #info (numbers of real users, downloads, external press coverage)
16:57:34 <skitt> #info analysing community health stats (numbers of current contributors, their diversity, number of commercial products built on ODL)
17:00:20 <skitt> #info for 2019: what's our top priority, what adjacent techs are relevant, what are our top barriers, what are our top dev priorities
17:02:27 <skitt> #info Martin (our marketing liaison) will participate in TSC calls weekly from now on
17:03:37 <skitt> #topic Cookies
17:03:44 <skitt> #endmeeting