16:01:11 <skitt> #startmeeting tsc
16:01:11 <odl_meetbot> Meeting started Thu Aug 23 16:01:11 2018 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:11 <odl_meetbot> The meeting name has been set to 'tsc'
16:01:20 <skitt> #topic Roll-call and agenda-bashing
16:01:28 <skitt> TSC *members* and proxies, please #info in
16:01:35 <skitt> Project representatives, please #project in
16:01:40 <skitt> #link Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:01:43 <skitt> #info skitt
16:01:45 <anipbu> #info anipbu
16:01:57 <skitt> #project odlparent controller netvirt ovsdb
16:02:02 <anipbu> #project usc
16:02:29 <anipbu> #info gzhao
16:02:42 <zxiiro> #info Thanh Ha
16:02:47 <rovarga> #info rovarga
16:03:15 <rovarga> #project odlparent yangtools mdsal controller infrautils coretutorials honeycomb/vbd bgpcep
16:03:22 <faseelak> #info faseelak proxy for Abhijit
16:03:30 <jamoluhrsen> #info jamoluhrsen
16:03:32 <skitt> #topic Impromptu infrastructure update
16:03:41 <skitt> #info we need to disable all our CLM jobs
16:03:42 <faseelak> #project serviceutils infrautils coe genius
16:04:01 <skitt> #info we found out that the way we use the jobs doesn't respect Sonatype's ToS
16:04:25 <LuisGomez> #info LuisGomez
16:04:41 <vina_ermagan_> #info vina_ermagan
16:04:48 <vina_ermagan_> #project lispflowmapping
16:04:56 <vishnoianil_> #info Anil Vishnoi
16:04:56 <LuisGomez> #project distribution
16:05:17 <vina_ermagan_> #info vina_ermagan proxy for lori
16:05:22 <vishnoianil_> #project openflowplugin
16:06:16 <gzhao> #info gzhao
16:06:34 <skitt> #topic General topics
16:07:50 <skitt> #undo
16:07:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2b59190>
16:07:53 <skitt> #topic Action items
16:08:20 <skitt> #info LuisGomez provided a patch for the managed project documentation to document the steps involved in a release
16:08:24 <LuisGomez> #link https://git.opendaylight.org/gerrit/#/c/75312/
16:09:23 <skitt> #info CaseyLF followed up with Lisa re marketing concerns, Lisa will join the call in a few minutes
16:09:57 <skitt> #info OPNFLWPLUG-1022 has a fix which is merged
16:10:21 <skitt> #topic ODL Parent updates
16:10:36 <skitt> #info ODL Parent 4 is nearly ready, waiting for a Karaf release and a couple of bug fixes
16:10:48 <skitt> #info YANG Tools is ready for Neon, MD-SAL is 50% there
16:11:06 <skitt> #info the integration window patches for kernel projects are in progress
16:11:39 <skitt> #topic ONAP CVE reports
16:12:11 <skitt> #info apparently some of our third-party tooling has open CVEs
16:12:56 <skitt> #info but more importantly, CaseyLF would like us to formalise security relationships with our sister communities
16:15:09 <skitt> #link our vulnerability management process: https://wiki.opendaylight.org/view/Security:Vulnerability_Management
16:17:37 <skitt> #info the conversation started because ONAP is shooting for silver CII and needs security issues reported in CLM to be resolved in ODL
16:18:29 <shague> #info shague
16:18:34 <skitt> #info realistically, ONAP can get silver CII only if ODL gets it too, which means investment on our end, hopefully with help from ONAP
16:20:31 <skitt> #info CaseyLF thinks our CLM reports might be different, which would explain why ONAP sees more issues than we do
16:21:30 <skitt> #info other LFN projects share a CLM instance, we have our own
16:22:12 <skitt> #action zxiiro to open a bug to migrate our instance to the shared infra
16:22:15 <skitt> #undo
16:22:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2dce690>
16:22:25 <skitt> #action zxiiro to open a bug to migrate our CLM instance to the shared infra
16:26:33 <skitt> #info so far the security team aren't aware of this discussion with ONAP
16:26:49 <skitt> #topic Update on SSH/VM access
16:27:16 <skitt> #info there's a workaround to get SSH access to VMs
16:27:39 <skitt> #info apparently the LF hasn't offered SSH access in the past because of an OpenStack bug
16:28:36 <skitt> #info once that's dealt with we'll be able to have SSH access
16:28:48 <skitt> #topic Release dashboard
16:29:10 <skitt> #info today is the Fluorine final checkpoint
16:30:17 <skitt> #action aadam to find a way to identify the releases affected by MRI blocker bugs
16:30:53 <skitt> #info Fluorine autorelease is looking good
16:31:52 <rovarga> skitt: the builds are "similar" not "the same" :)
16:32:05 <skitt> rovarga, true, until we have reproducible builds ;-)
16:32:09 <rovarga> or perhaps equal, but definitely not the same :)
16:32:14 <skitt> rovarga, the code that went into them should be the same
16:32:21 <rovarga> skitt: which we realistically won't have... ever :)
16:32:56 <skitt> rovarga, I know a few people who are betting otherwise
16:33:22 <skitt> rovarga, or rather, that it will become possible to have reproducible builds
16:33:26 <rovarga> skitt: well, until I see some serious effort being put into it ... :)
16:33:53 <skitt> rovarga, https://reproducible-builds.org/ (not specific to ODL of course)
16:34:13 <skitt> #info the release integration window starts on September 7
16:34:43 <skitt> #info for Neon, the affected projects are ODL Parent, YANG Tools and MD-SAL
16:35:00 <skitt> #info they should all be ready by September 7 and we’ll have a fair idea of the amount of work involved to integrate
16:36:44 <skitt> #topic Clustering
16:36:51 <skitt> #info CONTROLLER-1742 might be fixed
16:37:31 <skitt> #info CONTROLLER-1858 needs more debugging info, which will take some time
16:37:50 <skitt> #info CONTROLLER-1849 involves using Artery in a three-node cluster, and jamoluhrsen might be the first person on earth to try this
16:39:07 <skitt> #info jamoluhrsen needs an Artery and Docker and Linux shared memory expert to help him out with this issue
16:39:59 <skitt> #info OPNFLWPLUG-1022 should be fixed, but there's a CSIT issue to fix too
16:40:29 <zxiiro> CaseyLF: If we have time at the end of the meeting I'd like to circle back on the CLM migration request.
16:40:36 <skitt> #action vishnoianil_ to update OPNFLWPLUG-1022
16:40:58 <CaseyLF> Ok.  We need to give Lisa a few minutes too.
16:43:24 <skitt> #info NETVIRT-1015 might correspond to expected messages since the test involves killing two nodes
16:44:07 <skitt> #info the key question is how to monitor a cluster
16:46:29 <skitt> #action shague to downgrade NETVIRT-1015
16:47:36 <skitt> #topic Addressing CSIT at the start of a release
16:48:07 <skitt> #info aadam thinks that now that we've stabilised autorelease, we should address issues in our CSIT
16:49:21 <skitt> #info rovarga fears removing tests; if we end up disabling tests, we need some workflow to ensure they're re-enabled
16:49:37 <skitt> #info any lost test coverage will come back as bug reports later
16:50:24 <skitt> #info shague thinks we need to identify those tests which never pass and are always signed off on
16:50:33 <skitt> #info there are tests which haven't passed in two years
16:50:46 <skitt> #info those probably don't have much value at all
16:51:22 <skitt> #info if we end up removing all the tests for a project, that will have to be addressed by a system test waiver
16:52:13 <skitt> #info vishnoianil_ suggests opening a JIRA every time a test is removed or disabled
16:53:10 <skitt> #info LuisGomez suggests running two test jobs, one with only known-good tests to spot regressions, the other with all tests
16:55:38 <skitt> #topic Marketing
16:56:16 <shague> zxiiro: for the change to use a ahitelist for the tests ro run, that would dovetail into this conversation
16:56:16 <jamoluhrsen> skitt: aadam: autorelease build for us to use is #189 (https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine/189/)
16:56:47 <aadam> jamoluhrsen, owe yeah :-)
16:56:52 <CaseyLF> #topic Marketing
16:56:53 <skitt> #link ODL 2019 planning notes for marketing: https://docs.google.com/document/d/10JQ2CkUX11Mr-64g0ugu6J18uR24LALYpmSzdRpzlf8/edit?usp=drive_web
16:57:07 <CaseyLF> ... I'm not chaired.  :)
16:57:19 <CaseyLF> But you go it, skitt.  Thanks.
16:57:26 <skitt> #info the marketing teams wants to understand what the project goals are for 2019, where the project is expected to focus
16:57:37 <zxiiro> shague: yep
16:57:38 <skitt> #info both in technical terms and marketing terms (new verticals etc.)
16:57:59 <skitt> #info without input from the TSC, marketing will use its best guesses
16:58:13 <skitt> #info the document needs to be completed by the end of August
16:58:47 <skitt> #action CaseyLF to send an email to the TSC list reminding everyone that the planning document needs to be completed
16:59:30 <skitt> #info the important aspect is the goals, tactics can be addressed later
16:59:39 <skitt> #info next Monday’s TWS will be dedicated to this
16:59:54 <skitt> #topic CLM
17:00:12 <skitt> #info there is no migration path if we migrate to the shared LFN system, so if we migrate we'll lose our history
17:00:19 <skitt> #info zxiiro sent an email to the mailing list
17:00:33 <skitt> #topic Cookies
17:00:36 <skitt> #endmeeting