16:01:01 <dfarrell07> #startmeeting tsc
16:01:01 <odl_meetbot> Meeting started Thu Oct  4 16:01:01 2018 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:01 <odl_meetbot> The meeting name has been set to 'tsc'
16:01:12 <dfarrell07> #chair abhijitk CaseyLF skitt
16:01:12 <odl_meetbot> Current chairs: CaseyLF abhijitk dfarrell07 skitt
16:02:07 <dfarrell07> #chair anipbu bradyjohnson jamoluhrsen lori rovarga_ shague vishnoianil vorburger
16:02:07 <odl_meetbot> Current chairs: CaseyLF abhijitk anipbu bradyjohnson dfarrell07 jamoluhrsen lori rovarga_ shague skitt vishnoianil vorburger
16:02:30 <skitt> #topic Roll-call and agenda-bashing
16:02:35 <skitt> #info TSC members please #info in
16:02:42 <skitt> #info Project reps please #project in
16:02:44 <lori> #info lori
16:02:44 <skitt> #info skitt
16:02:50 <bradyjohnson> #info Brady Johnson
16:02:51 <lori> #project lispflowmapping
16:02:52 <jmorvay> #project netconf
16:02:55 <bradyjohnson> #project SFC
16:02:59 <skitt> #project odlparent controller ovsdb netvirt
16:03:06 <vorburger> #info vorburger
16:03:14 <vorburger> #project neutron infrautils daexim genius
16:03:17 <shague> #info shague
16:03:23 <LuisGomez> #info LuisGomez
16:03:23 <LuisGomez> #project distribution
16:03:26 <mperina> #project bgpcep
16:03:34 <skitt> #link Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (somewhat outdated)
16:03:52 <shague> #info shague #project netvirt odltools serviceutils
16:04:08 <vorburger> #project archetypes serviceutils
16:04:34 <anipbu> #info anipbu
16:04:39 <anipbu> #project usc
16:05:44 * bradyjohnson its very quite on the goto meeting...
16:05:59 <skitt> bradyjohnson, goto?
16:06:12 <rovarga_> #info rovarga
16:06:26 * bradyjohnson sorry, zoom meeting
16:06:36 <rovarga_> #project odlparent yangtools mdsal controller bgpcep coretutorials infrautils
16:06:47 <jamoluhrsen> #info jamoluhrsen
16:07:36 <skitt> bradyjohnson, we're talking
16:07:43 <vishnoianil> #info Anil Vishnoi
16:09:38 <vishnoianil> #project openflowplugin
16:10:32 <skitt> #info The nomination period for the TSC elections will start on Nov 1st
16:10:42 <skitt> #topic Dashboards
16:15:43 <skitt> #action aadam_ to go over the list of project plans to identify projects which haven’t filed one yet
16:16:29 <rovarga_> bradyjohnson: will pom.json work? :)
16:16:44 <jamoluhrsen> bradyjohnson: same file we showed you last time:
16:16:45 <jamoluhrsen> https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-neon/58/dependencies.log.gz
16:17:00 <skitt> #action jamoluhrsen to send aadam_ a simple list of all the projects we expect to see there
16:17:01 <bradyjohnson> rovarga_: hahaha! I can read it, Im just thinking of management folks that want to see a list of the managed projects
16:17:05 <jamoluhrsen> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-neon/58/dependencies.log.gz <-- autorelease file showing what we have "in code" as our managed release projects
16:17:24 <bradyjohnson> Seems like we should have that in the release dashboard or on a wiki somewhere
16:17:40 <jamoluhrsen> bradyjohnson: sounds good.
16:18:37 <skitt> #info Neon MRI is looking good
16:18:58 <LuisGomez> fyi managed projects are also listed in the BUILD_ORDER list in the multi-patch job: https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-neon/45/parameters/
16:19:36 <LuisGomez> odlparent yangtools infrautils mdsal controller aaa netconf daexim bgpcep ovsdb neutron lispflowmapping openflowplugin coe genius sfc netvirt
16:24:31 <dfarrell07> #info discussion about preparing all MRI version bump patches for all MR projects and getting multipatch working
16:24:51 <lori> #info we have two possible approaches to merging: (1) start merging patches is dependency order whenever the next project in the queue is ready, breaking everyone until all patches are merged
16:24:56 <dfarrell07> #info there is trade-off between rebasing MRI version bump patches, keeping them working and multipatch passing as world changes under
16:25:15 <lori> #info (2) wait for a successful multipatch job and give releng the superpower to merge all patches
16:25:25 <dfarrell07> #info but by preparing all the patches before starting merge, there less not a large "break the world" window
16:26:07 <lori> #info for option (1) we would have a two-week window for merging all patches
16:26:13 <dfarrell07> #info the design of the MR is to accept breakage in this two week window
16:26:36 <dfarrell07> #info vorburger thinks it's hard to vote to accept a base if we don't know what problems it will bring
16:41:23 <dfarrell07> #info not-ready MRI patch projects: ovsdb, openflowplugin, genius, netvirt
16:44:02 <vorburger> rovarga_: skitt: I'll look into that genius failure after this call, as it's very late in the day for vthapar
16:44:33 * bradyjohnson are you ready, ready??? or just ready?? ;)
16:45:29 <vorburger> rovarga_: oh you just pushed patch set 8 to fix that problem? Are you starting a new multipatch?
16:45:40 <dfarrell07> #info clustering
16:45:43 <dfarrell07> #undo
16:45:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b4f750>
16:45:45 <skitt> #topic Clustering
16:45:53 <jamoluhrsen> #action jamoluhrsen to look at validating CONTROLLER-1746
16:45:56 <skitt> #info CONTROLLER-1746 should be fixed
16:46:18 <skitt> #action jamoluhrsen to check whether CONTROLLER-1746 is resolved
16:50:17 <rovarga_> vorburger: already started
16:53:23 <skitt> #topic Budgeting
16:53:42 <jamoluhrsen> skitt: dfarrell07: aadam_ : CaseyLF: i'd like to ask again about getting live access to our vms in infra.
16:53:51 <skitt> #info LFN is budgeting for 2019
16:54:03 <vorburger> rovarga_: yup, noticed it; I'll keep an eye on https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-neon/46/
16:54:13 <skitt> #info we need to decide what we need budget for (other than recurring stuff such as infra)
16:54:22 <skitt> #info items such as specific events, hiring interns...
17:03:13 <skitt> #topic Cookies
17:03:16 <skitt> #endmeeting