15:59:34 <skitt> #startmeeting tsc
15:59:34 <odl_meetbot> Meeting started Thu Oct 18 15:59:34 2018 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:34 <odl_meetbot> The meeting name has been set to 'tsc'
15:59:47 <skitt> #chair dfarrell07 bradyjohnson abhijitk CaseyLF
15:59:47 <odl_meetbot> Current chairs: CaseyLF abhijitk bradyjohnson dfarrell07 skitt
15:59:59 <skitt> #topic Roll-call and agenda-bashing
16:00:07 <skitt> #link Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:00:23 <skitt> #link Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-10-11-16.00.html
16:00:32 <skitt> #info TSC members, please #info in
16:00:39 <skitt> #info Project representatives, please #project in
16:01:25 <bradyjohnson> #info Brady Johnson
16:01:27 <gzhao> #info gzhao
16:01:30 <bradyjohnson> #project SFC
16:01:53 <mperina> #project bgpcep
16:02:18 <anipbu> #info anipbu
16:02:19 <skitt> #info skitt
16:02:20 <rovarga> #info rovarga
16:02:27 <anipbu> #project usc
16:02:27 <skitt> #project odlparent controller netvirt ovsdb
16:02:46 <rovarga> #project odlparent yangtools mdsal controller infrautils bgpcep coretutorials
16:03:04 <shague> #info shague
16:03:33 <vishnoianil> #info Anil Vishnoi
16:03:44 <vishnoianil> #project openflowplugin
16:03:53 <shague> #info shague #project serviceutils neutron genius
16:04:56 <jmorvay> #info jmorvay
16:04:57 <LuisGomez> #info LuisGomez
16:04:57 <LuisGomez> #project distribution
16:05:07 <jmorvay> #project netconf
16:06:19 <dfarrell07> #topic Neon MRI
16:07:04 <dfarrell07> #info skitt reports ongong fixes going in, currently in NetVirt, most projects passing unit tests, CSIT looking okay except for that NetVirt issue, maybe can start merging now
16:07:16 <zxiiro> #info Thanh
16:08:06 <dfarrell07> #info LuisGomez asks about link for tests
16:08:16 <skitt> #link MRI jobs: https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-neon/
16:08:43 <jamoluhrsen> #info jamoluhrsen
16:10:01 <dfarrell07> #info folks digging into jobs
16:12:28 <dfarrell07> #topic release dashboard
16:12:49 <dfarrell07> #info we missed Fluorine SR1 because milestone Jira didn't exist, wasn't on dashboard
16:12:56 <dfarrell07> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 rel dashboard
16:13:12 <dfarrell07> #info discussion about when to code freeze fluorine
16:13:34 <dfarrell07> #info rovarga says we need odlparent 3.1.4, and about one more day for yangtools after that
16:13:52 <dfarrell07> #info so rovarga says code freeze could be saturday, but working on the weekend sucks, so next week
16:14:23 <dfarrell07> #info odlparent release has security fixes says robert, maybe should have
16:14:47 <abhijitk> #info abhijitk
16:15:00 <dfarrell07> #info jackson update is security issue rovarga was talking about
16:15:06 <rovarga> #link https://git.opendaylight.org/gerrit/#/c/77056/
16:15:21 <rovarga> follow the links, it's a couple of CVEs
16:16:02 <dfarrell07> #info skitt isn't sure we're actually impacted by these jackson problems, but good to not have red flags anyway
16:16:17 <dfarrell07> #info SR2 is early december
16:16:20 <dfarrell07> #undo
16:16:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2d44e90>
16:16:28 <dfarrell07> #info Fluorine SR2 is early december, soonish
16:17:06 <dfarrell07> #info there are for sure users of jackson, like Neutron, that will have trouble checking if impacted (because Michael is on PTO)
16:17:14 <dfarrell07> #info so maybe better to assume we're impacted
16:17:47 <dfarrell07> #info we also want this update for Oxygen SR4 says robert
16:19:03 <dfarrell07> #info skitt has a multipatch job running now, if passes he will release 3.1.4, then releng must promote, then yangtools does same
16:19:17 <dfarrell07> #info best case this could be done tomorrow night
16:19:27 <skitt> #link the odlparent 3.1.4 multipatch job: https://jenkins.opendaylight.org/releng/job/integration-multipatch-test-fluorine/262/
16:21:16 <dfarrell07> #info shague and jamoluhrsen talk about a blocker bug e/// folks are working on, hope to have in today
16:21:44 <dfarrell07> #agreed will will try to get odlparent 3.1.4 and subsequent MRI versions into Fluorine SR1, so we will delay code freeze until early next week (Monday), then review/bless/promote next autorelease
16:23:27 <abhijitk> #topic Clustering
16:23:51 <dfarrell07> #info jamoluhrsen gives update about clustering, says controller clustering effrot wasn't making progress so moving on to netvirt, there are open bugs on dashboard
16:25:18 <dfarrell07> LuisGomez: do you have any progress on turning off faling test work?
16:25:42 <LuisGomez> i am still busy on netconf project
16:26:25 <LuisGomez> i had action point to create jira tickets for all projects having unstable test and i have not done yet
16:26:45 <abhijitk> #topic Turning off failing CI tests
16:27:27 <abhijitk> #info LuisGomez still working on NetConf - taking more time
16:28:46 <abhijitk> #info LuisGomez working on find the pattern to turn off the tests
16:30:01 <dfarrell07> #info there is a major lack of CI folks to do this work, can't really expect magic from jamoluhrsen and LuisGomez
16:31:34 <dfarrell07> #link CIST results https://jenkins.opendaylight.org/releng/view/CSIT/
16:31:40 <dfarrell07> #undo
16:31:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2d5e910>
16:31:47 <dfarrell07> #link https://jenkins.opendaylight.org/releng/view/CSIT/ CSIT results
16:38:05 <bradyjohnson> press the "S" column heading to better organize the results
16:43:26 <dfarrell07> #info lots of discussion about how to clean up tests
16:44:14 <dfarrell07> #info seem to want to have static list of tests we think are stable, make view in jenkins
16:44:27 <dfarrell07> #action shague will make static list of jobs that normally pass into a view in jenkins
16:53:44 <bradyjohnson> I have to drop off the call, I have another meeting to prepare for
16:56:58 <jamoluhrsen> dfarrell07: LuisGomez: shague: rovarga: we are talking about two different things.
16:57:10 <jamoluhrsen> 1) get a short list of blue balls that we all react to
16:57:54 * rovarga ROFL ...
16:59:30 <jamoluhrsen> 2) comment/clean/sanitize existing suites to be able to add them to the list of blue jobs
16:59:33 <shague> jamoluhrsen: agreed. two different things. one is a view. the other is the existing problem of how to keep test coverage. nothing has changed on the latter issue
17:02:16 <abhijitk> #topic Cookies
17:02:23 <skitt> #endmeeting