#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 16:01:22 UTC (full logs).

Meeting summary

    1. tsc members please #info in, projects please #project in (dfarrell07, 16:01:37)
    2. shague (shague, 16:02:12)
    3. abhijitk (abhijitk, 16:02:20)
    4. anipbu (anipbu, 16:02:42)
    5. shague #project netvirt genius serviceutils odltools ovsdb (shague, 16:02:54)
    6. jamoluhrsen (jamoluhrsen, 16:03:17)
    7. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (abhijitk, 16:03:21)
    8. LuisGomez (LuisGomez, 16:04:02)
    9. gzhao (gzhao, 16:04:24)
    10. vorburger (vorburger, 16:04:41)
    11. Thanh (zxiiro, 16:04:42)
    12. we have fluorine sr2 and oxygen sr4 coming up basically now (dfarrell07, 16:07:33)
    13. fluorine autorel is passing now (dfarrell07, 16:07:44)
    14. ariel proposes pushing oxygen back a week to 11/14 so can focus on fl (dfarrell07, 16:08:02)
    15. last chance to get things into oxygen, please cherry-pick now (dfarrell07, 16:08:42)
    16. fluorine was fixed a few days ago, neutron issue worked around and them vorburger properly fixed (dfarrell07, 16:09:57)
    17. AGREED: autorel 260 will be the version we audit as fluorine sr1 (dfarrell07, 16:10:40)
    18. we will do test sign-offs on fluorine sr1 (dfarrell07, 16:11:13)
    19. distro-test job running on fluorine #260 autorelease is https://jenkins.opendaylight.org/releng/view/autorelease/job/integration-distribution-test-fluorine/259/ (jamoluhrsen, 16:12:18)
    20. Fluorine Tracking spreadsheet https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=375731420 (zxiiro, 16:12:22)
    21. csit is still running for 260 but we will copy into sheet above and get sign-offs as soon as done (dfarrell07, 16:13:06)
    22. there is a blocker in mdsal and lots of complexity around getting that verified in the MSI projects (dfarrell07, 16:17:18)
    23. https://jira.opendaylight.org/browse/INFRAUTILS-58 (vorburger, 16:18:14)
    24. detailed discussion about this bug^^ (dfarrell07, 16:18:48)
    25. this is a problem with the MRI model where it in theory it should be quick to get a patch version fix to blockers like this, but in this case we're being told it could take weeks (with a broken world) (dfarrell07, 16:20:50)
    26. we don't have tooling that can check proposed mdsal rel version in MSI projects, and there's lots of complexity in making that happen says LuisGomez (dfarrell07, 16:22:10)
    27. https://jira.opendaylight.org/browse/MDSAL-379 (faseelak, 16:22:54)
    28. the key mess is that projects are using multiple versions of mdsal, so we can't just script find/replace versions (dfarrell07, 16:24:03)
    29. real solution is to clean up projects to only take one or two versions of mdsal (dfarrell07, 16:24:20)
    30. we might want to try to push this cleanup as the blocker, says vorburger (dfarrell07, 16:24:56)
    31. tomp suggests just bumping genius to the proposed-fixed mdsal version to test it, as it's the one that's seeing the problem (dfarrell07, 16:25:47)
    32. one option is to just release the version of mdsal and bump to it to test (dfarrell07, 16:26:22)
    33. another option is to back out all the version bump patches (dfarrell07, 16:26:30)
    34. long-term, we really need to fix this multi-mdsal-version issues if we want to solve this kind of thing in the future (dfarrell07, 16:27:08)
    35. LuisGomez thinks that might be the best path, even if takes a few days, as it's the more useful thing long-term (dfarrell07, 16:27:26)
    36. vorburger suggests if we share this load we might be able to do it quickly enough (dfarrell07, 16:27:42)
    37. shague asks if we can just make mdsal snapshot again (dfarrell07, 16:27:56)
    38. LuisGomez says that impact of making mdsal mri is huge, and maybe we didn't look at it enough, need to get everyone on the same version first (dfarrell07, 16:28:22)
    39. when rovarga returns we might want to discuss bringing mdsal back to snapshots until we fix many-mdsal-version problem (dfarrell07, 16:29:59)
    40. LuisGomez does a better job of explaining this many-mdsal-version thing than I did above (dfarrell07, 16:31:05)
    41. projects seem to be using internal mdsal versions, different per-bundle (dfarrell07, 16:31:41)
    42. doing this fixing how we consume mdsal versions solution seems to be a quick-ish way out that would be useful long-term (dfarrell07, 16:32:23)
    43. that would also make everything for mri mdsal easier (dfarrell07, 16:32:42)
    44. seems to be consensus that we should clean up how we consume mdsal versions as solution (dfarrell07, 16:33:05)
    45. AGREED: we will work with all projects to collab on cleaning up mdsal versions in pom files to converge on single mdsal versions (dfarrell07, 16:34:02)
    46. we need an example, like form skitt, that other projects can follow (dfarrell07, 16:34:22)
    47. this cleaning up versions would also make it easy to switch back to snapshot mdsal if we wanted to go that route (dfarrell07, 16:36:30)
    48. and also make it easier to make job that can auto-bump proposed to mdsal version for testing things in the future (dfarrell07, 16:37:04)
    49. the work of manually changing versions to test one-off now is about the same work as cleaning up versions (dfarrell07, 16:37:24)
    50. the key is that it needs to be easy to switch mdsal versions, which needs this cleanup (dfarrell07, 16:38:04)
    51. after we do cleanup, we switch mdsal to 3.0.2 snaphosts and test (rovarga will not like this), iterate until we fix, then make decision about moving mdsal back to mri (dfarrell07, 16:39:00)
    52. sorry rovarga we know you will not like that but it's the best idea we have (dfarrell07, 16:39:17)
    53. Proposed Plan (vorburger, 16:40:04)
    54. 1. get all projects to switch their mdsal dependencies to mdsal-artifacts, following an example from Stephen (vorburger, 16:40:27)
    55. 2. switch all mdsal versions from 3.0.1 (3.0.0 ?) to 3.0.2-SNAPSHOT on a topic branch, doesn't have to be merged, just so that we can run a multipatch job (vorburger, 16:41:14)
    56. 3. merge those patches, either for 3.0.2-SNAPSHOT o or 3.0.2 if we have a mdsal release (vorburger, 16:41:37)

  1. stable jobs (dfarrell07, 16:42:56)
    1. we have a set of jobs (thanks shague!) that we think should be passing (dfarrell07, 16:43:17)
    2. there are errors in some of the jobs that we want to keep stable (dfarrell07, 16:43:28)
    3. seems a few jobs broke yesterday, 31st (dfarrell07, 16:44:12)
    4. LuisGomez points out that it may have broke on various branches, which is odd (dfarrell07, 16:45:28)
    5. jamoluhrsen is looking at logs (dfarrell07, 16:45:32)
    6. seeing some logs about binding exception addr in use (dfarrell07, 16:46:40)
    7. we can't debug this live, need to take to lists (dfarrell07, 16:46:48)
    8. int/releng call will look at it in a few hours (dfarrell07, 16:47:05)
    9. https://lists.opendaylight.org/pipermail/tsc/2018-October/010496.html (abhijitk, 16:49:23)

  2. kubcon (dfarrell07, 16:50:25)
    1. dfarrell07 gives updates about lfn booth at kubecon (dfarrell07, 16:50:35)
    2. we have 10 min talk and shared booth (dfarrell07, 16:50:51)
    3. https://lists.opendaylight.org/pipermail/tsc/2018-November/010512.html (abhijitk, 16:51:12)
    4. Call for nominations out (abhijitk, 16:51:25)
    5. https://wiki.opendaylight.org/view/TSC:2018_Election tsc nominations wiki (dfarrell07, 16:52:40)
    6. two week window. nominate! (dfarrell07, 16:52:51)
    7. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/openflowplugin-csit-3node-clustering-only-fluorine/259/robot-plugin/log.html.gz#s1-s1 (LuisGomez, 16:52:55)

  3. cookies (dfarrell07, 16:53:54)
    1. Folks who have not been TSC members - do consider running for the election (abhijitk, 16:54:00)


Meeting ended at 17:08:15 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dfarrell07 (59)
  2. abhijitk (16)
  3. vorburger (12)
  4. LuisGomez (12)
  5. zxiiro (11)
  6. jamoluhrsen (9)
  7. faseelak (3)
  8. odl_meetbot (3)
  9. shague (2)
  10. anipbu (2)
  11. gzhao (1)
  12. lori (1)


Generated by MeetBot 0.1.4.