16:59:53 <CaseyLF> #startmeeting tsc
16:59:53 <odl_meetbot> Meeting started Thu Nov  8 16:59:53 2018 UTC.  The chair is CaseyLF. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:53 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:18 <CaseyLF> #chair dfarrell07 zxiiro skitt
17:00:18 <odl_meetbot> Current chairs: CaseyLF dfarrell07 skitt zxiiro
17:00:33 <zxiiro> #info Thanh Ha
17:00:56 <lori> #info lori
17:01:00 <jamoluhrsen> #info jamoluhrsen
17:01:06 <lori> #project lispflowmapping
17:01:18 <anipbu> #info anipbu
17:01:26 <abhijitk> #info abhijitk
17:01:31 <anipbu> #project usc
17:01:53 <abhijitk> CaseyLF: can you also make me the chair on IRC?
17:02:03 <dfarrell07> #chair abhijitk
17:02:03 <odl_meetbot> Current chairs: CaseyLF abhijitk dfarrell07 skitt zxiiro
17:02:09 <skitt> #info skitt
17:02:16 <skitt> #project odlparent controller ovsdb netvirt
17:02:19 <mperina> #project bgpcep
17:03:18 <shague> #info shague
17:03:22 <zxiiro> abhijitk: it's 1 am for me. so good mornight.
17:03:27 <dfarrell07> #chair jamoluhrsen vishnoianil shague lori
17:03:27 <odl_meetbot> Current chairs: CaseyLF abhijitk dfarrell07 jamoluhrsen lori shague skitt vishnoianil zxiiro
17:03:45 <shague> #info shague #project netvirt serviceutils genius
17:04:02 <vishnoianil> #info Anil Vishnoi
17:04:11 <vishnoianil> #project openflowplugin
17:04:41 <dfarrell07> #info thanks for all the great work over many years lisa!
17:05:00 <dfarrell07> #info lisa will be stepping down from LF marketing role, taking role in member company
17:05:18 <dfarrell07> #info discussions ongoing about next leadership of ODL marketing work group
17:06:17 <LuisGomez> #info LuisGomez
17:06:25 <LuisGomez> #project distribution
17:08:40 <jmorvay> #info jmorvay
17:08:45 <jmorvay> #project netconf
17:08:58 <dfarrell07> #info tsc nomination period is half way through, ends next week
17:09:12 <dfarrell07> #info find the wiki and self nominate
17:09:32 <skitt> #link https://wiki.opendaylight.org/view/TSC:2018_Election
17:09:33 <abhijitk> #topic TSC election
17:09:46 <abhijitk> #info Reminder of self nominations for TSC 2019 election
17:09:57 <abhijitk> #link https://wiki.opendaylight.org/view/TSC:2018_Election
17:10:33 <rovarga> #info rovarga
17:10:37 <CaseyLF> #topic Release Updates
17:10:48 <rovarga> #project odlparent yangtools mdsal controller coretutorials bgpcep infrautils
17:11:50 <dfarrell07> abhijitk, CaseyLF Can I request some time to do the Ansible project creation review?
17:12:20 <CaseyLF> We should have time.  Particularly if Brian / Alexis don't show up.
17:12:21 <abhijitk> #info Fluorine SR1
17:12:34 <CaseyLF> Speaking of which, does anyone have their number?
17:12:42 <CaseyLF> Can you message it to me if you do?
17:12:45 <CaseyLF> Or text me.
17:13:43 <abhijitk> #startvote Shall the TSC approve the build specified as Fluorine SR1? -1,0,+1
17:13:43 <odl_meetbot> Begin voting on: Shall the TSC approve the build specified as Fluorine SR1? Valid vote options are -1, 0, +1.
17:13:43 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:13:51 <dfarrell07> #endvote
17:13:51 <odl_meetbot> Voted on "Shall the TSC approve the build specified as Fluorine SR1?" Results are
17:14:00 <dfarrell07> #link https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=591778755 tracking spreadsheet for fl sr
17:14:19 <dfarrell07> #link https://jenkins.opendaylight.org/releng/job/autorelease-release-fluorine/260/ autorelase we're vetting as fl sr
17:15:11 <dfarrell07> #link https://nexus.opendaylight.org/content/repositories//autorelease-2463/org/opendaylight/integration/karaf/0.9.1/karaf-0.9.1.zip eact artifact we are evaluating
17:15:37 <dfarrell07> #link https://jenkins.opendaylight.org/releng/job/integration-distribution-test-fluorine/264/ distro test results (first ones failed due to infra)
17:16:40 <dfarrell07> #startvote Shall the TSC bless autorelease 260 as Fluorine SR1, assuming distro test results 264 get sign-offs? -1,0,+1
17:16:40 <odl_meetbot> Begin voting on: Shall the TSC bless autorelease 260 as Fluorine SR1, assuming distro test results 264 get sign-offs? Valid vote options are -1, 0, +1.
17:16:40 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:17:15 <jamoluhrsen> #vote +1
17:17:17 <zxiiro> #vote +1
17:17:19 <anipbu> #vote +1
17:17:20 <shague> #vote +1
17:17:26 <skitt> #vote +1
17:17:26 <abhijitk> #vote +1
17:17:52 <rovarga> #vote +1
17:17:58 <dfarrell07> lori
17:18:22 <lori> #vote +1
17:18:26 <abhijitk> #endvote
17:18:26 <odl_meetbot> Voted on "Shall the TSC bless autorelease 260 as Fluorine SR1, assuming distro test results 264 get sign-offs?" Results are
17:18:26 <odl_meetbot> +1 (8): rovarga, skitt, zxiiro, shague, lori, jamoluhrsen, anipbu, abhijitk
17:18:32 <dfarrell07> thanks :)
17:19:11 <abhijitk> #agreed TSC blesses autorelease 260 as Fluorine SR1, assuming distro test results 264 get sign-offs
17:20:43 <abhijitk> #topic ODL Licensing (EPL) and ONAP's (Apache 2.0)
17:21:06 <dfarrell07> #info brain and ONAP give briefing on DLUX use in ONAP, that they were finding value from it, we deprecated it because no maintainers
17:21:23 <dfarrell07> #undo
17:21:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2baadd0>
17:21:26 <dfarrell07> #topic dlux
17:21:28 <dfarrell07> #info brain and ONAP give briefing on DLUX use in ONAP, that they were finding value from it, we deprecated it because no maintainers
17:22:08 <dfarrell07> #info discussion about how best to proceed, if should try to revive dlux vs use something new, and downsides of profliration of third party options if no first party option
17:22:40 <dfarrell07> #info rovarga talks about ODL's perspective that project is in this state because no on has stepped up to maintain it in ODL upstream, despite many calls from us for contributions
17:23:28 <dfarrell07> #info Martin from High Street small team working on DLUX, would be willing to be a part of the solution but may not be able to do all of it
17:24:09 <dfarrell07> #info Anil V points out that if we revive it, we need folks to stick around long-term to maintain it for consumers, else we will have to depreciate it again
17:24:43 <dfarrell07> #info anil gives summary of how we could revive dlux inside odl, by getting folks watching release list, making it a managed project and tracking it properly
17:25:29 <dfarrell07> #info Martin says they know this, have knowledge, have tech experience, but can't guarantee it could be maintained for long-term
17:32:14 <dfarrell07> #info detailed discussion about if it should be inside of ODL or out, managed or unmanaged, implications of all
17:32:34 <dfarrell07> #info dfarrell07 and brain talk about how might be better to start with newer UI framework vs saving old DLUX
17:33:08 <dfarrell07> #info robert talks about detailed implications regarding project GUIs, strucutre, etc
17:33:43 <dfarrell07> #info anil v as selfish TSC member would love to have some pretty pictures to show in demos, as we've always been told we're good but have boring demos ;)
17:37:39 <dfarrell07> #info takeaway is that we need to go figure out plan, tech bits that will be used, unmanged project
17:37:53 <abhijitk> #topic Ansible Project Proposal
17:38:21 <shague> #link https://lists.opendaylight.org/pipermail/project-proposals/2018-October/000790.html
17:38:30 <shague> #link https://wiki.opendaylight.org/view/Project_Proposals:Ansible
17:38:41 <dfarrell07> shague: you just beat me on both ;)
17:42:09 <abhijitk> shague: can you link the presentation?
17:44:17 <shague> #link https://docs.google.com/presentation/d/1RZWwhQ4Pl77zbQUB-QcvE3vWZVNs2tDnhBLcqa8hWeI/edit#slide=id.g434775e8d2_0_182
17:44:31 <dfarrell07> #info anil asks about if logic is generic enough to add playbooks on sb and API on nb to do basically anything, not some specific use case
17:45:08 <dfarrell07> #info question about what protocol is used on SB, typically ansible uses SSH to get into any box (including switches) and the does local logic
17:46:29 <dfarrell07> #info question about why do this in ODL, answer is that this can be used for underlay mgmt on many devices
17:47:03 <dfarrell07> #info anil likes it a lot if it's not restricted to any use cases, able to be used by many for much
17:48:09 <dfarrell07> #info lori asks if this is only ansible or if it could be abstracted in some way to include things like chef or puppet
17:48:54 <abhijitk> #startvote Shall the TSC approve the Ansible Project (inside OpenDaylight) as an OpenDaylight project? -1, 0, +1
17:48:54 <odl_meetbot> Begin voting on: Shall the TSC approve the Ansible Project (inside OpenDaylight) as an OpenDaylight project? Valid vote options are -1, 0, +1.
17:48:54 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:49:11 <dfarrell07> #endvote
17:49:11 <odl_meetbot> Voted on "Shall the TSC approve the Ansible Project (inside OpenDaylight) as an OpenDaylight project?" Results are
17:49:14 <dfarrell07> #startvote Shall the TSC approve the Ansible project as an Incubation, Managed project? -1,0,+1
17:49:14 <odl_meetbot> Begin voting on: Shall the TSC approve the Ansible project as an Incubation, Managed project? Valid vote options are -1, 0, +1.
17:49:14 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:49:22 <zxiiro> #vote +1
17:49:23 <jamoluhrsen> #vote +1
17:49:24 <skitt> #vote +1
17:49:24 <rovarga> #vote +1
17:49:25 <LuisGomez> #vote +1
17:49:25 <lori> #vote +1
17:49:25 <anipbu> #vote +1
17:49:27 <shague> #vote +1
17:49:35 <abhijitk> #vote +1
17:50:28 <skitt> yeah we don’t really know how familiar shague is with the processes ;-)
17:50:33 <dfarrell07> #endvote
17:50:33 <odl_meetbot> Voted on "Shall the TSC approve the Ansible project as an Incubation, Managed project?" Results are
17:50:33 <odl_meetbot> +1 (9): rovarga, skitt, anipbu, LuisGomez, shague, lori, jamoluhrsen, zxiiro, abhijitk
17:50:38 <shague> what process?
17:50:46 <dfarrell07> #agreed actually *unmanged*, not managed, dfarrell07 mistake
17:50:52 <abhijitk> #undo
17:50:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2d72a10>
17:51:17 <abhijitk> #agreed actually *unmanaged*, not managed, dfarrell07 mistake
17:51:54 <abhijitk> #topic Releases
17:52:05 <dfarrell07> #action shague will work with helpdesk to do code import, get committer rights
17:52:38 <dfarrell07> #info follow up with Steve Winslow via helpdesk about IPR, ansible project and shague
17:53:38 <dfarrell07> #info ariel proposes moving oxygen sr4 back a bit so it doesn't conflict with fluorine release next week
17:54:01 <dfarrell07> #info we still need to merge odlparent 3.1.4 into oxygen before sr
17:54:29 <dfarrell07> #info there are important bugfixes in 3.1.4, including security fixes, so we should take our time to make sure it has these fixes in
17:54:51 <dfarrell07> #info there are some patches, maybe netconf, that need to be backported before ready
17:55:08 <dfarrell07> #info nov 28th is new oxygen sr4 date
17:55:24 <dfarrell07> #action skitt rovarga to work to get 3.1.4 odlparent into stable/oxygen
17:55:44 <dfarrell07> #topic clustering
17:55:51 <skitt> rovarga, ah yes, netconf-ssh
17:55:54 <dfarrell07> #info jamoluhrsen asks for more people to contribute cycles
17:56:52 <dfarrell07> #info there's a clustering bug that jamoluhrsen is having trouble setting fixed-in, basically we need versions for all the fl srs
17:57:08 <abhijitk> skitt: your statement sounded you said netconf-ish :)
17:57:09 <jamoluhrsen> #action ariel to add fluorine-sr2 release tag in jira
17:57:31 <dfarrell07> #action ariel to add all fluorine and maybe neon release tags in jira
17:58:21 <dfarrell07> #topic cookies
17:58:24 <dfarrell07> #endmeeting