17:00:36 <skitt> #startmeeting tsc
17:00:36 <odl_meetbot> Meeting started Thu Nov 15 17:00:36 2018 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:36 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:52 <skitt> #chairs dfarrell07 CaseyLF abhijitk
17:01:00 <jamoluhrsen> #info jamoluhrsen
17:01:01 <skitt> #topic Roll-call and agenda-bashing
17:01:07 <skitt> #info TSC members please #info in
17:01:14 <skitt> #info Project representatives please #project in
17:01:17 <skitt> #info skitt
17:01:26 <skitt> #project odlparent controller ovsdb netvirt
17:01:28 <JMorvay> #project netconf
17:01:55 <dfarrell07> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda
17:02:16 <shague> #info shague
17:02:36 <skitt> despite its old date, the agenda has been updated
17:02:46 <dfarrell07> skitt: I was just wondering that ;)
17:02:52 <zxiiro> #info Thanh ha
17:02:55 <shague> #info shague #porject netvirt serviceutils odltools
17:03:18 <faseelak> #project genius serviceutils coe infrautils
17:03:56 <vorburger> #info vorburger
17:04:36 <vorburger> #project infrautils odlparent neutron daexim archetypes controller genius
17:05:16 <mperina> #project bgpcep
17:05:34 <LuisGomez> #info LuisGomez
17:05:41 <LuisGomez> #project distribution
17:06:14 <dfarrell07> #chair rovarga_ anipbu vishnoianil
17:06:31 <dfarrell07> skitt: your first chair statement was wrong, no "s"
17:06:47 <skitt> #chair dfarrell07 CaseyLF
17:06:47 <odl_meetbot> Current chairs: CaseyLF dfarrell07 skitt
17:06:50 <anipbu> #info anipbu
17:06:53 <dfarrell07> #chair rovarga_ anipbu vishnoianil
17:06:53 <odl_meetbot> Current chairs: CaseyLF anipbu dfarrell07 rovarga_ skitt vishnoianil
17:07:09 <rovarga_> #info rovarga
17:07:23 <rovarga_> #project odlparent yangtools mdsal controller infrautils coretutorials bgpcep
17:07:30 <dfarrell07> #topic tsc election
17:07:55 <dfarrell07> #info confusion about when nominations end, wiki says yesterday utc midnight but casey says actually today 5pm pt
17:08:38 <abhijitk> #info abhijitk
17:09:17 <abhijitk> Can someone add me to chairs?
17:09:30 <skitt> #chair abhijitk
17:09:30 <odl_meetbot> Current chairs: CaseyLF abhijitk anipbu dfarrell07 rovarga_ skitt vishnoianil
17:10:54 <skitt> #info discussion about the company cap
17:11:07 <skitt> #info given the smaller company involvement, the context has changed
17:11:39 <skitt> #info but rovarga_ points out we still want to avoid company dominance, which becomes easier as involvement shrinks
17:12:03 <skitt> #info dfarrell07 still thinks caps are a good thing and the current limit seems fair
17:14:40 <skitt> #info question regarding the necessity of voting if the number of nominees equals the number of seats in each category
17:15:16 <skitt> #action CaseyLF to check with phrobb to determine whether a vote is actually required in these circumstances
17:16:34 <LuisGomez> dfarrell07, i respect your decision but i still think you should be in the tsc :)
17:17:02 <skitt> #info rovarga_ asks whether the lack of nominees reflects happiness with the current TSC composition or lack of volunteers
17:17:13 <skitt> #info if the latter, we may want to reduce the number of seats
17:17:22 <dfarrell07> LuisGomez: thanks buddy :)
17:18:20 <dfarrell07> LuisGomez: I trust how you guys vote, know we're in good hands ;)
17:18:49 <dfarrell07> #info discussion about not being lots of competition for seats, reasons why
17:19:24 <dfarrell07> #info robert suggests options 1. folks are happy with tsc 2. not enough folks from community interested
17:19:44 <skitt> dfarrell07, see minutes just above
17:19:48 <dfarrell07> #info dfarrell07 also thinks could be that folks are self-selecting for who would be best before nominations
17:19:57 <skitt> dfarrell07, good point
17:20:00 <dfarrell07> skitt: ah, othanks
17:21:49 <skitt> #topic Releases
17:22:37 <skitt> #info Fluorine SR1 is still not out
17:23:26 <dfarrell07> #info jamo reports that there is candidate build with test results being signed off, about 75% done
17:23:36 <dfarrell07> #info see mailing lists for details
17:24:20 <dfarrell07> #info vorburger asks about some newish bugs in openflow plugin that might be blockers, if we want to consider
17:24:42 <jamoluhrsen> faseelak: can you look at coe csit for fluorine sr1
17:24:43 <dfarrell07> #info rovarga_ says we should just get this out, pick up next blockers in sr2 which can be quite soon
17:24:58 <dfarrell07> #info rovarga_ says waiting on branch to be unfrozen to merge lots of things that will make things better
17:25:05 <faseelak> jamoluhrsen, it is fixed..
17:25:17 <faseelak> jamoluhrsen, rerun should pass
17:25:27 <jamoluhrsen> faseelak: can you write a note and mark it okay?
17:25:34 <jamoluhrsen> faseelak: https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=932344730
17:25:39 <faseelak> jamoluhrsen, sure!
17:25:42 <dfarrell07> #info rovarga_ says stuff vorburger found in openflowplugin is cluster* and should be fixed but not in sr1
17:25:52 <dfarrell07> #info go sign off
17:26:20 <faseelak> jamoluhrsen, done!
17:26:21 <dfarrell07> #info oxygen sr4 is targeted for two weeks, week after thanksgiving
17:26:30 <dfarrell07> #info we don't have a meeting next week
17:27:32 <dfarrell07> #info oxygen sr4 now oxygen 29th in jira too
17:29:24 <dfarrell07> #agreed we have passed the neon version bump and CSIT checkpoints, so the neon MRI artifacts are accepted
17:30:05 <dfarrell07> #info there are currently two blocking bugs
17:31:20 <dfarrell07> #info neutron-204 is a blocker on all branches
17:31:47 <dfarrell07> #info vorburger says there is a fix for neutron-204 and it just needs to get merged to all branches
17:33:14 <dfarrell07> #info other blocker is ovsdb-470, again there seems to be patches and they need to cherry-picked
17:33:28 <dfarrell07> #info skitt says patch or no patch ovsdb-470 isn't a blocker
17:33:37 <dfarrell07> #info ovsdb-470 changed from blocker to high
17:33:48 <vorburger> #action vorburger to move NEUTRON-204 from Fluorine-SR1 to Fluorine-SR2
17:34:45 <dfarrell07> #action aadam to work on filters for relmang dashboard to not show done items
17:35:27 <dfarrell07> #info vorburger reports that archetype project needs help after neon mri, tomp says will help
17:35:28 <vorburger> #action aadam to make sure https://jira.opendaylight.org/browse/SRVUTILS-4 which is Status Done does not show up on the Release dashboard Neon-MRI anymore
17:35:52 <vorburger> #action tomp will take care of https://jira.opendaylight.org/browse/ARCH-3
17:35:53 <dfarrell07> #info no clustering updates, says jamoluhrsen
17:36:19 <dfarrell07> #info rovarga_ reports that version bump for odlparent and yang tools is happening right now
17:36:52 <dfarrell07> #action aadam will do fl retrospective after thanksgiving
17:39:26 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/77837/ supercomitter patch
17:39:32 <vorburger> jamoluhrsen: while moving the Fix Version of yizr https://jira.opendaylight.org/browse/NEUTRON-204, I've just stumbled upon https://jira.opendaylight.org/browse/NEUTRON-202. Is Josh onto that, or should I add that to my pile to have at least a closer first look some time?
17:39:37 <abhijitk> #undo
17:39:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2c397d0>
17:39:40 <abhijitk> #topic Super committer
17:39:46 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/77837/ supercomitter patch
17:41:10 <abhijitk> #topic State of infra
17:41:38 * rovarga_ is really missing infra updates :)
17:42:07 <dfarrell07> #info zxiiro reports they are digging in with vexxhost, lf infra people, starting today hard and will update
17:42:57 <rovarga_> dfarrell07: not sure if it's a campfire or a bonfire, though :)
17:43:17 <dfarrell07> rovarga_: as long as it's communal ;)
17:43:53 <zxiiro> There hasn't been much infra changes in recent times so not much to update. Other than the gateway timeouts it's been fairly smooth sailing.
17:45:02 <zxiiro> Last major change was the Nexus CLM / Nexus IQ move which was discussed on TSC.
17:45:08 <rovarga_> zxiiro: ah, I know ... can you discuss about Central artifacts?
17:45:32 <zxiiro> I could
17:50:36 <abhijitk> #topic Pushing artifacts to Maven Central
17:50:58 <dfarrell07> #info discussion about making sure we are trying to optimize infra cost, that we have process in place and are doing it, that we need to share infra costs more widely (with test/releng, not just tsc)
17:51:09 <skitt> #info we're now ready to push artifacts to Maven Central
17:51:17 <skitt> #info the next step is to push a release of odlparent
17:53:51 <skitt> #info pushing historical artifacts to Maven Central is very tedious so it's not planned for now
17:54:28 <skitt> #info rovarga_ wants to make "push to Maven Central" a blocker: a release of odlparent etc. isn't complete if it's not on Maven Central
17:54:47 <skitt> #info rovarga_ also points out that we have historical artifacts which are difficult to republish, but that we may want to push to Maven Central
17:54:58 <rovarga_> #info not exactly what I meant, but it's fine :)
17:54:58 <skitt> #info such as adsal remnants
17:55:04 <skitt> rovarga_, ah sorry
17:55:27 <skitt> #endmeeting