16:58:38 <dfarrell07> #startmeeting tsc
16:58:38 <odl_meetbot> Meeting started Thu Dec  6 16:58:38 2018 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:38 <odl_meetbot> The meeting name has been set to 'tsc'
16:59:33 <dfarrell07> #chair abelur anipbu faseelak jamoluhrsen LuisGomez phrobb rovarga shague skitt vishnoianil vorburger
16:59:33 <odl_meetbot> Current chairs: LuisGomez abelur anipbu dfarrell07 faseelak jamoluhrsen phrobb rovarga shague skitt vishnoianil vorburger
16:59:46 <dfarrell07> #info TSC members please #info in
16:59:53 <skitt> #info skitt
16:59:56 <dfarrell07> #info Daniel Farrell for Thanh Ha
17:00:06 <premsankar> #info premsankar
17:00:12 <faseelak> #info faseelak
17:00:22 <dfarrell07> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda agenda in the normal place
17:00:31 <LuisGomez> #info LuisGomez
17:00:55 <jamoluhrsen> #info jamoluhrsen
17:02:38 <shague> #info shague
17:02:42 <abelur> #info abelur
17:02:45 <anipbu> #info anipbu
17:02:52 <dfarrell07> #info Abhijit is sick and Ariel is at some manager meeting, so both not here I think
17:03:03 <dfarrell07> 9
17:03:18 <skitt> #info TSC members, please remember to vote for the TSC chair
17:03:25 <shague> #info shague #project netvirt serviceutils odltools ovsdb
17:03:30 <skitt> #info if you haven't received an email with the Condorcet link, ping CaseyLF
17:03:56 <faseelak> #project genius serviceutils coe infrautils
17:04:01 <dfarrell07> #topic TSC chair election
17:04:05 <premsankar> #project coe
17:04:10 <dfarrell07> #info voting is open, please go vote TSC members
17:04:24 <dfarrell07> #topic LF closure
17:04:54 <dfarrell07> #info there will be a holiday shutdown for LF folks
17:05:07 <dfarrell07> #info if you need casey he will be on IRC
17:05:16 <dfarrell07> #info if you need IT support check lf-releng IRC and helpdesk
17:05:23 <CaseyLF> #info LF it support channel is #lf-releng
17:05:45 <skitt> #topic Releases
17:06:06 <skitt> #info Fluorine SR1 is out, officially
17:06:55 <dfarrell07> #info Luis says it's getting a bit more clear how to do these MR releases, just need to remember that it's a bit more work/time after release
17:07:19 <dfarrell07> #info skitt asks if it's all doc'd, LuisGomez says yes because he has no memory so he's always reading the doc
17:07:19 <skitt> #info Releasing the distro is now the same as releasing a release-managed project
17:07:46 <skitt> #info Oxygen SR4 is on-going, with a number of last-minute patches, and we now have a build
17:07:52 <skitt> #info We are waiting for sign-offs
17:07:59 <abelur> #link https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=1286339548
17:08:01 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=1286339548 <- oxy sr4 csit sign-off
17:09:06 <dfarrell07> #info there are still lots of projects that need sign-off
17:09:10 <vorburger> #info vorburger
17:09:28 <vishnoianil> #info Anil Vishnoi
17:09:36 <vishnoianil> #project openflowplugin
17:09:39 <vorburger> #project {$projects.where.vorburger.isCommiter()}
17:09:52 <dfarrell07> #info jamoluhrsen had concern that bgpcep had signed-off first totally-bad result as okay, turns out bgpcep doesn't know who did that, but the actual lead is actually auditing
17:10:06 <abelur> #project releng/builder releng/autorelease
17:10:31 <dfarrell07> abelur: you don't have to do that for non-Managed projects
17:10:39 <dfarrell07> abelur: but you can :)
17:10:57 <abelur> ah ok :)
17:12:02 <dfarrell07> #info question about when to do SR2 Fl, since SR1 was quite late
17:12:27 <dfarrell07> #info can either bump it out and maybe also adjust other SR dates, or maybe just drop the SR and only have 3 for fl
17:13:11 <dfarrell07> #info SR3 is scheduled for Feb 7, so that's pretty good timing anyway
17:14:42 <dfarrell07> #agreed Fluorine SR2 will happen on SR3 orig date, SR3 on SR4 date, and no SR4
17:14:55 <anipbu> +1
17:22:42 <dfarrell07> #topic release
17:22:52 <dfarrell07> #info we went through dashboard but didn't take notes, all is okay
17:23:15 <dfarrell07> #topic ONAP Edge using ODL
17:23:28 <dfarrell07> #info Prem brings discussion about ODL usage in ONAP Edge effort
17:24:01 <dfarrell07> #info Prem would like to see us work on reducing footprint and bring down startup time for ODL to be more useful in ONAP Edge
17:24:22 <dfarrell07> #info Ildiko is talking with Prem about some usage of ODL in ONAP as well
17:25:03 <dfarrell07> #info vorburger has some efforts, old-simple, that would help with bringing down footprint/startup
17:25:40 <dfarrell07> #info some +1s to bringing group together who have interests in this, but mainly need people working in the trenches to make progress
17:26:23 <dfarrell07> #info basically we need devs who want this to step up and do work, but can start a group and then hope we pull in those people
17:26:43 <dfarrell07> #topic ODL rep for ONAP
17:27:19 <dfarrell07> #info Prem has been attending various ONAP meetings and noticed a need/ask for ODL people to come and be in their conversations
17:29:06 <dfarrell07> #info Prem gives info about SDNC and SDNR usage of ODL in ONAP
17:29:38 <dfarrell07> #info For SDNR, they want netconf to be very performate so can handle large yang models
17:30:13 <dfarrell07> #info tl;dr there are many consumers of ODL in ONAP and we should do a better job of interacting with them
17:30:57 <dfarrell07> #info maybe prem can come back and give some more detailed presentations about ODL in ONAP and help drive better collaboration, help us understand what users need
17:32:19 <dfarrell07> #info dfarrell07 suggests we can combine this with thoughts about getting people who get value from ODL supporting ODL
17:32:42 <dfarrell07> #info maybe we can work with these folks using ODL to teach them how to support/improve the parts they care about
17:34:32 <dfarrell07> #info anil V suggests we have something like the old advisor group, but for these open source projects vs companies
17:34:57 <dfarrell07> #info LuisGomez points out that a huge user for ODL is various other Open source projects, so really should work on supporting those downstreams
17:35:35 <dfarrell07> #info there are companies that have lots of devs working on ODL, but they are just doing it in ONAP, which is very, very sad
17:36:21 <dfarrell07> #info Prem says there are lots of not-shared ~forks of ODL in various places in ONAP, need to get those people working with us
17:38:14 <dfarrell07> #action dfarrell07 to bring idea to TAC to start having periodic, maybe monthly, meetings with projects that consume ODL to get feedback
17:40:12 <dfarrell07> #topic CII badging for ONAP ODL work
17:40:27 <dfarrell07> #info ONAP is doing lots of scanning to do CII badging
17:40:45 <dfarrell07> #info they have told us a number of times that they are picking up issues with ODL
17:40:56 <dfarrell07> #info they didn't get back to us with details of what they are seeing, per our request
17:41:07 <dfarrell07> #info the current email thread also doesn't have the detail we need
17:41:45 <dfarrell07> #link https://clm.opendaylight.org/assets/index.html ODL CLM should also show these issues
17:42:19 <dfarrell07> #info they have quite a few components that we don't care about, like DLUX, that are likely pulling in many problems
17:42:42 <dfarrell07> #info they also are on oxygen sr3, and oxygen sr4 is about to go out the door, then no more oxygen, so bit late for that version
17:44:03 <dfarrell07> #action skitt will follow-up on ONAP email regarding vulns
17:46:07 <dfarrell07> #info michael has sent one reply, but bounced, skitt will send properly to ONAP TSC list
17:52:46 <dfarrell07> #info there has also been discussion about hiring an intern to clean up CLM, but that will not happen right away
17:52:48 <dfarrell07> #topic infra
17:52:57 <dfarrell07> #info abelur gives updates about recent infra issues
17:53:15 <dfarrell07> #info just went to CentOS 7.6, which seems to have fixed some load issues
17:53:47 <dfarrell07> #info there also seems to be issue between a proxy and nexus, working on understanding
17:53:55 <dfarrell07> #info jobs with small files might be more impacted
17:53:57 <skitt> LuisGomez, integration/distribution is missing oxygen tags for sr1, sr2, sr3 and sr4
17:53:59 <dfarrell07> #undo
17:53:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2be1d90>
17:54:05 <skitt> LuisGomez, do you have the info necessary to add them?
17:54:10 <dfarrell07> #info jobs with many small files might be more impacted
17:54:15 <dfarrell07> #info workaround is to retrigger jobs
17:54:54 <dfarrell07> #info vexxhost team is kinda blocker at the moment, so no eta
17:55:34 <dfarrell07> #info javadocs jobs seem to be main jobs impacted, verify and publish, most other seem to be stable at this point
17:56:41 <dfarrell07> #info many small files are causing sockets to go into wait, then run out of sockets
17:57:15 <dfarrell07> #info tomp says he's seeing CSIT controller job fails, jamoluhrsen says that's likely the autorelease malformed URL issue
17:57:37 <LuisGomez> skitt, tags are there :)
17:57:50 <LuisGomez> have you done this: git fetch --all --tags --prune
17:57:56 <skitt> LuisGomez, yeah
17:58:02 <dfarrell07> #info if you see a mountain of red in jobs triggered from autorelease, keep this in mind
17:58:07 <skitt> LuisGomez, OK, a second run picks the tags up, thanks
17:58:32 <dfarrell07> #topic cookies
17:58:35 <dfarrell07> #endmeeting