17:00:13 <dfarrell07> #startmeeting tsc
17:00:13 <odl_meetbot> Meeting started Thu Dec 13 17:00:13 2018 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:13 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:25 <dfarrell07> XiongQuan: sorry, can you do that again?
17:00:35 <dfarrell07> #info TSC members please #info in
17:02:26 <abhijitk> #info abhijitk
17:03:14 <vishnoianil> #info Anil Vishnoi
17:03:22 <vishnoianil> #project openflowplugin
17:03:23 <jmorvay> #info jmorvay
17:03:29 <premsankar> #info premsankar
17:03:30 <jmorvay> #project netconf
17:03:36 <premsankar> #project coe
17:03:36 <zxiiro> #info Thanh Ha
17:03:48 <vorburger> #info vorburger
17:03:53 <vorburger> #project neutron
17:03:54 <abelur> #info abelur
17:04:08 <jamoluhrsen> #info jamoluhrsen
17:04:10 <vorburger> #project infrautils genius archetypes odlparent controller serviceutils
17:04:13 <XiongQuan> #info XiongQuan
17:04:16 <jamoluhrsen> #info shague via jamoluhrsen proxy
17:04:31 <LuisGomez> #info LuisGomez
17:04:48 <dfarrell07> #chair abhijitk
17:04:48 <odl_meetbot> Current chairs: abhijitk dfarrell07
17:05:04 <abhijitk> #topic TSC Chair Elections
17:05:11 <dfarrell07> #chair skitt rovarga_ premsankar LuisGomez vorburger jamoluhrsen
17:05:11 <odl_meetbot> Current chairs: LuisGomez abhijitk dfarrell07 jamoluhrsen premsankar rovarga_ skitt vorburger
17:05:18 <abhijitk> #info Reminder to vote
17:05:21 <faseelak> #info faseelak
17:05:35 <faseelak> #project genius serviceutils infrautils coe odltools
17:05:49 <dfarrell07> #info 9 of 13 TSC members have voted, go vote!
17:05:53 <LuisGomez> #project distribution
17:06:11 <abhijitk> #topic DetNet Project Proposal
17:06:17 <lori> #project lispflowmapping
17:06:32 <abhijitk> #link https://wiki.opendaylight.org/view/Project_Proposals:DetNet_Plugin
17:06:54 <dfarrell07> #topic project propsal netdev plugin
17:07:07 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:DetNet_Plugin proposal wiki
17:07:18 <dfarrell07> #info proposal has been up on the mailing list for more than two weeks
17:08:30 <dfarrell07> #info this is a IETF proposal, with implementation in ODL
17:09:05 <dfarrell07> #info basic idea seems to be around deterministic flows with some guarantees for flows
17:12:55 <dfarrell07> #info so for example might reserve data plane routes that don't change, or are aggregated
17:14:08 <dfarrell07> you can go ahead :)
17:14:17 <dfarrell07> Prem will write here and we can address at end
17:14:35 <premsankar> XiongQuan:  What would be the southbound protocol to talk with the devices?
17:15:34 <dfarrell07> #info seems like this project will be fairly large, will have many components inside of it, see diagram
17:17:08 <dfarrell07> #info so for example seems like will have topo manager inside this project, as well as some sb protocol, and will also have e2e managing service that does thinks like handle bandwidth guarantees
17:17:58 <dfarrell07> #info project will make use of ODL components like mdsal, netconf, restconf
17:18:17 <dfarrell07> #info so prem's question about what SBs project will use to manged devices is 'netconf'
17:18:49 <dfarrell07> #info dfarrell07 thinks this is exceptionally well thought-out proposal, very good details on the wiki
17:19:52 <premsankar> dfarrell07:  Looks like they also use the PCE and BGP-LS
17:20:06 <dfarrell07> premsankar: say it in the minutes please :)
17:20:19 * dfarrell07 is struggling to parse and make good minutes
17:20:26 <premsankar> #info Looks like they also use the PCE and BGP-LS
17:22:13 <dfarrell07> #info BGP-LS and PCE will be reused, they will use existing ODL projects
17:23:19 <dfarrell07> #info this seems like a very clear example of why ODL as a platform is useful - new research idea doesn't have to re-invent much, is reusing huge chunks of ODL
17:23:52 <dfarrell07> #info there are IETF docs about detailed usecases, but tldr seems to be "5G"
17:24:55 <dfarrell07> #info there are 5 initial committers, which is a nice number, enough for robustness but not absurd-many
17:26:13 <dfarrell07> #info all committers are from ZTE, but seems like they are working with other folks through IETF
17:27:12 <dfarrell07> #info prem asks how CSIT would work, if they need real devices
17:27:53 <dfarrell07> #info seems like they will use software emulation for tests initially and have some ideas about real devices later
17:29:42 <dfarrell07> #startvote Shall the TSC approve DetNet Plugin as a Self-Managed project in Incubation state? -1,0,+1
17:29:42 <odl_meetbot> Begin voting on: Shall the TSC approve DetNet Plugin as a Self-Managed project in Incubation state? Valid vote options are -1, 0, +1.
17:29:42 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:30:15 <abhijitk> #vote +1
17:30:16 <zxiiro> #vote +1
17:30:16 <jamoluhrsen> #vote +1
17:30:18 <LuisGomez> #vote +1
17:30:20 <premsankar> #vote +1
17:30:21 <jamoluhrsen> #vote +1 (for shague)
17:30:21 <odl_meetbot> jamoluhrsen: +1 (for shague) is not a valid option. Valid options are -1, 0, +1.
17:30:27 <jamoluhrsen> #vote +1
17:30:30 <abelur> #vote +1
17:30:34 <vorburger> #vote +1
17:30:39 <dfarrell07> 8
17:30:42 <faseelak> #vote +1
17:30:42 <dfarrell07> that carries
17:30:46 <dfarrell07> 9
17:30:56 <abhijitk> #endvote
17:30:56 <odl_meetbot> Voted on "Shall the TSC approve DetNet Plugin as a Self-Managed project in Incubation state?" Results are
17:30:56 <odl_meetbot> +1 (8): vorburger, LuisGomez, faseelak, premsankar, jamoluhrsen, zxiiro, abhijitk, abelur
17:31:24 <abhijitk> #agreed OpenDaylight TSC approves DetNet Plugin as a Self-Managed project in Incubation state
17:32:31 <dfarrell07> #info please reach out to helpdesk@opendaylight.org to add committers, get repos
17:33:36 <dfarrell07> #info they want to join for Neon, which is fine but they don't have much time
17:33:49 <dfarrell07> #undo
17:33:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x293df10>
17:34:01 <dfarrell07> #info they want to join the release after Neon, not Neon, so lots of time
17:34:21 <dfarrell07> #info since they are self-managed they can join the relase however they like, reach out to LuisGomez for help
17:34:25 <abhijitk> #topic Super committer Discussion
17:34:58 <abhijitk> #link https://git.opendaylight.org/gerrit/#/c/77837/ Proposal for the super committer
17:35:55 <dfarrell07> #info idea is to put more process around who can be a super committer for releng activities like bumping versions
17:36:04 <dfarrell07> #info that woud allow non-LF-admins to do this work
17:36:17 <dfarrell07> #info there are detailed docs on exactly when this power can be turned on
17:36:27 <abhijitk> #startvote Shall OpenDaylight have an official TSC Managed super committer list? -1,0,+1
17:36:27 <odl_meetbot> Begin voting on: Shall OpenDaylight have an official TSC Managed super committer list? Valid vote options are -1, 0, +1.
17:36:27 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:36:38 <dfarrell07> #info and there are detaile docs about tthe limits of when this can be used, for what
17:36:52 <LuisGomez> #vote +1
17:36:54 <premsankar> #vote +1
17:36:55 <zxiiro> #info the detailed docs also have a list of initial super committers
17:36:55 <abelur> #vote +1
17:36:56 <abhijitk> #vote +1
17:36:58 <faseelak> #vote +1
17:36:59 <jamoluhrsen> #vote +1
17:37:01 <vorburger> #vote +1
17:37:01 <zxiiro> #vote +1
17:37:11 <dfarrell07> 8
17:37:15 <vishnoianil> #vote 0
17:37:20 <jamoluhrsen> I don't know how to officially vote for shague?
17:37:29 <dfarrell07> #vote +1
17:37:40 <dfarrell07> #endvote
17:37:40 <odl_meetbot> Voted on "Shall OpenDaylight have an official TSC Managed super committer list?" Results are
17:37:40 <odl_meetbot> 0 (1): vishnoianil
17:37:40 <odl_meetbot> +1 (9): vorburger, LuisGomez, dfarrell07, faseelak, premsankar, jamoluhrsen, zxiiro, abhijitk, abelur
17:37:50 <dfarrell07> #info dfarrell07 vote was for sam hague
17:38:19 <abhijitk> #topic Fluorine DDF Retrospective Follow-up
17:38:31 <abhijitk> #undo
17:38:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2ae6e90>
17:38:38 <dfarrell07> #agreed the TSC approves  super-committer process as doc here
17:38:53 <dfarrell07> #undo
17:38:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2ae6f10>
17:38:56 <dfarrell07> #agreed the TSC approves  super-committer process as doc here https://git.opendaylight.org/gerrit/#/c/77837/
17:39:33 <abhijitk> #topic Governing Board Meeting Update
17:40:44 <arieladam> Fluorine Retrospective https://docs.google.com/document/d/16ssjcNRzP_uQr1HMZCkb_lc8gLeYNfqrGAI6XEw9Gko/edit#
17:44:05 <dfarrell07> #info We gave ODL update to Board, they like idea ot onboard new devs to kernel projects by trading training for support, might get help
17:44:41 <dfarrell07> #info We gave proposal on direct project representation to board, also well received
17:46:13 <dfarrell07> #info TF TAC vote is ongoing, dfarrell07 voted against because: 1. TF is single-vendor dominated and unhealthy in a variety if ways related to that; dfarrell07 thinks unlikely to be fixable 2. they are taking a pretty huge chunk of money from existing projects
17:46:56 <dfarrell07> #info there are a few very vocal supporting companies that have voted +1 and a ton of company reps who don't seem to really be paying attention but just vote +1 because it's easy/friendly
17:47:31 <dfarrell07> #info there are a fair number of people who haven't voted because don't want company to look bad, but have told dfarrell07 off-list they disapprove
17:48:15 <dfarrell07> #info Board vote hasn't happened yet, but dfarrell07 suspects will pass for same reason TAC vote will pass - lots of companies that aren't paying enough attention to know better
17:49:01 <dfarrell07> #info dfarrell07 was wrong on the vocal update about this passing already, thanks for correction phrobb/CaseyLF, notes above are right
17:50:13 <dfarrell07> #info Fluorine Retrospective
17:50:16 <dfarrell07> #undo
17:50:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b5fc10>
17:50:18 <abhijitk> dfarrell07: is the update done?
17:50:22 <dfarrell07> #topic Fluorine Retrospective
17:50:36 <dfarrell07> #link Fluorine Retrospective https://docs.google.com/document/d/16ssjcNRzP_uQr1HMZCkb_lc8gLeYNfqrGAI6XEw9Gko
17:50:37 <abhijitk> thx dfarrell07
17:50:42 <dfarrell07> abhijitk: np :)
17:57:39 <dfarrell07> #info lots of discussion about infra but dfarrell07 fails to take minutes
18:01:19 <dfarrell07> #vote Meeting next week? -1,0,+1
18:01:24 <jamoluhrsen> #vote +1
18:01:25 <dfarrell07> #startvote Meeting next week? -1,0,+1
18:01:25 <odl_meetbot> Begin voting on: Meeting next week? Valid vote options are -1, 0, +1.
18:01:25 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:01:28 <jamoluhrsen> #vote +1
18:01:36 <zxiiro> #vote 0
18:01:45 <premsankar> #vote 0
18:01:49 <LuisGomez> #vote 0
18:01:54 <dfarrell07> #vote 0
18:01:54 <abelur> #vote 0
18:02:02 <CaseyLF> #vote 0
18:02:03 <abhijitk> #vote 0
18:02:22 <arieladam> #vote 0
18:03:23 <dfarrell07> #endvote
18:03:23 <odl_meetbot> Voted on "Meeting next week?" Results are
18:03:23 <odl_meetbot> 0 (8): LuisGomez, dfarrell07, arieladam, abhijitk, premsankar, zxiiro, CaseyLF, abelur
18:03:23 <odl_meetbot> +1 (1): jamoluhrsen
18:03:43 <dfarrell07> #info we mostly don't care if meeting but CaseyLF talks us out of it at last moment
18:03:51 <dfarrell07> #info so no meeting next week
18:04:00 <dfarrell07> #info do things over email and respond
18:04:04 <dfarrell07> #topic cookies
18:04:07 <dfarrell07> #endmeeting