17:06:01 <rovarga> #startmeeting Kernel projects call
17:06:01 <odl_meetbot> Meeting started Tue Jan  8 17:06:01 2019 UTC.  The chair is rovarga. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:06:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:01 <odl_meetbot> The meeting name has been set to 'kernel_projects_call'
17:09:09 <rovarga> #info jmorvay asks about CDS persistence: can journal/snapshots be used to replicate data to another cluster instance?
17:09:48 <rovarga> #info that should be doable, assuming source and target clusters match in configuration (member names, etc.)
17:11:15 <rovarga> #info Tom mentions an online backup facility is available through cluster-admin service
17:12:03 <rovarga> #info jmorvay asks if snapshots contain the data tree
17:12:31 <rovarga> #info snapshots contain data tree contents plus all backend metadata -- all raft state, transaction state, etc.
17:14:14 <rovarga> #topic Fluorine SR2 readiness (for 2/7/2019)
17:14:46 <rovarga> #info odlparent-3.1.6 needs a multipatch test, which should be done tomorrow
17:15:04 <rovarga> #info then we need yangtools bump, which should take about a day to release
17:16:14 <rovarga> #topic Neon code freeze readiness (for 1/24/2019)
17:16:38 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-userfeatures-all-neon/
17:16:51 <LuisGomez> regression detected in basic CSIT netconf test
17:18:00 <rovarga> #info build #140, #142 and #144-148 are completely failing
17:18:33 <rovarga> #info jmorvay mentions we have had some code movement, but nothing that would be expected to regress
17:19:40 <rovarga> #action jmorvay to check what is going on
17:19:44 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-userfeatures-all-fluorine/
17:19:51 <LuisGomez> same job in fluorine
17:20:54 <rovarga> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/netconf-csit-1node-userfeatures-all-neon/148/odl_1/odl1_karaf.log.gz
17:21:57 <rovarga> #info Caused by: org.w3c.dom.DOMException: NAMESPACE_ERR: An attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
17:22:14 <rovarga> #info this looks like we are getting xerces implementation when we should not
17:23:30 <jmorvay> https://git.opendaylight.org/gerrit/#/c/77471/
17:23:57 <rovarga> #link https://git.opendaylight.org/gerrit/#/c/77471/
17:24:03 <rovarga> #info that should help the situation
17:25:40 <rovarga> #info we need odlparent-4.0.8 and the usual yangtools/mdsal propagation
17:27:40 <rovarga> #info reverted spotbugs upgrade, because it breaks downstreams
17:28:08 <rovarga> #link https://git.opendaylight.org/gerrit/#/c/79317/ is the final bit, awaiting review
17:28:21 <rovarga> #info we should be ready to release tomorrow
17:29:11 <rovarga> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-4.0.7 is the ongoing bump
17:31:50 <LuisGomez> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/openflowplugin-csit-1node-flow-services-all-oxygen/491/odl_1/odl1_karaf.log.gz
17:31:52 <rovarga> #info skitt will updated the outstanding patches to 4.0.8
17:32:02 <LuisGomez> this is happening in all oxygen CSIT jobs
17:32:08 <skitt> #info and push all the other necessary patches
17:32:26 <rovarga> #info oxygen is in a busted state, as it did not complete odlparent-3.1.5 bump, which was needed to fix the xtend issues
17:33:19 <rovarga> #info odlparent-3.1.6 includes jackson-databind fix, which has a couple CVEs attached to it
17:33:36 <rovarga> #info might be a cause to release Oxygen SR5
17:33:50 <rovarga> #action rovarga to raise this at security@/tsc@
17:34:58 <rovarga> #info mdsal-3.0.4 has two more patches outstanding
17:35:13 <rovarga> #link https://git.opendaylight.org/gerrit/79051 to add aggregate javadocs (for javadoc.io integration)
17:36:06 <rovarga> #link https://git.opendaylight.org/gerrit/75569 is optional, as it just brings about mdsal-trace without adding a feature
17:37:51 <rovarga> #info we still need to figure out how mdsal's odl-mdsal-trace and controller's odl-mdsal-trace will work together
17:38:22 <rovarga> #info rovarga suspects this will need the code to be published as artifacts from mdsal and then controller will do *something*
17:42:49 <rovarga> #info blueprint will need some more work, and should be fair for mdsal-3.0.5
17:43:03 <rovarga> #info mdsal-trace should go into 3.0.4, though
17:50:40 <rovarga> #info mdsal/controller blueprint structure is TBD, as we may just keep the forked copy
17:52:07 <rovarga> #action rovarga to ask around how controller->mdsal migration is going in downstreams
17:52:50 <rovarga> #topic tell-based CSIT
17:53:56 <rovarga> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/controller-csit-3node-ddb-expl-lead-movement-longevity-only-neon/21/robot-plugin/log.html.gz
17:54:12 <rovarga> #info we are getting a DeadTransactionException
17:54:52 <rovarga> #info which really should not be there, as we are expecting a stateful switchover
17:56:10 <rovarga> #info the transaction is in purged transactions
18:00:43 <rovarga> #info the transaction is from the default history, i.e. not chained
18:01:09 <rovarga> #action Tom to file an issue to track this
18:02:42 <rovarga> #endmeeting