16:01:48 <rovarga_> #startmeeting Kernel Projects Call
16:01:48 <odl_meetbot> Meeting started Tue Jun 25 16:01:48 2019 UTC.  The chair is rovarga_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:48 <odl_meetbot> The meeting name has been set to 'kernel_projects_call'
16:01:53 <rovarga_> #chair rovarga skitt
16:01:53 <odl_meetbot> Warning: Nick not in channel: rovarga
16:01:53 <odl_meetbot> Warning: Nick not in channel: skitt
16:01:53 <odl_meetbot> Current chairs: rovarga rovarga_ skitt
16:02:07 <rovarga_> #chair rovarga_ skitt
16:02:07 <odl_meetbot> Current chairs: rovarga rovarga_ skitt
16:02:19 <skitt> #topic Clustering in ODL
16:02:34 <skitt> #info the default datastore is the clustered datastore
16:02:51 <skitt> #info by default it replicates data across all nodes and provides access to the data across the cluster
16:04:10 <skitt> #info for any single piece of data, there is a single master in the cluster
16:04:19 <skitt> #info any modification goes through the master (leader)
16:04:33 <skitt> #info leaders are chosen per shard
16:05:24 <skitt> #info from the developer's perspective, if you write a transaction and submit it, you get a future which succeeds when the data is persisted
16:05:53 <skitt> #info in the current implementation, success is indicated when the data is stored in a majority of the nodes (cluster consensus) — but that's an implementation detail
16:06:15 <skitt> #info the contract is that when the future succeeds, the data is securely stored (barring operator error as always)
16:09:38 <skitt> #info if you kill the leader, before a transaction succeeds, the transaction will eventually fail
16:11:15 <skitt> #info after a transaction succeeds, before the success message was sent, the committing client will receive a failure, but the data is actually there
16:16:14 <skitt> #topic OpenFlowPlugin reviews
16:16:21 <skitt> #info rovarga_ has a few patches stuck in limbo
16:16:45 <skitt> #info Ericsson committers only +1 patches apparently, and when Anil doesn't merge patches nothing happens
16:17:22 <skitt> #action LuisGomez to bring this up in next Monday's call
16:18:04 <rovarga_> #topic https://jira.opendaylight.org/browse/MDSAL-456
16:18:23 <rovarga_> #link https://git.opendaylight.org/gerrit/82558
16:22:01 <rovarga_> #topic karaf-4.2.6
16:24:49 <skitt> #info with Karaf 4.2.6, there's a wiring issue between Akka persistence and LevelDB
16:25:03 <skitt> #info starting LevelDB first, and then persistence, works
16:25:11 <skitt> #info starting persistence on its own, then something else, works
16:25:18 <skitt> #info starting everything in one go fails
16:25:57 <skitt> #info triggering a bundle refresh later on fixes everything
16:26:17 <skitt> #info so it looks like feature:install with optional imports, skips a propagation path
16:26:35 <skitt> #info it feels like a resolver bug
16:28:29 <skitt> #action skitt to check whether Karaf 4.2.5 + the Equinox downgrade works with multipatch
16:34:31 <skitt> #topic MD-SAL simple patches
16:34:45 <skitt> #info rovarga_ merged a few of Michael's patches, the remaining ones need quite a lot of rework
16:36:00 <rovarga_> #topic archetypes
16:37:09 <skitt> #info we'll skip all the Fluorine SRs until SR3
16:37:16 <skitt> #info the first proper archetypes release will be 1.0.3
16:37:18 <rovarga_> #info fluorine jobs are suspended pending SR3 activities
16:47:26 <skitt> #endmeeting