16:02:17 <rovarga> #startmeeting Kernel Projects Call
16:02:17 <odl_meetbot> Meeting started Tue Jul  2 16:02:17 2019 UTC.  The chair is rovarga. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:17 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:17 <odl_meetbot> The meeting name has been set to 'kernel_projects_call'
16:02:23 <rovarga> #chair skitt rovarga
16:02:23 <odl_meetbot> Current chairs: rovarga skitt
16:02:48 <rovarga> #topic agenda
16:03:49 <rovarga> #info Actions support update
16:04:40 <rovarga> #info odlparent-6 (i.e. Magnesium)
16:04:51 <rovarga> #info stable/neon MRI update
16:07:19 <rovarga> #info reinstall clustering from scratch
16:07:38 <rovarga> #info administrative things
16:08:20 <rovarga> #topic  Actions support update
16:08:37 <rovarga> #info we have two trains: controller and netconf (in restconf)
16:08:52 <rovarga> #info reviewers requested
16:09:08 <rovarga> #action rovarga to add people on review
16:10:50 <rovarga> #action rovarga to send out the 'busy committers like this' rant
16:12:12 <rovarga> #info restconf patch by end of week
16:13:00 <rovarga> #info testtool magic
16:15:02 <rovarga> #link rovarga recently came across https://github.com/remkop/picocli
16:16:49 <rovarga> #info LuisGomez notes that *some* parameters are working, but not all and it takes some doing
16:18:13 <rovarga> #info we need a docs update to spell out how system tools are setting up testtool
16:21:34 <rovarga> #topic odlparent-6
16:21:51 <rovarga> #info java-11 required
16:21:57 <rovarga> #undo
16:21:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2bb1e10>
16:22:10 <rovarga> #info java-11 required? pending the TSC's final decision
16:22:39 <rovarga> #info probably will have karaf-4.3.0 with OSGi R7
16:22:45 <rovarga> #undo
16:22:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c39c50>
16:22:51 <rovarga> #info probably will have karaf-4.3.0 with OSGi R7, do we want that?
16:23:24 <rovarga> #info scala-2.13.0 available (with akka 2.5.x, 2.6.x)
16:24:47 <rovarga> #info forcing guava-28.0 is not fair
16:24:55 <rovarga> #Info checkstyle bump?
16:25:47 <rovarga> #info checkstyle/spotbugs are usually easily fixed up minor version bump changes
16:27:46 <rovarga> #agree update odlparent policy to say that minor patch can break build, but tests need to be kept working
16:29:24 <rovarga> #info removing jsr305 completely
16:30:04 <rovarga> #info we down to 4/5 downstreams using it, before Sodium there should be at most 2
16:30:40 <rovarga> #action create a 6.0.0 release in JIRA and will open issues for the changes we want to make
16:32:39 <rovarga> #info karaf-4.3.0 is probably going to be painful
16:32:52 <rovarga> #topic stable/neon MRI update
16:33:26 <rovarga> #info odlparent-4.0.11, yangtools-2.1.11, mdsal-3.0.9 is out
16:34:59 <rovarga> #link https://git.opendaylight.org/gerrit/#/q/topic:mri-neon-sr2
16:36:20 <rovarga> #info odlparent-5.0.2 would be nice
16:36:48 <skitt> https://git.opendaylight.org/gerrit/73686
16:37:46 <rovarga> #info yangtools is still doing some work for the next release, will roll out either 5.0.1 or 5.0.2 dependending on readiness
16:38:13 <rovarga> #topic reinstall clustering from scratch
16:38:40 <rovarga> #info it's just a reinstall of a single node
16:38:42 <LuisGomez> #link https://jira.opendaylight.org/browse/CONTROLLER-1626
16:40:45 <LuisGomez> #link https://docs.opendaylight.org/en/stable-neon/getting-started-guide/clustering.html#geo-distributed-active-backup-setup
16:41:02 <LuisGomez> POST  /restconf/operations/cluster-admin:add-replicas-for-all-shards
16:43:00 <rovarga> #info as a workaround, is it possible to add the old *system* as a new *cluster node*? it should be possible to add a new cluster member and delete the old one -- it's just that the reinstalled node would have a different name in ODL cluster
16:44:35 <rovarga> #topic general discussion
16:47:01 <rovarga> #info https://docs.google.com/spreadsheets/d/1CN-ACdIekRKMYRIuREIRALl6S8az7quAcQlRb3KeMJ8/edit#gid=650373173 looks a bit worrying
16:47:28 <rovarga> #link https://docs.google.com/spreadsheets/d/1CN-ACdIekRKMYRIuREIRALl6S8az7quAcQlRb3KeMJ8/edit#gid=650373173 looks a bit worrying
16:47:34 <rovarga> #link https://docs.google.com/spreadsheets/d/1CN-ACdIekRKMYRIuREIRALl6S8az7quAcQlRb3KeMJ8/edit#gid=588630221
16:48:48 <rovarga> #action rovarga to rever bgpcep/osgi patch
16:48:54 <rovarga> #undo
16:48:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2d5ea10>
16:48:57 <rovarga> #action rovarga to revert bgpcep/osgi patch
16:49:37 <rovarga> #info LuisGomez needs to refactor bgp tests
16:51:02 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-csit-1node-userfeatures-all-sodium/
16:52:36 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-csit-1node-throughpcep-all-sodium/
16:53:09 <LuisGomez> #info for the first link it should be just the patch revert
16:53:30 <LuisGomez> #info for the second link I have to go deep in the suite
16:54:57 <rovarga> #info last success was https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/bgpcep-csit-1node-throughpcep-all-sodium/65/
16:55:15 <rovarga> #info which was Mar 28, which is a loong time ago
16:55:29 <LuisGomez> Counter({'status: 204 content: ': 65535})' does not contain 'Counter({'pass': 65535})'
16:57:10 <rovarga> #link https://git.opendaylight.org/gerrit/#/c/64782/ was changed on Mar 26nd in bgpceep
16:58:07 <rovarga> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/bgpcep-csit-1node-throughpcep-all-sodium/215/odl_1/odl1_karaf.log.gz
16:58:19 <rovarga> 2019-07-01T15:26:51,544 | WARN  | pool-24-thread-1 | TopologyStatsProviderImpl        | 259 - org.opendaylight.bgpcep.pcep-topology-stats - 0.12.0 | Failed to prepare Tx for BGP stats update
16:58:20 <rovarga> java.util.ConcurrentModificationException: null
16:58:22 <rovarga> at java.util.HashMap$HashIterator.nextNode(HashMap.java:1445) ~[?:?]
16:58:23 <rovarga> at java.util.HashMap$ValueIterator.next(HashMap.java:1474) ~[?:?]
16:58:25 <rovarga> at java.util.AbstractCollection.toArray(AbstractCollection.java:141) ~[?:?]
16:58:26 <rovarga> at com.google.common.collect.ImmutableList.copyOf(ImmutableList.java:258) ~[36:com.google.guava:27.1.0.jre]
16:58:28 <rovarga> at org.opendaylight.bgpcep.pcep.topology.provider.AbstractTopologySessionListener.getDelegatedLspsCount(AbstractTopologySessionListener.java:596) ~[?:?]
16:58:42 <rovarga> which looks like a locking problem
16:58:48 <rovarga> or nesting problem
16:58:55 <LuisGomez> test runs this command: bash -c "cd /tmp; taskset 0x00000001 python updater.py --workers '64' --odladdress '10.30.170.69' --user 'admin' --password 'admin' --scope '' --pccaddress '10.30.170.38' --pccs '1' --lsps '65535' --hop '8.8.8.8/32' --timeout '900' --refresh '0.1' --reuse 'False' 2>&1"
16:59:07 <LuisGomez> and it returns:
16:59:08 <LuisGomez> took 153.47883296
16:59:09 <LuisGomez> Counter({'status: 204 content: ': 65535})
17:02:01 <rovarga> #link https://jira.opendaylight.org/browse/BGPCEP-875 tracks the CME
17:02:11 <rovarga> #endmeeting