#opendaylight-meeting: tsc

Meeting started by abhijitk at 16:57:45 UTC (full logs).

Meeting summary

  1. Roll Call and Agenda Bashing (abhijitk, 16:58:59)
    1. rovarga (rovarga, 16:59:09)
    2. faseelak_ (faseelak_, 16:59:14)
    3. LuisGomez (LuisGomez, 16:59:41)
    4. skitt (skitt, 16:59:44)
    5. Happy New Year Everyone! (abhijitk, 16:59:51)
    6. shague (skitt, 16:59:56)
    7. Daniel Farrell for Anil Belur (he asked me on IRC but I think forgot to send email) (dfarrell07, 17:00:09)
    8. Prem (premsankar, 17:00:32)
    9. jmorvay (jmorvay, 17:01:49)
    10. Anil Vishnoi (vishnoianil, 17:02:50)

  2. ODLParent Updates (faseelak_, 17:03:26)
    1. Thanh Ha (zxiiro, 17:05:14)
    2. rovarga mentions that using odlparent 4.0.8 he was able to build netconf with Java 11 (lori, 17:06:40)
    3. bump to odlparent 4.0.5 completed (faseelak_, 17:07:39)
    4. the bump to 4.0.7 is the conclusion of the bump to 4.0.3 started before the break, which revealed a number of problems which rovarga took care of (skitt, 17:07:40)

  3. CSIT test reduction for infra improvements (abhijitk, 17:07:45)
    1. odlparent-4.0.5 was a christmas present, making xtend work, upgrading karaf to 4.2.2 and bringing in a bunch of additional wrapper features (rovarga, 17:07:58)
    2. odlparent-4.0.7 fixes SFT with Java 11 to the point where yangtools/mdsal/controller pass with trivial patches (most of them already merged up) (rovarga, 17:08:37)
    3. odlparent-4.0.8 will bring in fixes to BouncyCastle intregation, which fixes aaa with Java 11 (rovarga, 17:09:05)
    4. Some test cleanup happen as Oxygen tests will be removed (abhijitk, 17:09:48)
    5. hence the lookahead is that odlparent-4.0.8 integration will mean core platform is Java-11 ready and we can start having a conversation about how to leap to that (rovarga, 17:10:25)
    6. Some other cleanup can be done with removal of tests of inactive projects (abhijitk, 17:10:34)
    7. we need to reduce our infra costs very substantially as part of budget this year (dfarrell07, 17:11:25)
    8. dfarrell07 mentions the next step should be start an intern project proposal (abhijitk, 17:11:42)
    9. ACTION: dfarrell07 will write intern project proposal for infra cost reductions (dfarrell07, 17:14:07)
    10. btw. we are trackign https://issues.apache.org/jira/browse/SUREFIRE-1574, which will help with verify/merge job speed (rovarga, 17:14:52)
    11. int/test/releng folks will tag-team mentoring infra reduction intern (dfarrell07, 17:14:57)

  4. OpenDaylight Training Content (abhijitk, 17:15:10)
    1. Pavan presenting the ODL Training Content document (abhijitk, 17:19:04)
    2. Pavan, as a first pass for January, is working on cleaning up the existing SDN training material (faseelak_, 17:21:02)
    3. Pavan says several portions of the document needs a rework, as there were a lot of sections talking about DLUX UI which is now deprecated and removed (faseelak_, 17:27:39)
    4. dfarrell07 suggests we should consider linking the training materials to docs project (faseelak_, 17:30:50)
    5. dfarrell07 thinks we should get details about where these docs are hosted, what infra is connected to them, consider ways we can harmonize/improve (dfarrell07, 17:35:38)
    6. there was discussion about some training labs going out of date because of packages changing. those labs could be made into jobs and run periodically to test, show working examples to students (dfarrell07, 17:36:19)
    7. getting the training doc source more accessible to generally community will result in option to keep it more up-to-date (dfarrell07, 17:36:51)
    8. ACTION: Pavan to connect Abhijit/others to Coop for a TWS session (abhijitk, 17:42:08)

  5. Releases (abhijitk, 17:49:20)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 (abhijitk, 17:49:35)
    2. ACTION: CaseyLF to follow up LF IT report about the infrastructure issues we've had at the beginning of December 2018 (rovarga, 17:58:15)

  6. Cookies (abhijitk, 17:58:34)


Meeting ended at 17:58:45 UTC (full logs).

Action items

  1. dfarrell07 will write intern project proposal for infra cost reductions
  2. Pavan to connect Abhijit/others to Coop for a TWS session
  3. CaseyLF to follow up LF IT report about the infrastructure issues we've had at the beginning of December 2018


Action items, by person

  1. dfarrell07
    1. dfarrell07 will write intern project proposal for infra cost reductions
  2. UNASSIGNED
    1. Pavan to connect Abhijit/others to Coop for a TWS session
    2. CaseyLF to follow up LF IT report about the infrastructure issues we've had at the beginning of December 2018


People present (lines said)

  1. abhijitk (17)
  2. rovarga (10)
  3. faseelak_ (9)
  4. dfarrell07 (8)
  5. skitt (5)
  6. odl_meetbot (5)
  7. vishnoianil (3)
  8. jmorvay (2)
  9. LuisGomez (2)
  10. premsankar (2)
  11. lori (2)
  12. zxiiro (1)


Generated by MeetBot 0.1.4.