#opendaylight-meeting: tsc

Meeting started by abhijitk at 16:00:01 UTC (full logs).

Meeting summary

  1. Agenda Bashing and Roll Call (abhijitk, 16:00:27)
    1. https://wiki.opendaylight.org/view/File:Antitrust_Slide.pptx Antitrust policy (abhijitk, 16:01:03)
    2. Thanh Ha (zxiiro, 16:01:25)
    3. LuisGomez (LuisGomez, 16:01:27)
    4. jamoluhrsen (jamoluhrsen, 16:01:58)
    5. abhijitk (abhijitk, 16:02:35)
    6. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda (abhijitk, 16:02:47)
    7. Anil Vishnoi #project openflowplugin, ovsdb (vishnoianil_, 16:03:20)
    8. Anil Belur (abelur, 16:03:41)
    9. danieldelarosa (danieldelarosa, 16:04:24)

  2. Releases (abhijitk, 16:05:04)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 (abhijitk, 16:05:19)
    2. We are on Sodium Final Checkpoint today (abhijitk, 16:06:04)
    3. rovarga says MDSAL 4.0.4 needs to be integrated into Sodium (abhijitk, 16:08:51)
    4. rovarga (rovarga, 16:12:30)
    5. https://jira.opendaylight.org/browse/INTDIST-105 <-- blocker bug to get mdsal 4.0.4 integrated to sodium release (jamoluhrsen, 16:13:50)
    6. ACTION: rovarga to follow up on Jira rant/workflows (rovarga, 16:21:52)
    7. Neon SR2 signoff in process (abhijitk, 16:23:19)

  3. Openjdk{8,11} support for Sodium and Magnesium (abhijitk, 16:24:23)
    1. Group discussing suggestions from zxiiro, rovarga around job groups and verify (abhijitk, 16:30:01)
    2. Broad approval around zxiiro suggestions (abhijitk, 16:32:44)
    3. zxiiro volunteers to implement his suggestions (abhijitk, 16:32:58)
    4. there are really two classes of jobs -- 'production' and 'verify', where 'production' affects -merge and -stage jobs (and there can only be 1 version), while verify really is about multiple versions and affects -verify and CSIT jobs (rovarga, 16:33:22)
    5. the idea is to hhave separate per-JDK groups, i.e. odl-maven-jobs-jdk11, with odl-maven-jobs being jdk8-implied (rovarga, 16:35:00)

  4. Self-service release process follow-up (abhijitk, 16:35:38)
    1. abelur says all bits are in place for this - but needs some optimizations (abhijitk, 16:36:09)
    2. ACTION: zxiiro to follow up with job group refactor to support jdk11 merge/release jobs (rovarga, 16:36:12)
    3. https://docs.releng.linuxfoundation.org/projects/global-jjb/en/latest/jjb/lf-release-jobs.html (abelur, 16:37:48)
    4. https://jira.linuxfoundation.org/browse/RELENG-1914 (rovarga, 16:46:37)
    5. Casey's escalation went unheeded for two weeks (rovarga, 16:46:52)
    6. rovarga is not happy (at all!) about LF engagement with projects and transparency (rovarga, 16:53:34)
    7. ACTION: CaseyLF to share LFN single 'get-invovled' page :) (rovarga, 16:59:01)

  5. Cookies (abhijitk, 17:21:50)


Meeting ended at 17:22:05 UTC (full logs).

Action items

  1. rovarga to follow up on Jira rant/workflows
  2. zxiiro to follow up with job group refactor to support jdk11 merge/release jobs
  3. CaseyLF to share LFN single 'get-invovled' page :)


Action items, by person

  1. rovarga
    1. rovarga to follow up on Jira rant/workflows
  2. zxiiro
    1. zxiiro to follow up with job group refactor to support jdk11 merge/release jobs


People present (lines said)

  1. abhijitk (22)
  2. rovarga (15)
  3. zxiiro (10)
  4. jamoluhrsen (6)
  5. odl_meetbot (4)
  6. abelur (4)
  7. vishnoianil_ (1)
  8. danieldelarosa (1)
  9. LuisGomez (1)


Generated by MeetBot 0.1.4.