14:59:20 <shague> #startmeeting NetVirt Weekly 07/18/17
14:59:20 <odl_meetbot> Meeting started Tue Jul 18 14:59:20 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:20 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_07_18_17'
14:59:33 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:28 <vthapar> #info Vishal
15:03:52 <shague> #topic Review existing action items
15:04:07 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_07_11_17/opendaylight-netvirt-netvirt_weekly_07_11_17.2017-07-11-15.01.html
15:04:32 <skitt> #info skitt
15:04:42 <vpickard> #info vpickard
15:04:45 <afredette> #info Andre Fredette
15:04:45 <janki> #info Janki
15:04:45 <aswinsuryan> #info Aswin Suryanarayanan
15:04:49 <mattw4> #info Matt Welch
15:04:51 <sridharg> #info Sridhar Gaddam
15:05:18 <vpickard> #info odlparent 2.0.2 patches merged to netvirt
15:05:23 <shague> #topic karaf 4
15:05:46 <daya_k> #info daya_k
15:06:10 <shague> #thanh still working on adding netvirt andother projects to int/distro
15:06:43 <shague> #info dhcp config changes
15:07:11 <shague> #action vthapr still looking if changes are needed
15:07:42 <shague> #info vthapar has different solution to use neutron changes instead
15:08:44 <shague> #info vthapar to discuss at next neutron northbound meeting
15:10:08 <shague> #info venkat done list bugs NEC is tracking
15:10:44 <shague> #info need to triage those bugs
15:11:08 <vpickard> #topic csit exceptions
15:11:43 <shague> #info 5 new exceptions found
15:12:19 <vpickard> #info janki will take 8860
15:19:36 <shague> #action janki to add test cases to bug-8684
15:22:45 <shague> #info should we freeze code until all exceptions are cleared
15:22:50 <shague> #link https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=82037 exception list
15:23:22 <shague> #info merge excpetion related patches and reevaluate list
15:25:00 <shague> #link https://bugs.opendaylight.org/show_bug.cgi?id=8346
15:25:13 <shague> #info rebase and reun csit on patch. it might help with the sporadic failures
15:26:41 <shague> #info likely good to merge patch even if it doesn't help excpetion, but adds other pros
15:28:16 <shague> #topic eos deprecated
15:28:19 <shague> #link https://lists.opendaylight.org/pipermail/ovsdb-dev/2017-July/004368.html
15:28:42 <shague> #info vthapar: can we get signoff from mdsal to fix two existing bugs before migrating to CSS
15:29:33 <shague> #info need to understand how much work it will take to move to CSS, initial feel is it shouldnt be too much
15:29:48 <vthapar> #info need to come up with plan if we want to move to CSS in Nitrogen
15:30:56 <shague> #info to move to css the two bugs must be fixed
15:31:19 <shague> #action anil to track eos deprecation and two css bugs
15:32:28 <shague> #topic deprecate transparent
15:32:45 <shague> #info stateful andlearn work well now so transparent doesn't add much value
15:33:57 <shague> #info are there other orchestrations beyond Openstack that could use transparent
15:34:33 <shague> #info afredette there might be people using ovs offload
15:37:06 <shague> #info keep thread open until to kow about other orchestrations
15:37:40 <shague> #info does deprecation require the one release deprecate process
15:39:10 <shague> #info csit needs to have tests for using the disable-port security
15:39:26 <shague> #info aswin: says dhcp ports do ahve port-security disabled
15:39:43 <shague> #info sridharg tempest has tests to cover scenario
15:39:59 <shague> #info not running those tempest tests currently, need to enable
15:40:21 <shague> action jamoluhrsen to look at enabling tests
15:40:28 <shague> #action jamoluhrsen to look at enabling tests
15:41:44 <shague> #topic jamo thinks we might have some regressions in carbon sr1
15:42:01 <shague> #info new sporadic failures popping
15:42:51 <shague> #action jamoluhrsen identify new failing tests
15:45:33 <shague> #topic version matrix
15:46:29 <shague> #info venkat test carbon and ocata
15:47:08 <shague> #info venkta use osp11
15:47:15 <shague> #info venkat use osp11
15:47:36 <shague> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2017-July/005030.html
15:48:10 <vpickard> #info above link is test matrix coverage for ODL and Openstack releases
15:48:11 <shague> #info no pike jobs currently
15:48:31 <shague> #info do we wait for pike or just use openstack master
15:50:26 <shague> #info master jobs will likely fail, but it is good to ahve jobs running for visibility
15:50:58 <shague> #action shague followup with isaku on networking-odl jobs
15:52:12 <shague> #topic can snat conntrack be enabled as default
15:52:46 <shague> #info aswin: there is one patch still open
15:52:54 <shague> #link: https://git.opendaylight.org/gerrit/56709 gre patch
15:53:19 <shague> #info daya_k need a job in csit still using controller snat
15:54:12 <shague> #info the current stateful job meets the needs, there is a new snat contrack job
15:56:08 <shague> #info daya_k learn mode can be removed
15:57:13 <shague> #action start thread on list to finalize
15:57:39 <shague> #topic vpickard:l2gw commands not recognized in netvirt csit - plugin looks correct
15:59:28 <shague> #info gvrangan thinks there might be an openstack cli issue
16:00:13 <shague> #info use the ssh workaround that was added recently to run commands from different vm
16:01:16 <shague> #info openstack cli might not have the l2gw commands
16:01:48 <shague> #info
16:01:49 <shague> 16:16:18.415 INFO Running command 'neutron l2-gateway-list -f yaml 2>&1'.
16:01:51 <shague> 16:16:18.650 INFO ${rc} = 1
16:01:52 <shague> 16:16:18.650 INFO ${output} = neutron CLI is deprecated and will be removed in the future. Use openstack CLI instead.
16:01:54 <shague> Unknown command [u'l2-gateway-list', u'-f', u'yaml'
16:02:49 <shague> #action gvrangan to find workaround
16:02:55 <vpickard> #action venkat to check on neutronclient for netvirt hwvtep csit
16:03:48 <vpickard> #action gvrangan to check on neutronclient for netvirt hwvtep csit failures for l2-gateway-list command not found
16:07:28 <shague> #endmeeting