15:01:55 <shague> #startmeeting NetVirt Weekly 08/22/17
15:01:55 <odl_meetbot> Meeting started Tue Aug 22 15:01:55 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:55 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_08_22_17'
15:02:10 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:30 <vthapar> hmm... strange, I was in netvit meting with vivek an just got booted, what is meeting id?
15:02:38 <vthapar> #info Vishal
15:02:46 <vpickard> mine says waith for host to start meeting
15:03:14 <vthapar> same here, I saw Victor and vivekanandan in that room before I got booted
15:03:32 <vthapar> shague: did you start some other meeting?
15:03:34 <vpickard> yes, I joined briefly, then was disconnectd
15:03:40 <vpickard> now, cant get in
15:03:54 <vthapar> vpickard: same here
15:04:52 <shague> vthapar: yeah, I was over in genius meeting... netvirt one shoud lbe good now
15:04:55 <vthapar> vpickard: am in now
15:05:03 <vpickard> vthapar: same. thanks
15:06:30 <Hanamantagoud> #info Hanamantagoud
15:08:12 <shague> #topic Review existing action items
15:08:16 <daya_k> #info daya_k
15:08:40 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_08_08_17/opendaylight-netvirt-netvirt_weekly_08_08_17.2017-08-08-14.59.html
15:08:53 <vpickard> #info Vic
15:09:03 <aswinsuryan> #info Aswin
15:10:11 <shague> #topic jamoluhrsen shague add config option to csit for mdsal config for timeout issue
15:11:27 <jamoluhrsen> #action jamoluhrsen to try another job with the tell based config in sandbox to make sure it works
15:11:28 <shague> #topic viveknarasimhan kiran identify single router patches
15:12:12 <shague> #info vivek: patches landed but not merged
15:12:53 <shague> #action vivek to send list of patches
15:13:24 <shague> #info patches can go in for nitrogen sr1
15:15:35 <viveknarasimhan> #info viveknarasimhan
15:15:36 <viveknarasimhan> https://git.opendaylight.org/gerrit/62136   https://git.opendaylight.org/gerrit/62087
15:15:49 <shague> #link https://git.opendaylight.org/gerrit/62136
15:16:00 <shague> #link  https://git.opendaylight.org/gerrit/62087
15:18:12 <shague> #topic carbon sr2
15:19:49 <shague> #info controller oom patch is breaking ha and holding up release
15:20:19 <shague> #topic csit exceptions
15:20:43 <jamoluhrsen> #action jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
15:22:47 <shague> #info bug-8953: kiran: found issue in external network csit
15:23:45 <shague> #info datastore for physnet1 network is not being cleaned up
15:25:24 <shague> #action viveknarasimhan_ kiran to investigate why mdsal is not removing the network
15:25:42 <shague> #info viveknarasimhan_ mentions patch that might be able to help with issue
15:27:02 <shague> #link https://bugs.opendaylight.org/show_bug.cgi?id=9013
15:27:13 <shague> #info need to work with genius to fix
15:28:09 <viveknarasimhan_> #viveknarasimhan joining again
15:28:32 <sridharg> #info Sridhar Gaddam
15:28:33 <shague> #link https://bugs.opendaylight.org/show_bug.cgi?id=7826
15:29:06 <shague> #info swati wip on patch
15:29:18 <shague> #action shague send email to viveknarasimhan_
15:29:51 <shague> #info https://bugs.opendaylight.org/show_bug.cgi?id=7830
15:30:22 <shague> #info viveknarasimhan_: difficult to troubleshoot, needs more investigation
15:30:40 <shague> #info duplicate attempts to modify the same flow id
15:33:16 <shague> #topic exception fail test
15:33:42 <shague> #info jamoluhrsen: about to add test to enable failing if exceptions found during a test
15:34:27 <shague> #info add check during test teardown debug
15:35:36 <shague> #topic downstream patches to upstream
15:35:43 <shague> #info some patches merged
15:35:56 <shague> #info two acl patches remaining
15:37:09 <shague> #info are some of the fixes blockers and needed for sr2?
15:37:34 <shague> #action shague to work with viveknarasimhan_ to identify any for post carbon sr2
15:38:29 <shague> #topic dualstack branching
15:38:49 <shague> #info three large patch stacks
15:39:13 <shague> #info ps1: single router
15:39:44 <shague> #info ps2: v4 and v6 routers
15:39:57 <shague> #info ps3: enable access to extrnal router
15:40:16 <shague> #info ps1 is under review
15:40:39 <shague> #info ps2 and ps3 might need a topic branch
15:41:28 <shague> #action viveknarasimhan_ to talk with 6wind team on plan for ps2 and ps3
15:42:18 <shague> #info csit patches have been raised
15:45:30 <shague> #topic bug 8823
15:45:33 <shague> #link https://git.opendaylight.org/gerrit/#/c/61168/
15:46:14 <shague> #info blocker for carbon sr2
15:47:48 <shague> #info need genius devs to review
15:48:23 <shague> #info vthapar concerned with performance
15:49:49 <shague> #info patch removes batching and migth lead to performance issues
15:50:41 <shague> #action vthapar to work with gvrangan_odl on solution
15:51:46 <shague> #topic yamahata openstack is at end of Pike cycle
15:52:06 <shague> #info yamahata: jobs are unstable
15:52:15 <shague> #info what branch should be used
15:52:42 <yamahata> http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate?panelId=7&fullscreen
15:54:10 <shague> #info sync carbon with pike
15:55:22 <shague> #info pike releases in two weeks. ideally issues should be fixed by then, otherwise by queens early cycle - 1 or 2 months
15:55:51 <shague> #link http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate?panelId=7&fullscreen
15:58:19 <shague> #topic 3node csit
15:59:23 <shague> #info downstream ha testing looks good - what is different compared to upstream failing tests
15:59:38 <shague> #info vthapar mentions adding cpu logging
16:00:43 <shague> #info vthapar asks about haproxy and shard configuration
16:01:53 <shague> #info viveknarasimhan_ downstream doesn't use load balancing
16:02:28 <shague> #info v1 and v2 are both used in upstream
16:02:40 <shague> #info viveknarasimhan_ should only use v2 in upstream
16:03:39 <shague> #action gvrangan_odl add the shard and leader debugging to tests
16:04:02 <shague> #action vthapar gvrangan_odl work offline on how to collect debugging
16:05:05 <shague> #info vthapar asks how to know when ODL is up and ready for tests
16:07:33 <shague> #endmetting
16:07:38 <shague> #endmeeting