15:01:29 <shague> #startmeeting NetVirt Weekly 08/29/17
15:01:29 <odl_meetbot> Meeting started Tue Aug 29 15:01:29 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:29 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_08_29_17'
15:01:41 <daya_k> #info daya_k
15:01:42 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:05 <daya_k> #info daya_k
15:03:06 <Hanamantagoud> #info Hanamantagoud
15:03:44 <shague> #topic Review existing action items
15:03:55 <jamoluhrsen> #info jamoluhrsen
15:04:37 <shague> #topic pre created bridge issues
15:04:54 <shague> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2017-August/005369.html thread
15:05:49 <vpickard> #info Vic
15:06:12 <aswin__> #info Aswin
15:06:28 <shague> #info timing issues where patch ports created stomp on previous ports in mdsal
15:07:28 <shague> #info jhershbe: can ODL take ownership of br-int?
15:08:04 <shague> #info jhershbe: external entities cannot change br-int properties after this.
15:15:30 <shague> #info can csit be updated to test scenario
15:15:41 <shague> #info add br-int before devstack starts
15:16:02 <shague> #action daya_k to review jhershbe proposal
15:16:10 <shague> #action jhershbe work on patch
15:16:37 <shague> #action jamoluhrsen jhershbe look at adding csit test case
15:17:10 <Kiran_> #info Kiran
15:21:05 <shague> #topic [wip] jamoluhrsen to try another job with the tell based config in sandbox to make sure it works
15:21:16 <shague> #info many failures with changed setting
15:21:30 <jamoluhrsen> #link https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-ocata-jamo-upstream-stateful-nitrogen/ <-- 1 node job with tell based
15:21:54 <jamoluhrsen> #link https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-3node-openstack-ocata-jamo-upstream-stateful-nitrogen/ <-- 3node tell based job
15:21:58 <shague> #action jamoluhrsento reply on thread for debugging
15:22:16 <shague> #topic [wip] vivek to send list of patches for single router to merge
15:22:39 <shague> #info [done]
15:22:53 <shague> #topic [wip] jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
15:23:05 <shague> #action [wip] jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
15:23:11 <shague> #topic [wip] viveknarasimhan_ kiran to investigate why mdsal is not removing the network. physnet1 network is not being cleaned up
15:24:30 <shague> #info csit tests running for patch
15:24:32 <shague> #link https://git.opendaylight.org/gerrit/62186
15:26:17 <shague> #info need to investigate why oxygen tests are failing
15:27:28 <shague> #topic [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2
15:29:31 <shague> #info vivek working on list
15:29:42 <shague> #action [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2
15:29:58 <shague> #info vivek looking at l2gw and elan patches
15:30:14 <shague> #topic [wip] viveknarasimhan_ to talk with 6wind team on plan for ps2 and ps3, do we need a topic branch they can maintain?
15:30:32 <shague> #info a branch is requested for the patch sets 2 and 3
15:32:41 <shague> #action vivek to followup on if branch is needed
15:38:05 <shague> #info need to fix aclservice npe to make progress on master
15:39:50 <shague> #link https://git.opendaylight.org/gerrit/#/q/topic:l3vpn-dual-stack-internet
15:40:18 <shague> #topic [wip][agenda] vthapar to work with gvrangan_odl on solution for bug-8823 - auto tunnels and batching
15:41:31 <shague> #topic dhcp port allocation feature breaks sr-iov usecase
15:41:51 <shague> #info feature is in carbon sr2 and nitrogen
15:42:46 <shague> #info likely not a blocker since neutron dhcp agent is the default and does not have problem
15:43:08 <shague> #topic [wip][agenda] vthapar to work with gvrangan_odl on solution for bug-8823 - auto tunnels and batching
15:43:40 <shague> #info discuss during genius call
15:43:43 <viveknarasimhan> #info viveknarasimhan
15:43:54 <shague> #topic [wip] gvrangan_odl add the shard and leader debugging to tests - needed for 3node testing
15:44:17 <shague> #info gvrangan__odl to push patch later in week
15:44:36 <shague> #topic [wip] vthapar gvrangan_odl work offline on how to collect debugging
15:46:12 <shague> #topic hardware offload support for openvswitch - https://git.opendaylight.org/gerrit/#/c/60259/
15:50:27 <shague> #info odl will only process nw_odl marked ports
15:50:52 <shague> #info moshe patch removes the check for these vnic types
15:51:13 <shague> #link https://review.openstack.org/#/c/448536/ openstack patch
15:54:59 <shague> #info daya_k: l2gw dhcp usecase requires the vnic type check
16:02:59 <shague> #action moshe to add spec
16:03:38 <shague> #action spec fo acl reflection
16:03:48 <shague> #link https://trello.com/c/lDeLcKB1/39-spec-for-acl-change-reflection-on-existing-communication
16:04:18 <shague> #info aswin__ spec looks good, minor comments
16:07:35 <shague> #topic csit:exceptions
16:07:54 <shague> #action shague work with vorburger to add logs for bug-8860
14:24:22 <gvrangan> shague, jamoluhrsen Pike seems to work https://logs.opendaylight.org/sandbox/jenkins091/netvirt-csit-1node-openstack-pike-upstream-stateful-snat-conntrack-nitrogen/4/log.html.gz
14:25:47 <shague> gvrangan: awesome
14:26:00 <gvrangan> only L2 tests for now
14:26:18 <gvrangan> I think more delay needs to be added to check IP Addresses tests in al lthe suites
14:27:27 <shague> gvrangan: what changes did you make? in Jamo's job the vif port attachment failed so we don't even get to a p[oint where we wait for the vm to get an ip
14:27:39 <gvrangan> it failed in mine too....
14:27:54 <gvrangan> has to modify the vif_plugging_error_fatal as False
14:28:01 <gvrangan> in compute nodes nova.conf
14:28:32 <gvrangan> [DEFAULT]
14:28:33 <gvrangan> vif_plugging_timeout = 300
14:28:33 <gvrangan> vif_plugging_is_fatal = False
14:28:46 <shague> oh, that isn't good though right? Somehow during l3 I guess it really plugged, but we have no idea to know truthfully
14:31:30 <gvrangan> yeah...I was guessing it probably retries
14:31:51 <gvrangan> Let me analyze a little more
14:21:13 <shague> #endmeeting