15:02:26 <shague> #startmeeting NetVirt Weekly 10/24/17
15:02:26 <odl_meetbot> Meeting started Tue Oct 24 15:02:26 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:26 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_10_24_17'
15:02:41 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:43 <shague> #topic Review existing action items
15:02:51 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_17_17/opendaylight-netvirt-netvirt_weekly_10_17_17.2017-10-17-15.01.html
15:03:18 <shague> #info [Review previous minutes](https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_17_17/opendaylight-netvirt-netvirt_weekly_10_17_17.2017-10-17-15.01.html)
15:03:59 <vthapar> #info Vishal
15:04:15 <jamoluhrsen> #info jamoluhrsen
15:04:22 <vpickard> #info Vic
15:05:26 <janki> #info Janki Chhatbar
15:05:28 <shague> #topics siva add bug if needed for ipv6 and clustering issues
15:05:32 <Hanamantagoud> #info Hanamantagoud
15:05:49 <shague> #info siva to report bug
15:05:52 <jhershbe> #info jhershbe
15:06:33 <shague> #info sridharg to meet with e/// team to dicsuss changes
15:06:51 <shague> #topic shague to look at https://bugs.opendaylight.org/show_bug.cgi?id=9149 [jira](https://jira.opendaylight.org/browse/NETVIRT-905) - unable to reproduce in latest jobs
15:07:06 <sridharg> #info Sridhar Gaddam
15:07:33 <shague> #action jamoluhrsen to doublecheck
15:07:44 <daya_k> #info daya_k
15:07:45 <jamoluhrsen> #action jamoluhrsen to doublecheck bug 9149
15:07:46 <shague> #topic jamoluhrsen, shague, Hanamantagoud, kiran to start email with openflowplugin - [thread](https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-October/007746.html)
15:08:22 <shague> #topic shague initial triage at 3node tests - no progress yet
15:08:36 <shague> #topic janki need to look at tempest test case - initial triage and root cause found [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-October/005683.html)
15:09:22 <shague> #info janki found config issue needed for the one failing test
15:12:31 <jamoluhrsen> shague, janki: yes it's happening in queens:  https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/netvirt%20csit/job/netvirt-csit-1node-openstack-queens-upstream-stateful-nitrogen/60/robot/
15:13:36 <shague> #topic https://trello.com/c/iD2fOfF1/16-nitrogen-release-planning - SR1 10/26/17
15:13:58 <janki> jamoluhrsen, ack
15:14:08 <shague> #topic Jira migration is complete
15:20:24 <shague> #topic Spec reviews should include CSIT updates as mandatory. Code should not merge until CSIT tests are written.
15:21:41 <shague> #info by time code is to be merged, there should be a CSIT patch to verify the code
15:22:51 <shague> #info how to create CSIT tests for features spanning multiple patches
15:23:05 <shague> #info possibly create a feature specific job
15:23:34 <shague> #update CSIT to use a control+compute node and a compute node, rather than the current control node and two compute nodes
15:24:47 <shague> #info does this change infra
15:27:45 <shague> #topic bug scrub  [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946)
15:28:23 <shague> #topic [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - [bug-7826](https://bugs.opendaylight.org/show_bug.cgi?id=7826) - openflowplugin patch was abandoned, new patch [63896](https://git.opendaylight.org/gerrit/63896)
15:28:46 <shague> #info sunil making progress, recreating locally to further debug
15:29:34 <shague> #topic [bug-9245]() - [NETVIRT-940](https://jira.opendaylight.org/browse/NETVIRT-940) - [gerrit 64382](https://git.opendaylight.org/gerrit/64382)
15:31:11 <shague> #info fix will cover all table 21 bugs, NETVIRT-940 and 946
15:32:05 <shague> #topic [bug-9297](https://bugs.opendaylight.org/show_bug.cgi?id=9297) - adjacency]} does not exist - [NETVIRT-959](https://jira.opendaylight.org/browse/NETVIRT-959)
15:32:45 <shague> #info Hanamantagoud fip is present but no adjacency is found
15:33:03 <shague> #info looks like fip is moving from node to node
15:33:57 <shague> #info Hanamantagoud requested help from NAT guys
15:36:14 <shague> #topic [bug-9298](https://bugs.opendaylight.org/show_bug.cgi?id=9298) - port-name=e21f56c9-1513-4753-bf40-f9d391c45658}] does not exist - [NETVIRT-960](https://jira.opendaylight.org/browse/NETVIRT-960)
15:37:02 <shague> #info Cheta is out will look when back
15:37:17 <shague> #topic [gerrit 64124](https://git.opendaylight.org/gerrit/64124) - Updated to use bind-service update instead of bind and unbind in Acl VPN - listener - doesn't seem to help with [NETVIRT-962](https://jira.opendaylight.org/browse/NETVIRT-962) or [NETVIRT-963](https://jira.opendaylight.org/browse/NETVIRT-963) - shold we still commit if change is useful?
15:38:39 <shague> #info Aswin doublecheck
15:38:52 <shague> #topic L2GW CSIT - Move BGP VPN service into it's own CSIT so we can make L2GW CSIT gating for HWVTEP and L2GW related patches
15:39:47 <shague> #info vpnservice suites are in both netvirt and l2gw - should it be removed from l2gw
15:40:01 <shague> #info should bgpvpn be moved to genius?
15:40:46 <vthapar> #info no, it is netvirt suite.
15:42:15 <shague> #info vthapar bgpvpn should not be in the netvirt or l2gw suite
15:42:53 <shague> #info daya_k bgpvpn is not decoupled from l3 so it will cause issues if not ran as part of the full suite
15:44:04 <shague> #info l2gw should not have bgpvpn
15:44:32 <shague> #info need to decide then where bgpvpn should be - in netvirt basic suite or in separate suite
15:45:42 <shague> #action jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw
15:46:22 <shague> #info use the new feature job
15:47:22 <shague> #info vpnservice suites should remain in netvirt.
15:47:40 <shague> #action vpickard to push patch to remove vpnservice suite from l2gw
15:49:00 <shague> #info vthapar should l2gw gates be ran on all patches?
15:50:04 <shague> #info all ovsdb hwvtep patches should run the l2gw gate
15:50:25 <shague> #info how to identify what netvirt patches should run l2gw gates
15:51:12 <shague> #info most code has l2gw or hwvtep in the patch so that can be used as a guide
15:52:26 <shague> #topic Auto transport zone, Auto tunnels, and L2GW https://bugs.opendaylight.org/show_bug.cgi?id=7743
15:54:50 <shague> #info l2gw does not full support the autotunnel feature
15:55:43 <shague> #info also seeing issues in basic netvirt around autotunnel, timing issues
15:56:33 <shague> #info should we disable autotunnel and use other mechanism to create the zone and full tunnel mesh
15:57:43 <shague> #info port-status has issues in clustered setup, this is needed for auto-tunnels to work
15:58:11 <shague> #info jhershbe patches have been pushed to fix port-status clustering issues. need to be verified
15:59:26 <shague> #info restconf is combersome
15:59:39 <shague> #info genius autotunnel is easier to use
16:01:17 <shague> #info look at genius spec for autotunnel
16:02:08 <shague> #info daya_k no work is needed in l2gw if the genius autotunnel is used
16:02:45 <shague> #action vpickard to vrify the genius autotunnel
16:02:46 <sridharg> jfyi, vthapar shared the following link regarding the genius auto-tunnel - http://docs.opendaylight.org/en/stable-nitrogen/submodules/genius/docs/specs/itm-tunnel-auto-config.html
16:03:04 <shague> #link http://docs.opendaylight.org/en/stable-nitrogen/submodules/genius/docs/specs/itm-tunnel-auto-config.html
16:06:25 <shague> #info after vpickard verifies genius autotunnel, need to continue discussion to decide if we can move to genius autotunnel
16:07:34 <shague> #topic clustering topics
16:07:45 <shague> #info daya_k to start email with ideas discussed at dDF
16:08:48 <shague> #endmeeting