16:01:43 <shague> #startmeeting NetVirt Weekly 11/07/17
16:01:43 <odl_meetbot> Meeting started Tue Nov  7 16:01:43 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:43 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_11_07_17'
16:01:57 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
16:01:59 <shague> #topic Review existing action items
16:02:07 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_31_17/opendaylight-netvirt-netvirt_weekly_10_31_17.2017-10-31-15.03.html
16:02:07 <Hanamantagoud> #info Hanamantagoud
16:02:19 <vpickard> #info Vic Pickard
16:02:55 <shague> #topic [DONE] Action: jamoluhrsen: verify if bug still present [NETVIRT-905](https://jira.opendaylight.org/browse/NETVIRT-905) - bug is not present, bug resolved
16:03:00 <jamoluhrsen> #info jamoluhrsen
16:03:11 <shague> #topic ACTION: jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw
16:03:32 <shague> #info wip ACTION: jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw
16:03:45 <shague> #info job will be used for sandbox for new features
16:04:56 <shague> #info can we remove stateful from job names
16:05:06 <shague> #info shague would prefer to keep jobs a little longer
16:05:22 <shague> #topic ACTION: jamoluhrsen add genius autotunnel to netvirt suite
16:06:06 <shague> #info vpickard vthapar debugged hwvtep autotunnel csit, found ovsdb node is restarted
16:06:29 <shague> #info vpickard changes to remove restart, good progress
16:06:53 <shague> #info vpickard made changes to netvirt csit to enable autotunnel
16:06:55 <vthapar> #info not just restarted, but recreated bridge etc. everything.
16:07:13 <shague> #info New feature - ITM refactoring - address genius auto-tz to handle dpnid changes. Planned, need to figure out when it will be available.. discussed in last ODL DFG.
16:07:50 <shague> #info Need genius csit to test auto-tz use cases
16:08:33 <shague> #info the auto-tz genius csit will cover the other use cases
16:09:30 <shague> #info l2gw tests did nto need the recreate steps
16:09:59 <shague> #info netvirt jobs with auto-tx enabled:
16:10:01 <shague> #info Netvirt CSIT runs in progress using genius auto-tz https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-pike-upstream-stateful-carbon/3/console   https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-pike-upstream-stateful-nitrogen/3/consoleFull
16:11:10 <shague> #action vpickard jamoluhrsen verifying the sandbox jobs are working
16:12:03 <shague> #topic Action: jamoluhrsen to file a jira issue to help track the odl crashing problem
16:12:29 <shague> #info issue resolved, OS images have problems with ODL
16:12:53 <shague> #info new centos vm created
16:14:21 <shague> #info jamoluhrsen latest jobs using new image are looking good
16:14:37 <shague> #topic https://trello.com/c/iD2fOfF1/16-nitrogen-release-planning - SR1 10/26/17
16:15:08 <shague> #info blocker bugs requrie respin, need retest
16:15:32 <shague> #action jamoluhrsen update tracking sheet
16:15:42 <shague> #topic bug scrub  [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946)
16:15:58 <shague> #topic [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - [bug-7826](https://bugs.opendaylight.org/show_bug.cgi?id=7826) - openflowplugin patch was abandoned, new patch [63896](https://git.opendaylight.org/gerrit/63896) - patch merged on carbon, still need cherry-picks to nitrogen and master, Anil might be helping
16:16:43 <shague> #info patch needs cherry-pick to nitrogen and carbon
16:16:52 <shague> #info anil and sunil to work on cherry-pick
16:17:18 <shague> #topic [bug-9297](https://bugs.opendaylight.org/show_bug.cgi?id=9297) - adjacency]} does not exist - [NETVIRT-959](https://jira.opendaylight.org/browse/NETVIRT-959) - CSIT looking good so far, run again to be sure
16:17:28 <shague> #info latest csit looking good
16:17:55 <shague> #info shague to add more queens jobs
16:18:44 <shague> #topic [bug-9298](https://bugs.opendaylight.org/show_bug.cgi?id=9298) - port-name=e21f56c9-1513-4753-bf40-f9d391c45658}] does not exist - [NETVIRT-960](https://jira.opendaylight.org/browse/NETVIRT-960) - chetan pushed https://git.opendaylight.org/gerrit/#/c/64930/ - running csit to verify, had tempest failures, need to rerun
16:19:09 <shague> #info last csit run tempest test passed
16:19:15 <shague> #info run more times to verify
16:19:34 <shague> #info cehck if queens is needed
16:20:28 <shague> #topic https://jira.opendaylight.org/browse/NETVIRT-972
16:20:53 <shague> #info not seen recently, close if not seen
16:21:14 <shague> #topic https://jira.opendaylight.org/browse/NETVIRT-971
16:21:17 <shague> #info not seen recently, close if not seen
16:21:28 <shague> #topic https://jira.opendaylight.org/browse/NETVIRT-942
16:21:30 <shague> #info not seen recently, close if not seen
16:22:07 <shague> #topic vthapar: CSIT requirement in new specs [test template](https://git.opendaylight.org/gerrit/65081) - [rendered html](https://logs.opendaylight.org/releng/jenkins092/docs-rtd-verify-oxygen/330/html/submodules/genius/docs/testplans/index.html)
16:25:32 <shague> #info vivekn add test table
16:28:02 <shague> #info devs initially should write expected steps, int/test devs can review and help with actual robot code
16:29:08 <shague> #info daya is there a overall doc that lists all suites and tests
16:32:26 <shague> #info daya add gate identification section
16:33:15 <shague> #info add suite identification section - what suite should test be part of, should it be in gates...
16:34:38 <shague> #info vthapar: need to document existing tests
16:37:29 <shague> #info does the [Documentation] get pulled into a html doc?
16:37:58 <shague> #info jamoluhrsen: yes it can be rendered to an html doc
16:38:46 <shague> #info need to add hook to automatically generate the html
16:39:04 <jamoluhrsen> #link http://opendaylight.readthedocs.io/en/latest/_static/integration/robot/DevstackUtils.robot.html  <-- how we autogenerate robot test libs
16:42:59 <shague> #action jamoluhrsen look into test doc generation
16:44:25 <jamoluhrsen> vthapar, shague, just forwarded the email. check it out.
16:45:28 <shague> #topic start reviewing specs
16:46:03 <shague> #info new spec for evpn support
16:46:19 <shague> #info spec for weighted napt selection
16:46:54 <shague> #info need to review https://trello.com/c/QBPzg5Uw/40-hardware-offload-support-for-openvswitch
16:47:43 <shague> #topic daya: updating the csit environments
16:48:02 <shague> #info ovs updates, hardware offload
16:48:38 <jamoluhrsen> #link http://docs.opendaylight.org/en/stable-carbon/submodules/netvirt/docs/user-guide/support.html?highlight=verified%20combinations   <-- ovs/odl/openstack support matrix
16:49:40 <shague> #action daya to send email with list of updates
16:50:31 <shague> #info daya: vpn datapath tests are coming soon - they will need ovs 2.8
16:51:07 <shague> #info daya: bundles, resync can bet tested with ovs 2.6
16:51:25 <shague> #info jamoluhrsen: openflowplugin should have csit for testing budles
16:51:29 <shague> #info jamoluhrsen: openflowplugin should have csit for testing bundles
16:52:31 <shague> #topic manjeet: n-odl gate jobs for upgrade
16:53:01 <shague> #info manjeet: grenade job not passing
16:53:36 <shague> #link http://logs.openstack.org/33/501833/13/check/networking-odl-grenade-dsvm/c43b5af/logs/old/local_conf.txt.gz
16:53:48 <shague> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2017-November/005711.html
16:54:48 <shague> #info local tests work with different config
16:55:17 <shague> #info works locally, but neither config works in gate
16:58:41 <shague> #endmeeting