16:01:44 <shague> #startmeeting NetVirt Weekly 12/05/17
16:01:44 <odl_meetbot> Meeting started Tue Dec  5 16:01:44 2017 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:44 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_12_05_17'
16:01:54 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
16:01:55 <shague> #topic Review existing action items
16:02:12 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_11_28_17/opendaylight-netvirt-netvirt_weekly_11_28_17.2017-11-28-16.03.html
16:04:27 <vpickard> #info vpickard
16:04:28 <shague> #topic [DONE] shague run gate also with https://git.opendaylight.org/gerrit/#/q/I65644f32551124c61e30c02831ac4193d12471d2 - [60259](https://git.opendaylight.org/gerrit/#/c/60259/) - new patches pushed so need another run
16:04:32 <vthapar> #info Vishal
16:04:48 <vpickard> can't join mtg, wait for host to start?
16:06:32 <shague> #action vthapar to review impl and spec again
16:06:57 <jamoluhrsen> #info jamoluhrsen
16:07:28 <shague> #action shague run gate again once patches build
16:07:53 <shague> #info gate was requested to verify the spec
16:08:28 <shague> #topic genius auto-tz changes - Vic's testing looks good, need to update installers like devstack and OOO
16:08:47 <shague> #info vpickard testign looks good
16:08:57 <shague> #info need changes for the installers
16:09:42 <shague> #info questions about tep ip
16:09:45 <shague> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2017-December/005922.html
16:10:01 <shague> #info vpickard likely reuse local_ip
16:14:48 <shague> #action vpickard look at OOO variables, can local_ip be used? differentiate between data, mgmt or control ip
16:15:21 <shague> #link https://github.com/openstack/puppet-neutron/blob/master/manifests/plugins/ovs/opendaylight.pp#L7
16:19:56 <shague> #info vthapar, vpickard looks like local_ip can be used
16:20:45 <shague> #info daya mentions there are similar variables in the hostconfig
16:24:07 <shague> #action vpickard to work on genius patch to use lcoal_ip
16:24:24 <shague> #topic CSIT VM DHCP IP Failure [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-December/005893.html) - [csit job](https://logs.opendaylight.org/releng/jenkins092/netvirt-csit-1node-openstack-ocata-upstream-stateful-carbon/214/log_02_l3.html.gz#s1-t11-k9)
16:28:30 <shague> #info Aswhin : table 51 has same src mac
16:28:40 <shague> #info Ashwin : table 51 has same src mac
16:29:58 <shague> #info Ashwin : table 51 has same src mac on both computes
16:30:10 <shague> #info ashwin looking further
16:31:26 <shague> #info Ashwin : correction, table 50 rather than table 51
16:33:46 <shague> #topic [weather for neutron changes to uuid and tenant id](https://wiki.opendaylight.org/view/Weather#Neutron_Northbound:_Yang_Model_changes.28UUID.2FTenantID_consolidation.29) - [53438](https://git.opendaylight.org/gerrit/53438) - is there an impact to netvirt or genius?
16:36:24 <shague> #info vthapar tenant-id is not being used by netvirt so likely no changes in netvirt
16:37:05 <shague> #action vthapar to take a closer look if there are impacts
16:37:18 <shague> #topic neutron change to move port status to operational - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-February/003141.html) - [51981](https://git.opendaylight.org/gerrit/#/c/51981/)
16:38:11 <shague> #info daya asks if the prot status being in operational will be lost on reboots. Yes it will
16:38:47 <shague> #info josh will look at impacts
16:39:22 <shague> #topic bug scrub  [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946)
16:40:20 <shague> #info sunil posted another patch
16:41:04 <shague> #info sunil groupids stored in local cache before stats collected
16:41:32 <shague> #info sunil discrepancy in how cache is handle during delete
16:42:05 <shague> #info original patch cherry-picked to nitrogen and master
16:43:11 <shague> #topic https://jira.opendaylight.org/browse/OPNFLWPLUG-917 deserialization
16:43:22 <shague> #info patches under review
16:43:57 <shague> #topic https://jira.opendaylight.org/browse/NETVIRT-993
16:44:38 <shague> #info hanamant to update last debugging patch
16:45:32 <shague> #info vorburger mentions the retyr patchs in genius might have helped with other exceptions
16:46:54 <shague> #topic genius retry patches
16:47:10 <shague> #info vorburger to work with philippe on adding to ipv6 code
16:51:38 <shague> #topic vinh spec https://git.opendaylight.org/gerrit/#/c/65948/
16:51:43 <shague> #info need to review spec
16:52:08 <shague> #action daya, vthapar, shague, vivek to review spec
16:52:59 <shague> #topic specs
16:53:16 <shague> #info need specs in and review by m3 date, 12/21/17
16:53:24 <shague> #topic test spec
16:53:35 <shague> #info vthapar pushed new template, needs review
16:53:57 <shague> #link https://git.opendaylight.org/gerrit/#/c/65081/
16:54:08 <shague> #action shague, jamoluhrsen to review spec
16:54:49 <shague> #info vthapar removed robot code sections, better to not have duplicated in spec and actual test code
16:56:58 <shague> #topic https://git.opendaylight.org/gerrit/#/c/65880/ elan circular dependencies
16:59:49 <shague> #info link to bug for vm dhcp ip failure: https://jira.opendaylight.org/browse/NETVIRT-889
17:00:27 <shague> #info tom and vorburger reviewing patch in detail
17:12:20 <shague> #info vthapar action to look at neutron weather item for aggregating tenantid and uuid. change should not have an impact in netvirt
17:12:24 <shague> #endmeeting