16:03:14 <shague> #startmeeting NetVirt Weekly 01/09/18
16:03:14 <odl_meetbot> Meeting started Tue Jan  9 16:03:14 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:14 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_01_09_18'
16:03:24 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
16:03:25 <shague> #topic Review existing action items
16:03:34 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_12_19_2017/opendaylight-netvirt-netvirt_weekly_12_19_2017.2017-12-19-16.02.html
16:03:35 <vpickard> #info vpickard'
16:03:52 <vpickard> #info vpickard
16:03:57 <jhershbe> #info jhershbe
16:04:04 <vorburger> #info vorburger
16:05:00 <shague> #topic [WIP] - daya to look one final time at hw offload spec -  [spec](https://git.opendaylight.org/gerrit/#/c/62481/) - [sriov-hardware-offload](https://git.opendaylight.org/gerrit/#/q/topic:sriov-hardware-offload+(status:open+OR+status:merged)
16:05:04 <janki> #info janki
16:05:38 <shague> #info daya's comments were addressed
16:05:56 <sridharg> #info Sridhar Gaddam
16:06:01 <shague> #info likely merge spec, shague do one final review
16:07:06 <shague> #info more patches to review for the impl
16:07:24 <shague> #topic [WIP] - vthapar to follow up with vpickard on 3 issues on the genius auto-tz switch https://jira.opendaylight.org/browse/NETVIRT-1041  https://jira.opendaylight.org/browse/OVSDB-444                                            Other issue was with netvirt dyn tunnels, which I was not able to reproduce, so only 2 related to genius auto-tz.
16:08:20 <shague> #info vpickard ostly ready, one item still open: https://jira.opendaylight.org/browse/NETVIRT-1041
16:10:49 <shague> #info problem is only present on an odl ds wipe
16:11:29 <shague> #info workaround is available, so can merge
16:12:18 <shague> #action vpickard add workaround to bug
16:14:11 <shague> #info other bug, https://jira.opendaylight.org/browse/OVSDB-444 - bug for reboots should be fixed, but not related to auto-tz changes
16:17:34 <shague> #info vthapar: https://jira.opendaylight.org/browse/OVSDB-439  could be related
16:18:10 <shague> #topic Carbon sr3 - build is out -  Jamo can you sign off on failures? [tracking sheet](https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633)
16:22:20 <shague> #info dhcp bug and sg networking-odl open
16:23:34 <shague> #info keep dhcp bug as blocker and hold release
16:23:48 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - M3 12/21/17 Feature Freeze - Need to have specs reviewed
16:24:44 <shague> #info update hwoffload and chaining specs
16:24:49 <shague> #info other specs unde review
16:26:39 <shague> #info add hanamant to https://git.opendaylight.org/gerrit/#/c/65948/
16:27:33 <shague> #info M4: 01/21/18: Code Freeze
16:28:01 <shague> #info queue of patches to go in dualstack, upgrade fixes, transaction
16:28:43 <shague> #info tpantelis has cache patches in queue
16:31:26 <shague> #info focus on oxygen for dualstack
16:32:44 <shague> #info daya to get reviewers from E/// side to sign-off
16:33:39 <shague> #info shague, jamoluhrsen review the dualstack csit patches
16:34:11 <shague> #topic carbon, nitrogen and oxygen: can we focus solely on oxygen? There are exceptions in all branches, but tests seem to pass so can possibly be ignored.
16:36:02 <shague> #info team Ok with focusing on oxygen
16:36:26 <shague> #topic https://jira.opendaylight.org/browse/NETVIRT-1038
16:37:34 <shague> #info looks like lport tag recycling too quickly
16:37:54 <shague> #info default table 220 flow is installed, then quickly removed
16:39:31 <shague> #info vthapar need to trace flow back to config inventory
16:41:07 <shague> #topic [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - group-id bug. carbon is ready once branch unlocks, nitrogen running gate, oxygen needs rebase and gate
16:41:47 <shague> #topic [NETVIRT-896](https://jira.opendaylight.org/browse/NETVIRT-896) - tempest.api.network precommit_delete failure on security group delete
16:42:15 <shague> #info need networking-odl to look at bug
16:43:03 <shague> #[Josh] Upgrade patches and issues. Also at what release are upgrades supported? Relates to yang model compatibility.
16:43:41 <shague> #info josh has rebased patches
16:43:47 <shague> #info daya added reviewers
16:44:27 <shague> #info janki working on csit changes
16:46:31 <shague> #info ensure gate passes on current patch stack
16:47:16 <shague> #topic yang compatibility
16:48:13 <shague> #info dualstack introduces non-backward compatible changes.
16:48:46 <shague> #info daya evpn in nitrogen also has non-backward compatible changes
16:51:19 <shague> #info clustered-data-app-config plan to be handled by upgrade tooling
16:52:37 <shague> #info current replay upgrade process wipes datastore so alleviates many compatibility concerns
17:00:55 <shague> #endmeeting