16:02:03 <shague> #startmeeting NetVirt Weekly 01/30/18
16:02:03 <odl_meetbot> Meeting started Tue Jan 30 16:02:03 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:03 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_01_30_18'
16:02:16 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
16:02:17 <shague> #topic Review existing action items
16:02:25 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_01_23_18/opendaylight-netvirt-netvirt_weekly_01_23_18.2018-01-23-16.01.html
16:02:38 <skitt> #info skitt
16:02:52 <aswin__> #info Aswin Suryanarayanan
16:03:29 <shague> #topic [WIP] jamoluhrsen to push a job to use port status and report on results
16:03:50 <shague> #info job pas pushed and passing
16:04:05 <sridharg> #info Sridhar Gaddam
16:04:32 <vpickard> #info vpickard
16:04:41 <shague> #info job was merged
16:04:59 <shague> #topic [DONE] jhershbe check which openstack versions support port status - Pike and later support port-status
16:04:59 <jamoluhrsen> #info jamoluhrsen
16:05:31 <shague> #topic [WIP] jamoluhrsen to use distchanges on SR2 and latest carbon SR3 candidate to see differences between two branches. SR2 is passing tests whereas SR3 fails some.
16:05:53 <shague> #topic [WIP] jamoluhrsen and shague to try and run dualstack csit in sandbox. Patches are being actively reviewed. possibly add to new tdd-wip test-patch
16:06:27 <shague> #info dualstack csit patches are being reviewed
16:06:37 <shague> #info csit has failures to be addressed
16:07:20 <Hanamantagoud> #info Hanamantagoud
16:07:46 <shague> #info kiran mentions most patches are looking good.
16:10:46 <jamoluhrsen> #action jamoluhrsen to send email for someone from the dev/design side of dualstack to review the csit patch to understand what gaps we might or might not have
16:11:10 <shague> #info daya to assign resources to look at csit failures in new dualstack tests
16:12:28 <jamoluhrsen> #info need to understand the status of where we are in two router dualstack csit patches
16:12:35 <shague> #action shague to run gates on current patches
16:12:55 <shague> #action shague check with jhershbe_ on reviews for those patches
16:13:42 <shague> #info aswin__ mentions patches on vpnid in nitrogen
16:14:58 <shague> #info drop support in nitrogen
16:16:01 <shague> #action daya kiran to send current list of duslstack patches to merge
16:16:06 <aswin__> #info https://git.opendaylight.org/gerrit/#/c/59919/ may be abandoned since https://git.opendaylight.org/gerrit/#/c/66973/ removes vpnid dependecny
16:16:30 <jamoluhrsen> silence is deadly
16:16:59 <shague> #topic [WIP] daya to look into adding csit for acl patches - multicast/broadcast types
16:17:15 <shague> #action daya to follw up
16:17:42 <shague> #info netvirt acl patches are pushed and under review
16:18:51 <shague> #topic [DONE] shague to verify if the ovs version has changed for [OPNFLWPLUG-974](https://jira.opendaylight.org/browse/OPNFLWPLUG-974) - ovs-vswitchd (Open vSwitch) 2.7.3 been used before and after failures, so doesn't look related to ovs version
16:19:24 <shague> #topic https://trello.com/c/SCmPOAY6/18-carbon-release-planning - sr3 blocked on netvirt blockers. patches pushed yesterday, need to reevaluate status [tracking sheet](https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633)
16:19:50 <shague> #info jamoluhrsen started more jobs in sandbox.
16:20:06 <shague> #action jamoluhrsen needs to add tcpdump and trace log jobs
16:20:30 <shague> #link https://jira.opendaylight.org/browse/NETVIRT-1022
16:20:34 <jamoluhrsen> #link https://jenkins.opendaylight.org/sandbox/job/jamo-netvirt-csit-1node-openstack-ocata-upstream-stateful-carbon/  <-- job to debug carbon sr3 troubles
16:20:51 <shague> #info looking like an openflowplugin bug
16:20:59 <vpickard> #info jamoluhrsen, there is a new job to copy sandbox logs to save them
16:21:05 <vpickard> #info copy-logs: <job-name>/<job-number>
16:21:22 <jamoluhrsen> vpickard: what is that? really?
16:21:35 <vpickard> jamoluhrsen: copy-logs: bgpcep-csit-1node-userfeatures-all-oxygen/2
16:22:01 <vpickard> jamoluhrsen: this is a job that will copy the sandbox jobs to jenkins so that debug logs are not wiped on Friday night from sandbox
16:23:02 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - 1/21/18 Code Freeze - TSC agreed to delay release one week so now 1/28/18 as well as move all dates back one week. A soft code freeze was decided meaning another discussion would take place to decide when to really freeze and pull a stable branch.
16:24:07 <shague> #info aaa patches have impact on dates
16:24:53 <vpickard> #info jamoluhrsen, logs will be stored under builder-copy-sandbox-logs.job
16:29:21 <shague> #link https://git.opendaylight.org/gerrit/#/c/67198/
16:34:16 <shague> #info e/// team (jaya) has some csit tests downstream that are being upstreamed
16:36:04 <shague> #topic chaingin spec: https://git.opendaylight.org/gerrit/#/c/65948/
16:36:21 <shague> #action: daya to add another round of reviews
16:36:39 <shague> #info vivek n has comments that should be addressed
16:38:56 <shague> #action jhershbe_ forward email to the exat review comments in question
16:39:15 <shague> #topic [OPNFLWPLUG-974](https://jira.opendaylight.org/browse/OPNFLWPLUG-974) - Message deserialization failed...msgType: 36864 oxm_field: 6 experimenterID: null was not found - please verify that all needed deserializers ale loaded correctly - nitrogen and carbon fail. Maybe related to NETVIRT-1069
16:40:15 <shague> #info gobinath will update status soon
16:41:18 <shague> #topic [jc-metrics](https://git.opendaylight.org/gerrit/#/q/topic:jc-metrics) - used to monitor jobCoordinator
16:42:23 <shague> #topic genius auto tunnel patches - new patch to fix OOO deployment https://git.opendaylight.org/gerrit/#/c/67674/
16:42:56 <shague> #info downstream testing fails. tunnels do not come up
16:47:54 <shague> #topic queens csit broken - anyone looking at this? New l2gw csit test cases for updating ports on l2gw with existing connections requires queens
16:48:21 <shague> #info gvrangan has pacthes under test to fix queens
16:50:38 <shague> #link https://git.opendaylight.org/gerrit/#/c/67411/
16:51:05 <gvrangan> latest sandbox:https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-queens-upstream-stateful-snat-conntrack-oxygen/14/
16:51:06 <shague> #link
16:51:07 <shague> https://git.opendaylight.org/gerrit/#/c/67411/
16:51:09 <shague> https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-queens-upstream-stateful-snat-conntrack-oxygen/14/
16:51:24 <jamoluhrsen> gvrangan: thanks for that work
16:51:46 <jamoluhrsen> gvrangan: so why are we getting an abort?
16:52:36 <gvrangan> jamoluhrsen: It looks like tempest-output is missing
16:52:47 <gvrangan> tempest_output
16:53:15 <gvrangan> jamoluhrsen: had to comment that log copy for Queens
16:53:34 <shague> #endmeeting