15:02:41 <shague> #startmeeting NetVirt Weekly 05/15/18
15:02:42 <odl_meetbot> Meeting started Tue May 15 15:02:41 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:42 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_05_15_18'
15:02:58 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:03:03 <vthapar> #info Vishal
15:03:06 <vpickard> #info vpickard
15:03:12 <skitt> #info skitt
15:03:16 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_05_08_18/opendaylight-netvirt-netvirt_weekly_05_08_18.2018-05-08-14.59.html
15:03:51 <daya_k> #info daya_k
15:04:31 <shague> #topic [WIP] shague to identify date, if any, for API freeze related to yang changes
15:04:37 <sridharg> #info Sridhar Gaddam
15:06:43 <aswinsuryan> #info Aswin
15:11:45 <shague> #info use the Fluorine Middle Checkpoint as a soft date for the api freeze, 7/5/18
15:12:26 <shague> #info soft date means that is the target to get the yang changes in, but updates can still go in
15:14:05 <shague> #info vthapar mentions it would be good to have code committed for the yang changes earlier than the impl
15:15:47 <shague> #info devs should attempt to push yang, pipeline and service type changes earlier
15:16:03 <shague> #info use 6/7/18 as the target for these api changes
15:17:21 <shague> #topic [WIP] vishal to add comments to specs to take yang changes into consideration and update troubleshooting tool
15:17:55 <shague> #action vthapar and shague to discusss how to update specs for odltools
15:18:38 <shague> #info jamoluhrsen update on odltools project proposal
15:23:36 <shague> #action shague to clarify license issue, start with apache
15:23:53 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - csit 5/7/18 - looking good.
15:25:26 <shague> #info need to look again into the snat-conntrack failures so the default can be changed
15:27:38 <shague> #info daya mentions e/// woudl need some ha issues fixed before switching to snat-conntrack as default
15:28:55 <shague> #topic specs https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#
15:34:23 <shague> #info how to ensure pipeline changes are consistent - e.g. need genius reviewers
15:35:01 <shague> #info vivekn has been checking the pipeline changes so this area is covered
15:35:24 <aadam> #info Ariel
15:36:16 <shague> #info the pipeline doc should be updated
15:37:45 <shague> #action vivekn to request devs to update pipeline.rst
15:38:22 <shague> #info vivekn: pipeline.rst needs to have the l3 pipeline included
15:39:09 <shague> #info vthapar: in the meantime, devs should push patches to genius with the NWConstants changes
15:41:45 <shague> #link https://docs.google.com/presentation/d/15h4ZjPxblI5Pz9VWIYnzfyRcQrXYxA1uUoqJsgA53KM/edit#slide=id.g1c73ae9953_2_0
15:44:15 <shague> #topic running upstream csit with dpdk
15:52:21 <shague> #info team would like to have dpdk in the deployment
15:52:35 <shague> #info need to add the deployment support in csit
15:52:48 <shague> #info possibly the snapshot vms will have the dpdk support already
15:53:13 <shague> #endmeeting