#opendaylight-netvirt: NetVirt Weekly 06/12/18

Meeting started by shague at 15:02:43 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:54)
    1. vpickard (vpickard, 15:02:56)
    2. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_05_18/opendaylight-netvirt-netvirt_weekly_06_05_18.2018-06-05-15.03.html (shague, 15:03:13)

  2. [WIP] jamoluhrsen will look to add the code permanently for SnD in CSIT - [71598](https://git.opendaylight.org/gerrit/#/c/71598/) (shague, 15:04:30)
    1. Vishal (vthapar_, 15:04:59)
    2. still issues with the SnD so can't enable (shague, 15:05:00)
    3. ACTION: : jamoluhrsento work on patch (shague, 15:05:26)

  3. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:05:39)
  4. specs: [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#) (shague, 15:07:08)
  5. Error and exception handling: [72813](https://git.opendaylight.org/gerrit/#/c/72813/), [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-June/007027.html) (shague, 15:07:56)
    1. need to revisit exception handling (shague, 15:08:28)
    2. utils wrap read exceptions and swallow exceptions making it difficult to know what is happening (shague, 15:09:15)
    3. thsi handling will also help with the improved transaction handling ideas to ensure transactions are opened and closed properly (shague, 15:14:47)
    4. skitt: we can starts with listeners and rpc to follow trail and fix along the way (shague, 15:17:36)
    5. ACTION: skitt: create a jira and subtasks for tracking the fixes (shague, 15:18:22)
    6. suneelu mentions that we need to consider recovery aspects too (skitt, 15:19:20)
    7. we should perhaps add retries for every job (skitt, 15:21:12)
    8. need to think about how this all fits in with the job coordinator (skitt, 15:21:53)

  6. 3node and sharding - [CONTROLLER-1836](https://jira.opendaylight.org/browse/CONTROLLER-1836) - looking at switching to single shard (shague, 15:23:02)
    1. daya mentions need 3 shards at minimum: operational, config, eos (shague, 15:24:43)
    2. skitt also mentions a fourth shard (shague, 15:24:56)
    3. default adds: inventory and operational (shague, 15:26:36)
    4. skitt: rh ds uses default (shague, 15:26:48)
    5. default controller setup is default/topology/inventory, all with config/operational (skitt, 15:27:12)
    6. default puppet-opendaylight is default only, with config/operational (skitt, 15:27:23)

  7. bundles based resync (shague, 15:28:33)
    1. daya_k troubleshooting found that nat had stale flows when enabled (shague, 15:28:52)
    2. arun and gobinath will update the ofp code to handle missing resources (shague, 15:29:37)
    3. chetan is looking at netvirt side fixes (shague, 15:29:58)

  8. CSIT for new features (shague, 15:31:23)
  9. csit test suite upstreaming (shague, 15:35:21)
    1. ACTION: shague send copy-logs instructions (shague, 15:38:49)


Meeting ended at 15:42:14 UTC (full logs).

Action items

  1. : jamoluhrsento work on patch
  2. skitt: create a jira and subtasks for tracking the fixes
  3. shague send copy-logs instructions


Action items, by person

  1. shague
    1. shague send copy-logs instructions
  2. skitt
    1. skitt: create a jira and subtasks for tracking the fixes


People present (lines said)

  1. shague (27)
  2. skitt (5)
  3. odl_meetbot (3)
  4. vpickard (1)
  5. vthapar_ (1)


Generated by MeetBot 0.1.4.