15:01:26 <shague> #startmeeting NetVirt Weekly 06/19/18
15:01:26 <odl_meetbot> Meeting started Tue Jun 19 15:01:26 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:26 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_06_19_18'
15:01:41 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:01:47 <vthapar> #info Vishal
15:01:57 <jamoluhrsen> #info jamoluhrsen
15:02:00 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_12_18/opendaylight-netvirt-netvirt_weekly_06_12_18.2018-06-12-15.02.html
15:02:00 <sridharg> #info Sridhar
15:02:21 <jamoluhrsen> shague: reminder, I'll be checking out of here in about 20m and then rushing back aprox 20m after that
15:02:29 <vorburger> #info vorburger
15:03:35 <vpickard> #info vpickard
15:03:42 <shague> #topic [WIP] jamoluhrsen continue work on patch for SnD
15:04:01 <shague> #topic [WIP] skitt: create a jira and subtasks for tracking the fixes for the suggested best practices for handling error cases and exceptions
15:04:12 <vorburger> skitt: shague asking if you are joining netvirt weekly?
15:04:20 <shague> #topic [DONE] shague send copy-logs instructions - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-June/007030.html)
15:04:31 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400)
15:04:49 <skitt> shague, sorry, just joined
15:05:38 <shague> #info 1node csit looking good
15:06:06 <shague> #info one blocker: https://jira.opendaylight.org/browse/NETVIRT-1307
15:06:34 <shague> #info karthikeyan is working  the bug, patches under review
15:07:11 <shague> #info aswinsuryan snat-conntrack
15:07:27 <shague> #info https://jira.opendaylight.org/browse/NETVIRT-1304 seen
15:08:07 <shague> #info https://jira.opendaylight.org/browse/NETVIRT-1040 seen
15:08:58 <shague> #info https://jira.opendaylight.org/browse/NETVIRT-1270 also seens
15:09:13 <shague> #inf aswinsuryan has patches for 1304 and 1270
15:11:29 <shague> #info need +1 on https://git.opendaylight.org/gerrit/#/c/71872/
15:11:34 <shague> #info aswinsuryan has patches for 1304 and 1270
15:12:30 <shague> #info aswinsuryan mentions new pnf failures are occurring, will looko at after these patches are in
15:12:34 <jamoluhrsen> aswinsuryan: which patch is for 1304?
15:13:20 <shague> #info after all issues fixed, reevaluate when to switch to snat-conntrack as default
15:13:54 <shague> #topic clustering hit team - discuss current ideas - [73041 - ds-constrained txs](https://git.opendaylight.org/gerrit/#/c/73041/)
15:15:43 <shague> #info tomp: working on clustering deadlock issues
15:15:59 <shague> #info skitt: debugging clustering is very difficult
15:16:04 <aswinsuryan> jamoluhrsen, https://git.opendaylight.org/gerrit/#/c/71495/
15:16:16 <jamoluhrsen> aswinsuryan: thx
15:16:30 <aswinsuryan> #link Netvirt 1304 - https://git.opendaylight.org/gerrit/#/c/71495/
15:16:32 <shague> #info skitt: applications burdened with clustering details
15:17:35 <shague> #info vorburger: there is existing logging to include stacktraces for tx's
15:18:42 <shague> #info skitt: use managedTx at higher level, already made some changes
15:19:51 <shague> #info tomp mentions maybe txchains could be used
15:22:20 <shague> #info action skitt to file jiras and subtasks
15:24:28 <shague> #info action skitt jamoluhrsen checking extra logging in csit
15:25:41 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/73147/ <-- patch to enable extra logging
15:25:44 <shague> #info skitt most are the update of deleted node errors, OLFE, two writeers
15:26:11 <jamoluhrsen> #link https://jenkins.opendaylight.org/sandbox/job/jamo-netvirt-csit-3node-openstack-queens-upstream-stateful-oxygen/2/ <-- job jamoluhrsen needs someone to confirm if extra logging is there or not
15:36:14 <shague> #action skitt jamoluhrsen checking extra logging in csit
15:36:22 <shague> #action skitt to file jiras and subtasks
15:40:22 <shague> #info tomp mentioned akka version has been updated
15:44:32 <shague> #info need to find a time to have regular clustering call
15:46:10 <shague> #action jamoluhrsen to drive working on the controller jobs
15:46:49 <shague> #info daya_k: mentions https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-3node-clustering-bulkomatic-only-oxygen/
15:47:02 <shague> #info ofp would be next after controller jobs
15:48:22 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/controller/job/controller-csit-3node-rest-clust-cars-perf-only-fluorine/120/robot/ <-- cars and people
15:48:48 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/72871/
15:58:06 <shague> #action daya_k check with team about 72871 - why is this patch being done?
15:58:37 <shague> #info is there a real need to separate txs as in the patch
16:03:40 <jamoluhrsen> should we take this to the kernel call?
16:06:24 <jamoluhrsen> aadam: https://zoom.us/j/664690256
16:07:34 <shague> #endmeeting