15:02:43 <shague> #startmeeting NetVirt Weekly 06/26/18
15:02:43 <odl_meetbot> Meeting started Tue Jun 26 15:02:43 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:43 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_06_26_18'
15:02:50 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:03:09 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_19_18/opendaylight-netvirt-netvirt_weekly_06_19_18.2018-06-19-15.01.html
15:03:15 <vthapar> #info Vishal
15:03:34 <jhershbe> #info jhershbe
15:03:36 <sridharg> #info Sridhar Gaddam
15:03:54 <shague> #topic [DONE] skitt jamoluhrsen checking extra logging in csit - transaction-debug-context-enabled=true in HA jobs [73147](https://git.opendaylight.org/gerrit/#/c/73147/)
15:04:12 <jamoluhrsen> shague: are you talking? worried about my audio
15:04:12 <shague> #topic [DONE] skitt to file jiras and subtasks - [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318)
15:04:28 <shague> #info need to add genius tasks also
15:04:45 <shague> #topic [DONE] jamoluhrsen to drive working on the controller jobs - [NETVIT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315)
15:05:04 <shague> #topic [WIP] daya_k check with team about (72871)[https://git.opendaylight.org/gerrit/#/c/72871/] - why is this patch being done?
15:05:49 <shague> #info daya_k atomicity is wanted so tx chaining is being used
15:07:06 <shague> #info tomp mentions you will lose atomicity
15:07:24 <shague> #info daya_k says tx chaining will be used
15:08:12 <shague> #info manu asks for suggestions on which tx chain api to use, e.g. ping-pong broker, etc
15:10:25 <shague> #info skitt need to add rollback handler
15:10:34 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400)
15:11:24 <shague> #info specs to be complete by mid checkpoint
15:13:11 <shague> #info daya_k asks about ovs 2.9.2
15:13:50 <shague> #action jamoluhrsen work with therbert to get rpm
15:14:17 <shague> #topic skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices
15:15:28 <shague> #link https://git.opendaylight.org/gerrit/#/c/73440/
15:15:38 <shague> #info skitt reviewing https://git.opendaylight.org/gerrit/#/c/73440/
15:16:16 <shague> #info tx's can now be constrained
15:23:13 <odp-gerritbot> Aswin Suryanarayanan proposed a change to netvirt: Conflicting modification for vpn-to-dpn-list  https://git.opendaylight.org/gerrit/73146
15:33:06 <shague> #info what deadline should be set to finish NETVIT-1318?
15:34:10 <shague> #info deadline set for next week project meeting, 7/3/18
15:34:36 <shague> #info want these patches in so current feature and spec work can be rebased on the patches
15:37:42 <shague> #info daya_k: should reads have automatic retries?
15:38:47 <shague> #info skitt: new managed runner is rerunning the code, not the operation
15:39:25 <shague> #info skitt: so reads should be merged with rw tx's
15:40:32 <shague> #info daya_k: caches being used in between operations could complicate skitt's plan
15:40:48 <shague> #info: kiran: thinks it should be possible
15:43:04 <faseelak> #info faseelak
15:43:54 <shague> #topic cluster reboots, mdsal rebuilds db
15:44:22 <shague> #info daya_k: how is this done? is it per shard or across all ?
15:46:23 <shague> #info daya_k: block listener registrations until all is ready
15:46:47 <shague> #info jhershbe: the controller code is not the right place to do this
15:47:09 <shague> #info: jhershbe: better would be to make code reentrant
15:47:38 <shague> #info jhershbe: add tests to find these conditions
15:48:41 <shague> #info faseelak: tomp says bundles will only come up after elections are done
15:49:15 <shague> #info daya_k: has doubts, boron tests still have issues
15:51:03 <shague> #info daya_K if tom's statement is right, then problem could be solved. But need to verify with tests.
15:53:02 <shague> #topic rollback tx's
15:53:10 <shague> #info kiran: asks for suggestions
15:53:19 <shague> #info check in next call when experts are there
15:54:29 <shague> #topic jluhrsen: [NETVIRT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) -  Troubleshooting Controller CSIT
15:55:00 <shague> #info https://jira.opendaylight.org/browse/CONTROLLER-1838
15:57:16 <shague> #link https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/controller%203node/job/controller-csit-3node-clustering-all-oxygen
15:57:47 <shague> #info that job is the high-priority job that we need to get 100% passing
15:58:08 <shague> #info vpickard and jamoluhrsen looking at job now
16:03:09 <shague> #endmeeting