15:01:11 <shague> #startmeeting NetVirt Weekly 07/03/18
15:01:11 <odl_meetbot> Meeting started Tue Jul  3 15:01:11 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:11 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_07_03_18'
15:01:20 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:01:34 <Hanamantagoud> #info Hanamantagoud
15:01:53 <odp-gerritbot> Aswin Suryanarayanan proposed a change to netvirt: Add napt switch id in log  https://git.opendaylight.org/gerrit/73702
15:02:12 <shague> #topic Review existing action items
15:02:16 <odp-gerritbot> Aswin Suryanarayanan proposed a change to netvirt: Add napt switch id in log  https://git.opendaylight.org/gerrit/73703
15:04:01 <vorburger> shague: the past is history, the present is mystery, so focus on the present - and throw a party that the build works again? ;-) More seriously, read https://jira.opendaylight.org/browse/ODLPARENT-156 ... I'll update on the latest in a minute
15:04:25 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_26_18/opendaylight-netvirt-netvirt_weekly_06_26_18.2018-06-26-15.02.html
15:04:36 <shague> #topic [WIP] jamoluhrsen work with therbert to get ovs rpm to sideload in upstream csit
15:05:30 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400)
15:07:11 <shague> #topic Middle checkpoint - 4 weeks before code freeze
15:07:19 <odp-gerritbot> Stephen Kitt proposed a change to netvirt: MDSALManager clean-up part 1  https://git.opendaylight.org/gerrit/73710
15:08:04 <shague> #info robustness spec: kiran: vivekn wants to update spec one more time
15:08:14 <shague> #info kiran will push more reviews
15:08:38 <shague> #action kiran to check with vivekn on spec and patches
15:09:11 <shague> #info vpickard igmp snooping likely push out to neon
15:11:59 <shague> #action: shague: to followup with spec owners for remaining impl patches
15:13:18 <vorburger> shague: FYI Fasela is asking to tell you that due has connectivity issues she is not able to join the netvirt call today
15:13:24 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes
15:16:18 <shague> #topic jira: Severity field removed, use only priority, highest indicates blocker
15:19:43 <odp-gerritbot> Chetan Arakere Gowdru proposed a change to netvirt: Conflicit Modification Exception on napt-Switch  https://git.opendaylight.org/gerrit/73701
15:20:15 <shague> #topic QoS spec
15:20:17 <shague> #link https://git.opendaylight.org/gerrit/#/c/71820/
15:20:31 <shague> #info need final review from Arun Sharma
15:20:47 <shague> #info daya: driver issues?
15:21:05 <shague> #info vthapar: should be OK as driver is good
15:21:33 <shague> #info vthapar: need Rajesh's n-odl patch to be merged to continue testing
15:23:31 <shague> #topic ovsdb patches
15:24:29 <shague> #info looks like patch is causing failures, need to debug
15:24:38 <shague> #link https://git.opendaylight.org/gerrit/#/c/73348/
15:25:55 <shague> #link https://git.opendaylight.org/gerrit/71303
15:26:49 <shague> #info vthapar: reparent https://git.opendaylight.org/gerrit/#/c/73348/ on https://git.opendaylight.org/gerrit/71303
15:29:02 <shague> #topic tempest broken out from csit
15:31:41 <shague> #topic skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices
15:34:39 <shague> #info patches for constrained tx patches wip
15:35:31 <shague> #info faseelak: what to do with reads on operational
15:35:47 <shague> #info skitt: should be able to add a new transaction
15:36:40 <shague> #info skitt: there are additional different types of transactions that need to be fixed next
15:37:25 <shague> #info skitt finish constraned tx's then look at next cases
15:38:54 <skitt> #link Better transaction debugging: https://git.opendaylight.org/gerrit/62224
15:38:59 <shague> #info skitt: better logging and troubleshooting
15:40:31 <shague> #info skitt genius mdsal api changes are merged, can remove tx adapter code now
15:41:13 <shague> #info daya: problems that need retries on read's
15:42:09 <shague> #info skitt: retryManagedTxRunner onyl retries on OLFE's currently, needs more exceptions
15:42:25 <odp-gerritbot> A change was merged to netvirt: Add napt switch id in log  https://git.opendaylight.org/gerrit/73702
15:42:34 <shague> #action daya to send list of exceptions to genius list
15:43:02 <odp-gerritbot> A change was merged to netvirt: Add napt switch id in log  https://git.opendaylight.org/gerrit/73703
15:43:43 <shague> #info daya: during cluster reboot, 600ms window where all tx's (r and w) will fail
15:43:56 <odp-gerritbot> Michael Vorburger proposed a change to netvirt: really fix the recent xtend-maven-plugin problem  https://git.opendaylight.org/gerrit/73709
15:46:29 <shague> #info daya: everything comes up, then a reelection looks to be happening
15:49:46 <shague> #info work with Jamo on adding SND in csit
15:50:10 <shague> #info vthapar different use for SND to add app hooks
15:53:01 <shague> #topic Port the constrained-datastore patches to Oxygen? Other clustering fixes?
15:54:07 <shague> #info skitt: wait until we see benefits on flourine csit before backporting to oxygen
15:57:34 <shague> #topic jluhrsen: [NETVIRT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) -  Troubleshooting Controller CSIT
15:57:37 <rovarga> skitt: not to be a stickler, but we need *fewer* not *more* exceptions :)
15:59:03 <skitt> rovarga, I was saying that we need to retry following more exceptions, not produce more exceptions ;-)
15:59:44 <rovarga> skitt: I am just readining IRC :)
15:59:52 <skitt> rovarga, yup, that’s what I thought
15:59:56 <rovarga> FTR: https://shipilev.net/blog/2014/exceptional-performance/
16:00:04 <rovarga> and more to the point:
16:00:08 <rovarga> https://shipilev.net/blog/2014/exceptional-performance/#_conclusion
16:00:13 <skitt> rovarga, we have a retrying transaction manager which can auto-retry in the face of OptimisticLockFailedException
16:00:14 <rovarga> The optimistic rule-of-thumb seems to be 10-4 frequency for exceptions is exceptional enough.
16:00:24 <skitt> rovarga, but it should perhaps retry when other exceptions occur too
16:00:44 <rovarga> i.e. one in ten thousand transactions should fail, if it's performance you are after :)
16:01:01 <vpickard> https://zoom.us/j/664690256
16:01:23 <shague> #endmeeting