15:01:30 <shague> #startmeeting NetVirt Weekly 07/10/18
15:01:30 <odl_meetbot> Meeting started Tue Jul 10 15:01:30 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:30 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_07_10_18'
15:01:38 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:01:55 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_03_18/opendaylight-netvirt-netvirt_weekly_07_03_18.2018-07-03-15.01.html
15:01:57 <jamoluhrsen> #info jamoluhrsen
15:02:35 <vthapar> #info Vishal
15:03:26 <sridharg> #info Sridhar Gaddam
15:04:28 <vpickard> #info vpickard
15:05:08 <shague> #topic [WIP] kiran to check with vivekn on spec and patches - [NETVIRT-1204 - robustness spec](https://jira.opendaylight.org/browse/NETVIRT-1204)
15:05:54 <shague> #info kiran spec updates will come in this week
15:06:14 <shague> #info kiran will work to finish as many items as possible before 8/718
15:06:29 <shague> #topic [DONE] shague: to followup with spec owners for remaining impl patches - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-July/007230.html)
15:11:36 <shague> #topic [WIP] daya to send list of exceptions during cluster reboots to genius list
15:12:14 <shague> #info daya issues have been triaged, now working on how to fix
15:12:55 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400)
15:13:29 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes
15:14:22 <shague> #chetan: updates for bgpvpn use cases
15:14:59 <shague> #topic [OPNFLWPLUG-1023](https://jira.opendaylight.org/browse/OPNFLWPLUG-1023) - failures with ovs 2.8.x and 2.9.x
15:16:29 <shague> #info [TSC-114](https://jira.opendaylight.org/browse/TSC-114) - Support OVS 2.9 NSH implementation, drop OVS 2.6 out-of-branch NSH support.
15:16:40 <shague> #info spec is reviewed
15:20:03 <shague> #topic [OPNFLOWPLUG-1007](https://jira.opendaylight.org/browse/OPNFLWPLUG-1007) - Future (eventually) failed: addFlow -and- transmitPacket - two parts: lldp features causing issues and clustering problems. Also mention of setting inactivity-probe higher to 30s.
15:22:15 <shague> #info change inactivity_probe from 5s to 30s
15:24:53 <shague> #info theory: during up/down odl transitions, 5s is not long enough
15:25:32 <shague> #info daya: gobinath have moved echo/response logic down lower
15:26:39 <shague> #action daya: to check if the patches can be upstreamed to openflowplugin
15:27:54 <odp-gerritbot> Stephen Kitt proposed a change to netvirt: Allow MDSALManager exceptions  https://git.opendaylight.org/gerrit/73882
15:31:14 <shague> #info daya jfr could add value to profile java stats
15:31:22 <shague> #info should we add the tool to csit?
15:32:50 <shague> #action faseelak to pass along downstream jfr script
15:36:40 <zychen> Hi, does SH_FLAG (Split-Horizon flag) mean east-west and south-north?
15:38:59 <shague> #info for the lldp feature reduction, anil will see if we can use the existing features or a new one
15:39:22 <shague> #topic run snat-conntrack csit along with basic upstream csit. We need to transition to snat-conntrack as the default so tests need to pass.
15:41:33 <shague> #info jamoluhrsen should we just add snat-conntrack to the test-netvirt-current trigger?
15:42:02 <shague> #info whitelist should be updated for the existing snat-conntrack job
15:46:03 <shague> #action jamoluhrsen and shague to look at updating the test-netvirt-current
15:46:09 <shague> #topic [single shard patch for 3node 72955](https://git.opendaylight.org/gerrit/#/c/72955/) - merged - shague to add patch for 1node
15:46:40 <shague> #action shague to push a patch to update the 1node also
15:47:16 <shague> #topic jluhrsen: [NETVIRT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) -  Troubleshooting Controller CSIT
15:48:57 <shague> #info vpickard found new bug: https://jira.opendaylight.org/browse/MDSAL-362
15:49:09 <shague> #link https://jira.opendaylight.org/browse/MDSAL-362
15:56:23 <shague> #info vthapar openflowplugin uses ClusteredSingleton
15:57:12 <shague> #info jira vpickard filed is in a bgpcep CSIT and not netvirt
15:59:17 <shague> #info vpickard only looked at one netvirt csit so far and it did not have the error signature, need to look at more jobs to see if the issue does happen
16:00:47 <jamoluhrsen> time to move to kernel call?
16:01:00 <shague> yeah
16:01:42 <shague> #endmeeting