15:02:26 <shague> #startmeeting NetVirt Weekly 07/17/18
15:02:26 <odl_meetbot> Meeting started Tue Jul 17 15:02:26 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:26 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_07_17_18'
15:02:33 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:48 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_10_18/opendaylight-netvirt-netvirt_weekly_07_10_18.2018-07-10-15.01.html
15:03:35 <shague> #topic Review existing action items
15:04:15 <vthapar> #info VIshal
15:04:41 <jhershbe> #info josh
15:04:47 <aswins> #info Aswin S
15:04:58 <jamoluhrsen> #info jamoluhrsen
15:05:20 <shague> #topic [DONE] daya: to check if the patches can be upstreamed to openflowplugin - patches from gobinath that move echo/response logic down lower
15:07:40 <shague> #info ofp code is already upstreamed
15:07:51 <shague> #info do we want similar for ovsdb
15:09:03 <shague> #help need someone to work on the doing the same in ovsdb
15:09:34 <shague> #action vthapar to look into priority if this is reproducible
15:11:18 <shague> #topic [WIP] faseelak to pass along downstream jfr script
15:12:39 <shague> #info jfr will be free in an upcoming openjdk, so maybe we can wait till then
15:12:57 <faseelak> yourkit
15:13:14 <shague> #info faseelak mentions yourkit can be used in it's place
15:13:29 <shague> #info need to look into if it can be used
15:14:33 <shague> #info faseelak jstack might be enough
15:15:14 <shague> #info faseelak either tool should only be ran for small durations
15:17:30 <shague> #topic [WIP] jamoluhrsen and shague to look at updating the test-netvirt-current
15:17:38 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/74129/ added snat-conntrack to patch tests
15:18:06 <shague> #topic [DONE] shague to push a patch to update the 1node also to use [72955](https://git.opendaylight.org/gerrit/#/c/72955/) - [73956](https://git.opendaylight.org/gerrit/#/c/73956/)
15:18:32 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304)
15:22:12 <shague> #action daya to look into csits for new features
15:23:55 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes
15:24:17 <shague> #topic Ordering issues between group_mod and flow_mod https://git.opendaylight.org/gerrit/#/c/74029/ OFPlugin Bug  ->https://jira.opendaylight.org/browse/OPNFLWPLUG-991
15:25:01 <shague> #info aswins flows fail to install when required groups are not present
15:25:34 <shague> #info aswins ofp has a bug to ensure groups are present before flows are programmed
15:26:10 <shague> #info aswins other solution is to read config for group before programming flow
15:27:21 <shague> #info daya group caching code will ensure group is added before flow is programmed
15:27:39 <shague> #info need to know if the code is upstreamed
15:28:14 <shague> #action daya to check code status with Gobinath
15:29:48 <shague> aswins: what was the jira for the ofp fix?
15:31:26 <shague> #info aswin to rework patch to use ofp feature, but the patch can still go in independently
15:32:29 <shague> #topic [74025](https://git.opendaylight.org/gerrit/74025) - csit jobs renamed to this format: netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-fluorine - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-July/007264.html)
15:36:04 <shague> #topic clustering tools - [NETVIRT-1002](https://jira.opendaylight.org/browse/NETVIRT-1002)
15:37:32 <shague> #info monitor tool needs to be adapted to run via cli and capture output to log
15:38:27 <shague> #action skitt remove original monitor tool from int/test
15:38:57 <shague> #info tomp request to not append karaf logs when nodes restarted
15:40:13 <jamoluhrsen> damn skitt that was fast
15:40:37 <aswins> #link https://jira.opendaylight.org/browse/OPNFLWPLUG-991
15:40:44 <skitt> jamoluhrsen, I told you I had it open ;-)
15:41:02 * skitt loves deleting code
15:42:04 <shague> #info jhershbe request to log all admin commands in karaf
15:45:55 <shague> #info jhershbe at least for drastic admin commands like restartign nodes
15:46:02 <jamoluhrsen> jhershbe: I wonder if there is a log level for karaf console commands being logged more verbosely?
15:46:18 <jhershbe> jamoluhrsen, I assume so
15:46:57 <shague> #info request to break log into test#.log chunks
15:50:07 <shague> #info https://jira.opendaylight.org/projects/ODLTOOLS/issues/ODLTOOLS-13?filter=allopenissues
15:50:35 <shague> #info add jiras to odltools for new features
15:51:09 <skitt> odltools.brush_my_teeth()
15:51:48 <shague> #topic clustering issue with vlan tests
15:51:59 <faseelak> #link https://jenkins.opendaylight.org/sandbox/job/faseela-l2-netvirt-csit-3node-openstack-queens-upstream-stateful-fluorine/
15:52:05 <shague> #info faseelak running l2 suite
15:53:36 <shague> #info faseelak mentions seeing missing vm dhcp ips due to different reasons
15:53:59 <shague> #info aswins menations the table 43 case, but that is just one reason
15:54:19 <shague> #info faseelak only happens with the vlan provider
15:57:32 <shague> #info faseelak other vlan issues have been fixed
16:00:29 <shague> #info faseelak_ arun mentions maybe role status changes are involved
16:02:45 <shague> #endmeeting