15:01:49 <shague> #startmeeting NetVirt Weekly 07/24/18
15:01:49 <odl_meetbot> Meeting started Tue Jul 24 15:01:49 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:49 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:49 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_07_24_18'
15:01:57 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:39 <vthapar> #info Vishal
15:03:00 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_17_18/opendaylight-netvirt-netvirt_weekly_07_17_18.2018-07-17-15.02.html
15:03:56 <shague> #topic Review existing action items
15:04:37 <shague> #topic [WIP] vthapar to look into priority if this is reproducible - should ovsdb add similar lower layer hooks for echo request and response handling as ofp implemented.
15:04:59 <shague> #info vthapar still looking
15:05:14 <shague> #topic [WIP] daya to look into csits for new features
15:06:11 <shague> #info daya still checking
15:06:28 <shague> #topic [DONE] daya to check code status with Gobinath for ofp code that ensures groups are programmed before flows using those groups - [73531](https://git.opendaylight.org/gerrit/#/c/73531/)
15:07:49 <shague> #info patch is pushed, gates passed
15:10:04 <shague> #info discussion on how to verify the patch, since netvirt has code to workaround the issue
15:10:31 <shague> #info can a marker log be included on the patch to show when the condition hits
15:10:49 <shague> #topic [DONE] skitt remove original monitor tool from int/test - [74132](https://git.opendaylight.org/gerrit/#/c/74132/)
15:11:03 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/project:
15:11:05 <shague> netvirt+status:open+branch:master)
15:16:36 <shague> #info some tx patches not in yet, fibmanager and elanmanager, failing some csit's
15:18:17 <shague> #info may not make it by 8/7/18
15:18:39 <shague> #info skitt to possibly enable the checker restriction for modules that have the changes already
15:20:00 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes - [oxygen patches](https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open+branch:stable/oxygen)
15:23:14 <shague> #topic OVS 2.9.2 and kernel modules
15:26:16 <shague> #info will still need kernel modules evne if we have the userspace ovs 2.9.2 packages
15:28:25 <shague> #info venkat working on building ovs
15:28:45 <shague> #topic daya: ovsdb design around transaction chains and event queues - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-July/007280.html)
15:29:42 <shague> #info daya downstream investigations finding performance issues in ovsdb southbound
15:30:24 <shague> #info three main issues found:
15:30:31 <shague> #info Single queue mechanism for both config and event processing
15:30:38 <shague> #undo
15:30:38 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c2cd50>
15:30:42 <shague> #info 1. Single queue mechanism for both config and event processing
15:30:51 <shague> #info 2. Use of a single long running transaction chain causing huge heap allocations
15:31:00 <shague> #info 3. Full serialization via the single queue, vs using node id based serialization
15:31:41 <shague> #info muthu mentioned same design is used in ofp
15:32:22 <shague> #info leads to large and long gc latencies
15:33:12 <shague> #info muthu - bust ofp does not see the same problems
15:33:24 <shague> #undo
15:33:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c2c890>
15:33:28 <shague> #info muthu - but ofp does not see the same problems
15:38:10 <shague> #info single queue backing up because of initial node reads
15:38:29 <shague> #info vthapar: could use a cache for the node data
15:38:53 <shague> #info daya: use cluster listeners to help
15:41:18 <shague> #info clarify single queue - currently there is a dual queue, but single queue could help
15:43:57 <shague> #info vthapar seperate queues per switch and optimize per odl node
15:48:55 <shague> #info desire to get this into Fluorine sr1
15:49:21 <shague> #info need to get started on this if we want it in
15:53:22 <shague> #action daya to look into scheduling fixes
15:53:39 <shague> #topic clustering
15:54:02 <shague> #info jamoluhrsen received some akka debugging instructions from akka team
15:54:44 <shague> #info vpickard thought he found a new bug. after multiple restarts bundles fail to start
15:55:07 <shague> #info seed node could not rejoin cluster, causes blueprint to fail
15:57:47 <shague> #info tomp thinks it is an akka bug
15:58:13 <shague> #info jamoluhrsen is collecting debug to send to akka
16:00:38 <shague> #endmeeting