15:01:37 <shague> #startmeeting NetVirt Weekly 07/31/18
15:01:37 <odl_meetbot> Meeting started Tue Jul 31 15:01:37 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:37 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_07_31_18'
15:01:46 <jamoluhrsen> #info jamoluhrsen
15:01:47 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:01:49 <vthapar> #info Vishal
15:02:03 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_24_18/opendaylight-netvirt-netvirt_weekly_07_24_18.2018-07-24-15.01.html
15:03:05 <shague> vorburger: skitt: joining project call?
15:04:25 <faseelak> #info faseelak
15:05:27 <skitt> shague, yes
15:06:17 <shague> #topic [WIP] daya to look into scheduling fixes for ovsdb design around transaction chains and event queues
15:06:34 <shague> #info daya more observations are being found
15:06:49 <shague> #info daya more debugging underway
15:07:49 <shague> #info daya sill looking, as issues pop up will look to push patches
15:08:13 <shague> #info action daya suneelu to create jira to track issues
15:08:25 <shague> #https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/project:
15:08:27 <shague> netvirt+status:open+branch:master)
15:09:49 <sridharg> #info Sridhar Gaddam
15:09:57 <shague> #info chetan has a few nat patches to push
15:10:36 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes - [oxygen patches](https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open+branch:stable/oxygen)
15:14:27 <shague> #topic Enforce constrained tx's in some modules? If so, how to enable selectively for those modules that have been converted to constrained?
15:15:48 <shague> #info skitt there is an issue in checkstyle patch itself: https://git.opendaylight.org/gerrit/#/c/73686/
15:17:45 <vorburger> shague: can you open https://jira.opendaylight.org/browse/GENIUS-176 ?
15:19:36 <shague> #info vorburger: https://jira.opendaylight.org/browse/GENIUS-176 - need to keep working on jira
15:20:27 <shague> #info faseelak looking to find owners for the genius jira's
15:21:21 <shague> #info vorburger we need this jira in to enforce the managed transactions
15:23:07 <shague> #topic [OPNFLWPLUG-991](https://jira.opendaylight.org/browse/OPNFLWPLUG-991) : FRM: Flow Group Dependency support - [73531](https://git.opendaylight.org/gerrit/73531)
15:25:31 <shague> #info daya downstream sees the failure in restart tests
15:25:39 <shague> #info how can we verify the bug
15:26:48 <shague> #info vthapar should add a log when the ordering issue is hit
15:28:14 <shague> #info vthapar need help from ofp team to create test case that takes down node that is owner
15:28:59 <shague> #info aswins snat-conntrack would hit the issue more often
15:28:59 <aswins> #link https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-fluorine/9/robot/
15:30:05 <shague> #info aswins revert the patch to help increase likelikhood of hitting issue
15:30:21 <shague> #topic vorburger: Neutron SPEC dependency checks - [google doc](https://docs.google.com/document/d/1NrN9r_3O1yJKyS2o_MapurNqvUwyPxJANSfvAOvkXUg/edit)
15:31:10 <shague> #info vorburger neutron blindly returns 200 ok to neutron requests
15:31:23 <shague> #info no checks if the resources are actually created
15:32:30 <shague> #help vorburger looking for help and input on creating spec for the feature
15:32:57 <shague> #link https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-fluorine/9/robot/ - snat-conntrack ofp groups bug
15:33:27 <shague> #info daya asks if websockets updates will be part of the effort
15:33:36 <odp-gerritbot> Chetan Arakere Gowdru proposed a change to netvirt: 21->26 flow missing for NAT use case  https://git.opendaylight.org/gerrit/72662
15:35:41 <odp-gerritbot> Chetan Arakere Gowdru proposed a change to netvirt: 21->26 flow missing for NAT use case  https://git.opendaylight.org/gerrit/72662
15:38:10 <shague> #info vorburger needs help understanding the dependency map
15:39:55 <shague> #info vthapar create a jira with subtask's per each resource that owners can start adding the dependency tree
15:40:22 <shague> #action vorburger to create jira with subtasks
15:40:38 <shague> #action daya to help identify resources to help update the subtasks
15:44:14 <shague> #info daya solve problem in different groups, such as l2gw may not fit this model because of assumptions in the code
15:46:04 <shague> #info daya need to understand the driver architecture also
15:48:25 <shague> #info vthapar those updating the jiras should document if the driver needs work
15:50:11 <shague> #endmeeting