15:03:30 <shague> #startmeeting NetVirt Weekly 08/07/18
15:03:30 <odl_meetbot> Meeting started Tue Aug  7 15:03:30 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:30 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_08_07_18'
15:04:10 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:04:20 <vthapar> #info vishal
15:04:22 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_31_18/opendaylight-netvirt-netvirt_weekly_07_31_18.2018-07-31-15.01.html
15:04:41 <shague> #topic Review existing action items
15:05:18 <shague> #topic [DONE] vorburger to create jira with subtasks for Neutron SPEC dependency checks - [NEUTRON-158](https://jira.opendaylight.org/browse/NEUTRON-158)
15:05:38 <shague> #[WIP] daya to help identify resources to help update the subtasks
15:06:34 <shague> #info vthapar has pushed a patch for ports, will continue pushing other patches
15:06:43 <shague> #help others to help review the patches
15:09:01 <shague> vthapar: can you add info comments about what help you need?
15:09:35 <vthapar> #info review the n-odl current dependencies added to JIRAs, add any other dependencies that are not captured in n-odl yet
15:09:53 <shague> #info jhershbe_ tbd on dependency checks since n-odl does the checking, so no way to verify patches
15:10:09 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/project:
15:10:11 <shague> netvirt+status:open+branch:master)
15:11:30 <shague> #topic https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes - [oxygen patches](https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open+branch:stable/oxygen) - [SR3 Signoff](https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=392785629)
15:11:53 <shague> #action shague jamoluhrsen to look at the signoff sheet
15:13:25 <shague> #topic Fluorine code freeze, branching workflow
15:14:33 <faseelak> #info faseelak
15:15:14 <faseelak> #info once branch cut is done, continue working on master, and cherry-pick patches as relevent to stable/fluorine
15:16:17 <shague> #topic Fluorine blocker bugs
15:17:09 <shague> #info https://jira.opendaylight.org/browse/OPNFLWPLUG-1028 is a potential blocker bug
15:23:24 <shague> #topic skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices
15:25:12 <shague> #info vthapar https://git.opendaylight.org/gerrit/#/c/74026/ broken ut
15:25:27 <shague> #info vthapar stll working on patch
15:26:11 <shague> #info patches are nto blockers
15:26:29 <shague> #topic [NETVIRT-1015](https://jira.opendaylight.org/browse/NETVIRT-1015) - leader down, nodes quarantined, cluster in bad shape so reads fails - what should the applications do?
15:28:17 <odp-gerritbot> Faseela K proposed a change to netvirt: COE should not program L3 flows for service-gateway port  https://git.opendaylight.org/gerrit/74922
15:29:12 <shague> #info the cluster is in a bad state so all ds operations fail
15:31:56 <shague> #info tomp mentions this might be a dup of CONTROLLER-1849
15:32:41 <shague> #info tomp - need to characterize what the test is doing, what node is restarted, which shard is in use
15:33:35 <shague> #info can tooling be developed that can show the requested information
15:33:46 <shague> #info jhershbe_ says skitt has started a tool
15:35:52 <vorburger> shague: et all, I'm in the middle of coding something and thus not on the call, if there is anything you need me for just raise me here and I'll reply by chat
15:36:19 <shague> vorburger: thanks, no problem now
15:37:54 <shague> #info daya_k do these exceptions matter if the datapath is still working
15:40:13 <vthapar> jhershbe_, https://jenkins.opendaylight.org/sandbox/user/thapar/my-views/view/MyView/job/thapar-controller-csit-3node-clustering-ask-all-oxygen/
15:40:22 <vthapar> jhershbe_, https://jenkins.opendaylight.org/sandbox/user/thapar/my-views/view/MyView/job/thapar-controller-csit-3node-clustering-tell-all-oxygen/
15:40:35 <jhershbe_> vthapar, thanks
15:47:47 <shague> #daya_k e/// downstream has a cluster health check script
15:47:59 <shague> #info the script can be used in csit to know the test state
15:50:37 <shague> #info daya_k does a quarantined node mean the other two nodes are still connected?
16:04:05 <shague> #info daya_k should add more checks in tests to verify the cluster is good, otherwise just fail tests
16:04:26 <shague> #info would need to adapt for scale
16:06:06 <rovarga_> guys, are you joining the Kernel Projects Call?
16:06:22 <shague> yes, switching now
16:06:38 <rovarga_> we have topics, started without you :)
16:07:22 <shague> #endmeeting