15:02:00 <shague> #startmeeting NetVirt Weekly 08/21/18
15:02:00 <odl_meetbot> Meeting started Tue Aug 21 15:02:00 2018 UTC.  The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:00 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_08_21_18'
15:02:07 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:16 <vpickard> #info vpickard
15:02:18 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_08_14_18/opendaylight-netvirt-netvirt_weekly_08_14_18.2018-08-14-15.02.html
15:02:20 <skitt> #info skitt
15:02:21 <vthapar> #info Vishal
15:03:21 <shague> #topic Review existing action items
15:06:10 <jamoluhrsen> #info jamoluhrsen
15:06:26 <shague> ssh: Could not resolve hostname 10.30.170.47,10.30.170.30,10.30.170.42: Name or service not known
15:06:39 <jamoluhrsen> you gotta link for this?
15:06:49 <shague> https://jenkins.opendaylight.org/sandbox/user/thapar/my-views/view/MyView/job/thapar-netvirt-csit-3node-0cmb-1ctl-2cmp-openstack-pike-upstream-stateful-neon/4/consoleFull
15:07:21 <shague> #topic [DONE] shague jamoluhrsen find out info on release candidates. 8/23/18 is the date the RC should be signed-off
15:08:23 <shague> #topic [DONE[ ask patch writer how long the quagga takes to install or should this bake into the tools vms. The time is < 1m. Ask was made to move to use packer to also avoid install failures.
15:09:50 <shague> #info current plan to install into the packer vms
15:10:24 <shague> #topic [WIP] aswin to work on patch for https://jira.opendaylight.org/browse/NETVIRT-1395
15:10:39 <shague> #info aswin looking at it after finishing other patches
15:10:51 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - final Checkpoint: 8/23/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/
15:10:52 <shague> project:netvirt+status:open+branch:master) - [Release Schedule](https://docs.opendaylight.org/en/latest/release-process/release-schedule.html)
15:11:28 <shague> #topic upstreaming useful tools, i.e. neutron and odl consistency scripts, flow consistency scripts. Also adding to odltools
15:12:16 <shague> #info vthapar odltools has new analysis tools in current version
15:12:33 <shague> #info vthapar additions across oxygen, fluorine and neon
15:12:49 <shague> #help vthapar asking for contributors
15:14:16 <shague> #info daya asks about shard leader scripting
15:14:27 <shague> #info vthapar faseela has already migrated script to odltools
15:15:26 <shague> #info vthapar request for flow consistency checks
15:16:18 <shague> #info daya could add a flow diff checker for 3node tests
15:16:45 <shague> #info vthapar should create jiras on odltools for new features
15:18:52 <shague> #info shague keep adding documentation to testing and troubleshooting document
15:19:37 <shague> #link https://git.opendaylight.org/gerrit/#/c/74808/
15:20:46 <shague> #topic HAProxy configuration should be updated to use diagstatus: [ooo haproxy config](https://github.com/openstack/puppet-tripleo/blob/master/manifests/haproxy.pp#L1531), [downstream patch](https://review.openstack.org/#/c/581790/2/manifests/haproxy.pp), odl uses: [odl haproxy config](https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/integration-deploy-openstack-run-test.sh#L490)
15:23:05 <shague> #info downstream uses diagstatus to determine node status
15:23:13 <shague> #info this hsould be upstreamed
15:24:00 <shague> #action shague to look at adding the diagstatus to upstream
15:24:19 <shague> #topic Adding DPDK to CSIT
15:25:21 <shague> #info venkat looking at adding ovs dpdk package to the csit
15:25:44 <shague> #info need hostconfig
15:26:10 <shague> #info daya also need binding to nic, and other switch configuration
15:29:18 <shague> #info need to find way to install dpdk in virtual environment
15:31:58 <shague> #info aswin ovs 2.8 and later required for snat-conntrack
15:32:09 <shague> #info daya mentions maybe it needs to be at least 2.9.1
15:32:13 <shague> #info daya mentions maybe it needs to be at least 2.9.2
15:35:00 <shague> #info daya gre tunnel impl is in ovs 2.8.1 so it is needed
15:35:38 <shague> #info other issues so 2.9.2 is required
15:37:36 <shague> #info daya switch restart tests, by default client and server mode has issues, ovs 2.8 has a new client mode
15:38:59 <shague> #info daya will send email with versions to adapt the tests
15:39:44 <shague> #topic skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices
15:40:29 <shague> #info elan and vpn patches are still outstanding for the constrained tx's
15:46:13 <shague> #info skitt: adding support for tx chains in managed tx's
15:54:08 <shague> #endmeeting