15:01:40 <vthapar> #startmeeting NetVirt Weekly 10/09/18
15:01:40 <odl_meetbot> Meeting started Tue Oct  9 15:01:40 2018 UTC.  The chair is vthapar. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:40 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_10_09_18'
15:01:51 <vthapar> #topic Roll call and agenda bashing (please #info <your-nick>)
15:03:44 <vthapar> #info Vishal
15:03:55 <skitt> #info skitt
15:03:58 <vpickard> #info vpickard
15:04:02 <jamoluhrsen> #info jamoluhrsen
15:04:03 <jhershbe_> #info jhershbe_
15:04:10 <vthapar> #link https://trello.com/c/O9x0EXaZ/44-2018-netvirt-project-meeting-details-agenda-and-previous-meetings Trello board
15:05:52 <Hanamantagoud> #info Hanamantagoud
15:06:34 <aswins> #info Aswin
15:06:44 <vthapar> #topic review previous action items
15:06:53 <vorburger> #info vorburger
15:08:05 <sridharg> #info Sridhar Gaddam
15:08:28 <vthapar> #info aswins says conntrack jobs failing sporadic and failures don't seem to be conntrack specific though more frequent in conntrack suite
15:08:50 <jamoluhrsen> https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/netvirt%20csit/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-oxygen/79/robot/
15:09:19 <Hanamantagoud_> #info Hanamantagoud
15:09:34 <vthapar> #action jamoluhrsen to share list of all failures
15:09:38 <vthapar> #action aswins to review the failures
15:09:45 <jamoluhrsen> aswins: another connectivity issue: https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/netvirt%20csit/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-neon/49/robot/
15:10:31 <vthapar> #topic Neon Release planning
15:10:50 <vthapar> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#
15:15:15 <vthapar> #topic Neon DDF Recap
15:15:41 <vthapar> #action daya to send out list of DDF notes
15:19:58 <vthapar> #info refactoring yang models in netvirt to reduce internal models
15:20:27 <vthapar> #info #improve code coverage for netvirt by adding more UTs
15:20:47 <vthapar> #info Netvirt gate jobs for auto gating all merges
15:21:14 <vthapar> #topic Neon MRI bump status
15:21:55 <vthapar> #info skitt netvirt should be good to go, had to disable 3 UTs.
15:22:11 <vthapar> #info one of them about yangtools being more strict which caused issues with genius
15:23:58 <vthapar> #info vorburger says genius was building fully locally
15:24:22 <vthapar> #info quick multipatch now passes
15:25:42 <vorburger> #link https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-neon/62/
15:27:07 <vthapar> #info there are failures in netvirt jobs
15:27:18 <vthapar> #action jamoluhrsen to look into failures
15:30:04 <vthapar> #info full multipatch needs to pass before we start merging
15:35:42 <vthapar> #action vorburger to send mail on csit status on mri patch
15:36:31 <vthapar> #topic CSIT sporadic failures
15:36:48 <vthapar> #link https://jira.opendaylight.org/browse/OPNFLWPLUG-1039
15:37:03 <vthapar> #link https://jira.opendaylight.org/browse/NETVIRT-1441
15:37:13 <vthapar> #link https://jira.opendaylight.org/browse/NETVIRT-1372
15:37:30 <vthapar> #info Karthik and som looking into NETVIRT-1441 and NETVIRT-1372
15:41:59 <vthapar> #topic Netvirt automated gate status
15:42:21 <vthapar> #info job in sandbox is already working, currently taking 45 minutes
15:43:06 <vthapar> #info this job is currently running l2 and external with a few tests skipped
15:45:16 <vthapar> #action jamoluhrsen to send mail with link to robot results for gatejob runs in sandbox so all can review the tests that are part of it
15:46:01 <vthapar> #topic jumbo frames
15:47:08 <vthapar> #info vpickard tested ping across VMs in same network and across different networks, it worked
15:48:00 <vthapar> #info vpickard found that ping to external network interface didn
15:48:07 <vthapar> #undo
15:48:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29caa90>
15:48:15 <vthapar> #info vpickard found that ping to external network interface didn't work
15:55:39 <vthapar> #info how to handle jumbo frames? return supported mtu size through ICMP to reconfigure through pmtu discovery, or configure higher mtu on external interface?
15:59:35 <vthapar> #info would be good if we can give appropriate icmp message
16:02:33 <vthapar> #action vpickard to check with OVN team on how they're looking to solve this.
16:02:56 <vthapar> #cookies
16:03:01 <vthapar> #endmeeting