15:01:58 <vpickard> #startmeeting NetVirt Weekly 5/22/2018
15:01:58 <odl_meetbot> Meeting started Tue May 22 15:01:58 2018 UTC.  The chair is vpickard. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:58 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_5_22_2018'
15:02:14 <vpickard> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:32 <vpickard> #link https://trello.com/c/O9x0EXaZ/44-2018-netvirt-project-meeting-details-agenda-and-previous-meetings Trello board
15:03:12 <skitt> #info skitt
15:03:49 <jhershbe> #info jhershbe
15:03:58 <jamoluhrsen> #info jamoluhrsen
15:05:09 <vpickard> #topic [WIP] vthapar and shague to discusss how to update specs for odltools - some initial discussions but nothing concrete yet
15:06:09 <vpickard> #topic [DONE] shague to clarify license issue, start with apache - Switch to using Eclipse licence use by ODL projects, the RDO team indicates the license is an accepted Fedora license that meets their requirements
15:06:16 <jamoluhrsen> #info need to circle back with shague about the odltools license task.
15:06:28 <vpickard> #topic [DONE] vivekn to request devs to update pipeline.rst with flow updates
15:07:55 <vpickard> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400)
15:08:10 <jamoluhrsen> #info we have no good/automatic way to validate the flow pipeline (.rst, ppt) are kept up to date
15:09:08 <jamoluhrsen> #info fluorine seems on track
15:09:11 <vpickard> #topic [csit:exception](https://jira.opendaylight.org/issues/?filter=10116) - many exceptions and some random failures came in two weeks ago, so we have been holding off merging patches. Two weeks ago we merged 8 patches. Maybe we should revert and then work our way back slowly.
15:10:06 <jamoluhrsen> #info fluorine is suffering from new random failures and new exceptions showing up.
15:13:49 <jamoluhrsen> #info vivek says the new exceptions and failures are mostly related to the tempest.api.network superset of tests. those run in parallel, but they are hard to debug.
15:15:34 <vpickard> #info tempest api tests run in parallel, making it difficult to debug.
15:15:59 <vpickard> #info running 8 threads in tempest api test suite
15:17:30 <jamoluhrsen> #action jamoluhrsen to respond to viveks email about an idea to run tempest.api.network tests one at a time with the extra ROBOT log in karaf.log
15:18:03 <vpickard> #topic [TSC-99](https://jira.opendaylight.org/browse/TSC-99) - weather item for rpc changes. Patches are ready - thanks to Tom on NetVirt patch! Likely instability when those start merging soon.
15:19:26 <vpickard> #topic [TSC-101](https://jira.opendaylight.org/browse/TSC-101) - weather item for getKey() changes. That will be next to go in once the multipatch and csit passes. [72099](https://git.opendaylight.org/gerrit/#/c/72099/) - thanks again to Tom
15:20:36 <vpickard> #topic specs: [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#)
15:24:22 <vpickard> #topic [Vic] Present IGMP Snooping spec
15:34:57 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/71179/ <-- igmp snooping spec
15:46:56 <jamoluhrsen> #action jamoluhrsen to add a gerrit comment about how to simulate mcast query (i.e., how to test router sourced mcast traffic)
15:48:05 <vpickard> #topic adding support for evpn rt3 spec review
16:08:41 <vpickard> #endmeeting