#opendaylight-neutron: neutron northbound

Meeting started by regXboi at 16:04:04 UTC (full logs).

Meeting summary

    1. edwarnicke (edwarnicke, 16:04:14)
    2. regXboi (regXboi, 16:04:20)
    3. dfarrell07 (dfarrell07, 16:04:41)
    4. tbachman (tbachman, 16:04:47)
    5. https://wiki.opendaylight.org/view/NeutronNorthbound:Lithium_Release_Plan current NN Lithium status (regXboi, 16:05:26)
    6. https://git.opendaylight.org/gerrit/16144 <- Our features patch to integration (edwarnicke, 16:07:34)
    7. ACTION: flaviof to send out email to folks on how to migrate to the new neutron features, with a time a week out for when those features coming from controller will be deactivated (aka, no longer work, and thus no longer collide) (edwarnicke, 16:11:00)
    8. ACTION: edwarnicke to list karaf features on project page and update status to green (regXboi, 16:18:23)

  1. documentation (regXboi, 16:19:20)
    1. ACTION: regXboi to draft outlines of developer and contributer docs over the weekend and will post links onto the project page (regXboi, 16:21:21)

  2. testing (regXboi, 16:21:29)
    1. AGREED: We have a basic need to be able to test that we have not hammered the basic translation part of the rest API (regXboi, 16:22:54)
    2. ACTION: regXboi to write a dummy provider that answers 200 for all can I*Aware interfaces and dumps the received neutron data in log for the rest of the I*Aware interfaces (regXboi, 16:26:51)
    3. https://gist.github.com/dfarrell07/c2433a7d44c85d77c897 (dfarrell07, 16:42:12)
    4. https://gist.github.com/dfarrell07/c2433a7d44c85d77c897 draft of ODL+O/S integration team plans (regXboi, 16:43:11)
    5. http://logs.openstack.org/07/161407/4/gate/gate-tempest-dsvm-networking-odl/78d4cd1/logs/testr_results.html.gz results of ODL/OS tempest smoke tests (regXboi, 16:48:20)
    6. we fail 56 of 528 (regXboi, 16:48:28)
    7. testing discussion to continue on IRC and mailing list (regXboi, 16:51:23)

  3. yang model (regXboi, 16:54:23)
    1. https://git.opendaylight.org/gerrit/#/c/15989/ a proposed yang model (regXboi, 16:54:36)
    2. proposal to break yang model into individual pieces based on the following analysis: (regXboi, 17:17:15)
    3. base neutron consists of networks, ports, & subnets (regXboi, 17:17:34)
    4. all other objects/modifications are parts of extensions (regXboi, 17:17:43)
    5. so if we assume that extensions are covered in separate models to allow for selection (regXboi, 17:18:08)
    6. then a review of http://developer.openstack.org/api-ref-networking-v2.html shows that extensions will include new network and ports yang models (regXboi, 17:18:34)
    7. at which point, we might as well break the original base into separate yang models (regXboi, 17:18:54)
    8. ACTION: - kkoushik to add all the extensions into a single model - After a review, it can be split up into multiple models (kkoushik, 17:21:11)
    9. ACTION: regXboi to set up meeting wiki page to capture meetbot minutes and create next agenda (regXboi, 17:22:55)

  4. chocolate muffins (regXboi, 17:24:49)


Meeting ended at 17:24:52 UTC (full logs).

Action items

  1. flaviof to send out email to folks on how to migrate to the new neutron features, with a time a week out for when those features coming from controller will be deactivated (aka, no longer work, and thus no longer collide)
  2. edwarnicke to list karaf features on project page and update status to green
  3. regXboi to draft outlines of developer and contributer docs over the weekend and will post links onto the project page
  4. regXboi to write a dummy provider that answers 200 for all can I*Aware interfaces and dumps the received neutron data in log for the rest of the I*Aware interfaces
  5. - kkoushik to add all the extensions into a single model - After a review, it can be split up into multiple models
  6. regXboi to set up meeting wiki page to capture meetbot minutes and create next agenda


Action items, by person

  1. edwarnicke
    1. edwarnicke to list karaf features on project page and update status to green
  2. flaviof
    1. flaviof to send out email to folks on how to migrate to the new neutron features, with a time a week out for when those features coming from controller will be deactivated (aka, no longer work, and thus no longer collide)
  3. kkoushik
    1. - kkoushik to add all the extensions into a single model - After a review, it can be split up into multiple models
  4. regXboi
    1. regXboi to draft outlines of developer and contributer docs over the weekend and will post links onto the project page
    2. regXboi to write a dummy provider that answers 200 for all can I*Aware interfaces and dumps the received neutron data in log for the rest of the I*Aware interfaces
    3. regXboi to set up meeting wiki page to capture meetbot minutes and create next agenda


People present (lines said)

  1. regXboi (203)
  2. edwarnicke (156)
  3. flaviof (39)
  4. mestery (25)
  5. dfarrell07 (20)
  6. tbachman (15)
  7. kkoushik (12)
  8. odl_meetbot (7)
  9. TNadeau (3)


Generated by MeetBot 0.1.4.