15:02:48 <regXboi> #startmeeting neutron_northbound
15:02:48 <odl_meetbot> Meeting started Fri Apr  3 15:02:48 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:48 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:02:56 <regXboi> #chair regXboi edwarnicke
15:02:56 <odl_meetbot> Current chairs: edwarnicke regXboi
15:03:07 <edwarnicke> #info edwarnicke
15:03:16 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.284.2F3.29 agenda
15:03:21 <regXboi> #info regXboi
15:03:27 <regXboi> others who are here, please info in
15:03:40 <regXboi> #topic roll call + agenda bashing
15:04:04 <regXboi> I've made no progress on #1
15:04:05 <regXboi> so
15:04:08 <regXboi> #action regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
15:04:21 <regXboi> edwarnicke: have you looked at the documentation patch?
15:04:22 <edwarnicke> regXboi: many thanks
15:04:44 <regXboi> if not
15:04:44 <edwarnicke> I thought I +1 ed it
15:04:50 <regXboi> cool
15:05:06 <regXboi> let me check it
15:05:18 <regXboi> yeah you did
15:05:19 <regXboi> so
15:05:44 <regXboi> #action edwarnicke, flaviof to review current doc patch
15:05:56 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/
15:05:59 <regXboi> #undo
15:05:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b983d0>
15:06:09 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ current documentation patch
15:06:15 <regXboi> action item 3 is done
15:06:17 <regXboi> yea!
15:06:32 <regXboi> #info action items 3 and 4 are done
15:06:46 <regXboi> #info action item 5 is done
15:07:01 <edwarnicke> Doc patch reviewed
15:07:14 <regXboi> #action  flaviof to work karaf system test for merge, integration, and RC events
15:07:21 <kkoushik_> #info kkoushik
15:07:24 <regXboi> #info action item 7 is ongoing ... so
15:07:34 <regXboi> #action  Shreshtha_ to put together junit testing for some apis this week
15:07:42 <Bhavesh_> Hi All,
15:07:51 <regXboi> #info action item 8 is going to be deferred to after lithium
15:08:00 <regXboi> so we are putting it aside
15:08:09 <regXboi> and I didn't do action item 9, so
15:08:17 <regXboi> #action regXboi to float mini-hackathon trial balloon to mailing list
15:08:31 <regXboi> well we got rid of 3 of the 9
15:08:35 <regXboi> I guess that's something
15:08:41 <regXboi> #topic M4 status
15:08:46 <Bhavesh_> Me and Shreshtha have submitted patches of the Junit tests for the LoadBalancer, Routers, Security, Port and meters
15:08:59 <regXboi> #info M4 deadline was 4/2 and we are currently yellow
15:09:12 <edwarnicke> Bhavesh_: Many thanks :)
15:09:23 <regXboi> Bhavesh: yes, we've been reviewing/merging them - many thanks!
15:09:32 <regXboi> #info API freeze is done
15:09:33 <Bhavesh_> Thank you :)
15:09:54 <regXboi> #info documentaiton is 50% done - we need how to write the yang model side
15:10:12 <regXboi> #info Maven Central requirements are done - that patch got merged this morning
15:10:21 <regXboi> #info integration and system test is the big mess
15:10:53 <regXboi> #info current ETA reported for I&ST is 4/10, but regXboi doesn't have much confidence
15:11:13 <regXboi> edwarnicke: any thoughts/insights/hopes?
15:11:31 <edwarnicke> Hmm
15:12:11 <regXboi> I can't think of anything to meet this other than what I need to do with action item #1
15:12:27 <edwarnicke> Can we break it down into pieces folks could pick up?
15:12:30 <regXboi> figure out the darn karaf setup/test process and hook it to jjb and declare victory
15:12:54 <edwarnicke> regXboi: ah... That piece
15:13:01 <edwarnicke> So... Let me find the patch
15:13:04 <regXboi> edwarnicke: yeah
15:13:17 <edwarnicke> I got much of that figured out
15:13:38 <edwarnicke> And then shague_ took it either to the finish line or damn close
15:14:03 <regXboi> ah, if we have a pattern to run with, then I think that would help mightily
15:15:03 <edwarnicke> https://git.opendaylight.org/gerrit/#/c/17599/
15:15:28 <Bhavesh_> Me and the team are going to submit more patches on Junit JAXB in the coming week
15:15:39 <edwarnicke> Bhavesh_: :)
15:16:00 <regXboi> thanks, Bhavesh_
15:16:08 <Bhavesh_> If we can contribute more in any area, then please let us know
15:16:39 <edwarnicke> regXboi: do we have a feature for the dummy provider?
15:16:47 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/17599/ patch to act as pattern for karaf testing
15:16:57 <regXboi> edwarnicke: I *think* so, but I'm not 100% sure
15:17:12 <edwarnicke> Ok
15:17:35 <regXboi> edwarnicke: I stand corrected, we do not
15:17:43 <edwarnicke> Ack
15:17:56 <regXboi> can I action you for that?
15:18:23 <edwarnicke> Sure :)
15:18:38 <regXboi> #action edwarnicke to add karaf feature for dummy provider
15:18:54 <regXboi> #action regXboi to look at karaf testing pattern link
15:19:06 <regXboi> then I think we are ready to move to the next topic
15:19:07 <regXboi> which is
15:19:18 <regXboi> #topic M5
15:19:40 <regXboi> we need to fill in the NB pieces that currently return 501
15:19:50 * edwarnicke feels like the milestones never end
15:19:59 <regXboi> and the transcriber needs code for the yang model
15:20:04 <edwarnicke> Do we have a list?
15:20:13 <regXboi> list how?
15:20:23 <regXboi> you mean list of what we need to do or list of NB pieces that return 501?
15:20:24 <edwarnicke> Of the 501
15:20:36 <regXboi> oh... I can generate one pronto
15:21:09 <edwarnicke> Cool
15:21:20 <edwarnicke> Could be broken down and worked that way :)
15:21:45 <regXboi> NeutronMeteringLabelsNorthbound.java, NeutronVPNIKEPoliciesNorthbound.java, NeutronVPNIPSECSiteConnectionsNorthbound.java, NeutronVPNServicesNorthbound.java,
15:21:56 <regXboi> NeutronVPNIPSECPoliciesNorthbound.java, and NeutronMeteringLabelRulesNorthbound.java
15:22:03 <regXboi> so six classes
15:22:18 * regXboi just remembered dummy provider needs those classes added too
15:22:55 <regXboi> #action regXboi to extend dummy provider to cover new aware interfaces that were added to meet M4
15:23:12 <regXboi> anybody want to work on filling in those Northbound classes?
15:23:27 <regXboi> or work on the transcriber writing to the YANG models?
15:24:58 <regXboi> #info northbound classes that need filling in are NeutronMeteringLabelsNorthbound.java, NeutronVPNIKEPoliciesNorthbound.java, NeutronVPNIPSECSiteConnectionsNorthbound.java, NeutronVPNServicesNorthbound.java,NeutronVPNIPSECPoliciesNorthbound.java, and NeutronMeteringLabelRulesNorthbound.java
15:25:17 <regXboi> #info transcriber needs to write to the yang models
15:25:40 <regXboi> #info volunteers can either step up on the mailing list or (better yet) push code
15:26:12 <regXboi> #info For M5 the stability branch will need to be cut, but we'll table that for a couple of weeks - do that at the last minute
15:26:18 <regXboi> #undo
15:26:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b6fc50>
15:26:31 <regXboi> actually, edwarnicke, do you agree with that idea?
15:26:38 <regXboi> "For M5 the stability branch will need to be cut, but we'll table that for a couple of weeks - do that at the last minute"
15:26:40 <regXboi> ?
15:27:02 <edwarnicke> Yes
15:27:51 <regXboi> #agreed For M5 the stability branch will need to be cut, but we'll table that for a couple of weeks - do that at the last minute
15:28:16 <regXboi> we need to freeze strings, but somehow, I don't  think that will be a problem
15:28:29 <regXboi> we'll need to complete documentation :/
15:28:53 <regXboi> and we'll need to have a system test for each user-facing feature (do we have more than 1)?
15:29:12 <regXboi> but we'll talk about them more next week or on the mailing list
15:29:29 <regXboi> and so ....
15:29:35 <regXboi> #topic open discussion
15:29:50 <regXboi> opening the floor to any and all - have we missed any blind spots?
15:30:49 <Bhavesh_> We are looking to contribute more ...
15:31:24 <regXboi> Bhavesh_: are you folks comfortable with setting up the karaf related testing?
15:31:29 <Bhavesh_> If you have anything for us, then please let us know
15:31:41 <Bhavesh_> Yes, we are pretty comfortable
15:32:42 <regXboi> ok, then I'll pass you my action item on that patch
15:33:06 <Bhavesh_> regXboi: Yeah sure.
15:33:08 <regXboi> we need to basically set up a system that loads the NN karaf feature and the NN dummy provider karaf feature
15:33:18 <regXboi> and push REST in on the input side
15:33:30 <regXboi> and verify that the dummy provider sees the correct object on the output side
15:34:01 <regXboi> that will tell us that the NB->transcriber->*Aware path works
15:34:53 <edwarnicke> Bhavesh_: Thank you *so* much for all you have done and are willing to do
15:35:07 <regXboi> #action rather than roll back to the previous action Bhavesh_ and co will take up the karaf testing items
15:35:13 <edwarnicke> Bhavesh_: A big part of my questions like 'Can we break this down into small pieces' was hoping you guys would be willing to help more :)
15:35:24 <regXboi> Bhavesh_: yes thank you SO much
15:35:38 <edwarnicke> Bhavesh_: Ping me if you get stuck on the karaf testing stuff
15:35:44 <edwarnicke> Bhavesh_: I can talk you through a lot of it
15:36:01 <Bhavesh_> edwarnicke: Thank you for youe support
15:36:13 <regXboi> anything else?
15:36:17 <edwarnicke> Bhavesh_: question... any interest in doing the feature for the test-dummy (its a nice small piece of work that's helpful for learning about karaf features ;) )
15:37:17 <Bhavesh_> edwarnicke: Need to know about it more.. I and the team can pickup
15:37:27 <edwarnicke> Bhavesh_: Sure
15:37:30 <edwarnicke> Bhavesh_: So the idea is this
15:37:43 <edwarnicke> Bhavesh_: In order to be able to do basic testing of the neutron service
15:38:00 <edwarnicke> Bhavesh_: We need a 'dummy-feature' that doesn't really do anything except claim it can service any request
15:38:32 <regXboi> the java code for that already exists
15:38:41 <edwarnicke> Bhavesh_: The reason we need this is because the neutron service will respond with an error if there is no provider to provider something (which is correct, but makes testing the neutron service itself hard)
15:38:51 <edwarnicke> Bhavesh_: Yep, regXboi wrote it :)
15:39:10 <edwarnicke> Bhavesh_: So we just need a feature for that dummy-provider, so you can start up karaf and install it
15:39:41 <Bhavesh_> So, basically I need to develop a dummy-feature
15:39:42 <edwarnicke> Bhavesh_: Do you know about karaf features and feature repos?
15:39:47 <edwarnicke> Bhavesh_: Yep :)
15:40:07 <Bhavesh_> edwarnicke: Yes, I knoe about the karaf features
15:40:14 <edwarnicke> Bhavesh_: But note: by feature here I just mean the xml in a karaf feature repo such that it can be loaded in karaf :)
15:40:18 <edwarnicke> Bhavesh_: Cool
15:40:25 <edwarnicke> Bhavesh_: Do you know about feature *repos* ?
15:40:45 <regXboi> hey - can I end the meeting?
15:40:53 <regXboi> you can continue this topic :)
15:41:16 * regXboi needs to go argue about syslog and threads with some code
15:41:29 <Bhavesh_> edwarnicke: not much
15:41:56 <edwarnicke> Bhavesh_: so if you look at a features.xml file, that's basically a feature 'repo' as far as karaf is concerned
15:42:02 <edwarnicke> Bhavesh_: Its just a collection of feature stuff
15:42:09 <regXboi> ok...
15:42:27 <regXboi> #topic no ending topic today
15:42:29 <edwarnicke> Bhavesh_: The reason I mention it, is that we *probably* don't want to publish the test-dummy in the same repo as our *actual* features, lest it confuse production consumers
15:42:31 <regXboi> #endmeeting