14:59:43 <regXboi> #startmeeting neutron_northbound
14:59:43 <odl_meetbot> Meeting started Fri Apr 10 14:59:43 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:43 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
14:59:53 <regXboi> #topic info in and agenda bashing
15:00:24 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in its usual place
15:00:28 <regXboi> #info regXboi
15:01:43 <regXboi> anybody?
15:03:31 <flaviof> #info flaviof
15:04:23 <regXboi> still looking for folks to #info in if they are listening
15:04:30 <flaviof> argh... I did not review the doc patch
15:04:46 <adetalhouet> #info adetalhouet
15:05:00 <regXboi> flaviof: I think it got merged
15:05:13 <Bhavesh> #info Bhavesh
15:05:18 <flaviof> regXboi: oh cool. Looks like Colin saved the day/
15:05:20 <flaviof> my bad
15:05:29 <regXboi> yes - it was merged
15:05:35 <regXboi> so you are off the hook on that one
15:05:38 <colindixon> ?
15:05:42 * flaviof phew
15:05:52 <regXboi> #info while flaviof didn't review the doc patch, colindixon merged it so we can close action item 1
15:06:15 <regXboi> #info we've seen a bunch of JAXB patches, so action item 2 continues
15:06:30 <regXboi> Bhavesh: are all the JAXB unit tests in?
15:06:46 <Bhavesh> regXboi: Yes ..
15:07:01 <regXboi> Bhavesh: cool - thanks!
15:07:09 <Bhavesh> regXboi: We have pushed all the Junit JAXB tests.
15:07:12 <regXboi> #info action item 2 can be closed, all JAXB unit tests are in
15:07:32 <regXboi> Bhavesh: I went in and changed the copyright to TCS on each of them - credit where credit is due
15:08:01 <regXboi> #action regXboi to float mini-hackathon trial balloon to mailing list
15:08:02 <Bhavesh> regXboi: Thanks !!!
15:08:07 <regXboi> Bhavesh: yw
15:08:14 * regXboi mumbles I really need to do that
15:08:56 <regXboi> folks: what that last action item is about is do we need to set up a few times during the week where we gather here and on a hangout and spend an hour or two writing code/doc/test to make the M5 push
15:09:05 <regXboi> I think we might need it
15:09:15 <regXboi> but finding the time is going to be the trick
15:09:45 <regXboi> Bavesh: any progress on the karaf testing items?
15:10:14 <Bhavesh> regXboi: I'm working on creating feature-repo for dummyprovider
15:10:32 <Bhavesh> regXboi: Done with the o
15:10:43 <Bhavesh> pom.xml and features.xml
15:11:09 <Bhavesh> regXboi: Facing build issue with neutron
15:11:11 <regXboi> Bhavesh: ok, if you have something that you need help with, you can either reach out here or push the patch and ask for help with it
15:11:45 <regXboi> #info dummy provider feature-repo still being worked
15:11:56 <regXboi> #action ALL we still need testing :(
15:11:57 <Bhavesh> regXboi: Yeah sure, But I think once I need to sync with edwarnicke on this
15:12:25 <regXboi> Bhavesh: if you can't find him here - I'd say push a patch and then we'll all hunt him down
15:12:43 <regXboi> #info dummy provider has been updated
15:12:51 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/17791/ dummy provider extension patch
15:13:05 <regXboi> and that covers the action items
15:13:19 <regXboi> #topic Missing M4 Items
15:13:42 <regXboi> we still need a volunteer to write the YANG side of the documentation
15:13:45 <regXboi> anybody?
15:14:26 <regXboi> and we have the action item above for testing, but we really need to get that done, as we had given an ETA of today for M4 testing and we aren't there
15:15:13 <regXboi> #action ALL need a volunteer for how to write a consumer of the neutron yang model
15:15:26 <adetalhouet> I could do that
15:15:32 <regXboi> #undo
15:15:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x18b7510>
15:15:53 <regXboi> #action adetalhouet to write documentation for how to write a consumer of the neutron yang model
15:15:57 <regXboi> adetalhouet: sold
15:16:15 <regXboi> any other thoughts on M4 (going once)
15:16:22 * regXboi counts to 10
15:16:46 <adetalhouet> regXboi: but I might need some intel about what it does and how it works as I new to this project. Could you privde guidance for that?
15:17:15 <regXboi> adetalhouet: I think we can scrape up a resource to help you with that
15:17:19 <regXboi> and I know the resource
15:17:22 <regXboi> #undo
15:17:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1babad0>
15:17:42 <regXboi> #action adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
15:17:55 <regXboi> any other thoughts on M4 (going twice)
15:17:55 <adetalhouet> regXboi: great, appreciated
15:18:01 <regXboi> adetalhouet: yw
15:18:18 <regXboi> #topic M5 (what needs to be done)
15:18:27 <regXboi> ok... first item on M5 is code freeze
15:18:43 <regXboi> we need to finish the unimplemented northbound interfaces
15:19:10 <regXboi> what is missing is ... NeutronVPNIPSECSiteConnectionsNorthbound and NeutronVPNServicesNorthbound
15:19:26 <regXboi> I think we had a volunteer for NeutronVPNServicesNorthbound, but I have forgotten who
15:19:41 <regXboi> and we could use a volunteer for the other
15:19:44 <regXboi> any takers?
15:20:10 <Bhavesh> regXboi: Can I go with this ?
15:20:44 <regXboi> Bhavesh: if you have time, sure - you can use the other NeutronVPN* commits that were merged today as patterns
15:21:22 <regXboi> #action Bhavesh and co to fill in NeutronVPNIPSECSiteConnectionsNorthbound and NeutronVPNServicesNorthbound
15:21:34 <Bhavesh> regXboi: Yeah sure ..
15:21:48 <regXboi> The other thing we need is YANG code for the transcriber
15:22:07 * regXboi wanted to tab edwarnicke for this, but he seems to be awol
15:22:43 <regXboi> so I'm going to tentatively action him and we'll work it out
15:23:05 <regXboi> #action edwarnicke (tentatively) to code transcriber to talk to YANG model
15:23:43 <regXboi> fortunately we can skip the stability branch until 4/24
15:23:59 <regXboi> afaik, we don't have any strings to freeze
15:24:06 <regXboi> so we are ok on that
15:24:21 <regXboi> and we've got a volunteer for the documentation
15:24:37 <regXboi> and we're working the test items as well... so
15:24:45 <regXboi> #topic Other Topics (open discussion)
15:24:53 * regXboi throws open the floor
15:25:07 <regXboi> alagalah: you want to ask your securitygroups question here?
15:25:18 <alagalah> regXboi: Sure
15:26:16 <alagalah> #info When I do a "neutron security-group-create" I see nothing in wireshark for REST calls to ODL.
15:26:46 <alagalah> #info I have flavio's latest devstack, and set local.conf to pull everything #OFFLINE=True RECLONE=Yes
15:27:19 <regXboi> alagalah: I know you pulled a wireshark pcap - do you have an ascii version that we can #link in?
15:27:20 <alagalah> #info It stacks correctly, and I do see REST for net-create, subnet-create (and subsequent port create for the DHCP server)
15:27:30 <alagalah> hold 1
15:29:23 <regXboi> #info regXboi to help alagalah get wireshark into ascii format that all can look at
15:29:52 <alagalah> tyring libpcap
15:30:17 <regXboi> ok I got it
15:31:16 <regXboi> #link http://pastebin.com/ux8Zp0VL alagalah's pcap
15:31:29 <regXboi> tcpdump to the rescue
15:32:10 <alagalah> regXboi: Thanks... all the instructions I found were for windows version :( which lets you save As :)
15:32:36 <regXboi> #info alagalah, I think we need mestery for this one - it looks from this pcap that neutron isn't sending the securitygroups/rules related stuff to ODL
15:33:03 * regXboi goes off to ping mestery
15:33:05 <alagalah> #info correct
15:33:11 <flaviof> alagalah: iirc, there is some securityGrp info in the neutron port object.
15:33:22 <mestery> We should be adding security group info to port requests.
15:33:50 <regXboi> mestery: but that is only half the battle
15:33:50 <mestery> alagalah regXboi: https://github.com/stackforge/networking-odl/blob/master/networking_odl/ml2/mech_driver.py#L74
15:33:55 <mestery> regXboi: What's the other half?
15:34:13 <regXboi> getting the actual security group and rule POSTs?
15:34:47 <regXboi> alagalah: can you pull the server log from devstack and pastebin it
15:34:48 <alagalah> flaviof: yes, but that is not sufficient. mestery if I add a rule to an existing security group that is associated with a port, I don't get any update.
15:34:58 <flaviof> ack
15:35:21 <mestery> alagalah: Right, we're not pushing that now. File a bug in stackforge/networking-odl and we can make it work.
15:36:02 <regXboi> alagalah: does that meet your need?
15:36:17 <flaviof> #link https://bugs.launchpad.net/networking-odl launchpad for bugs in networking-odl
15:36:19 <alagalah> mestery: Ok, do we expect to also receive REST for just straight security group information? Or is it going to be via port API ?
15:36:43 * regXboi thinks we had better get straight group/rule information
15:37:15 <mestery> alagalah: We're not passing anything security group related at the moment other than what comes with the ports, we'll have to look into the straight REST
15:37:19 <regXboi> alagalah: write the bug to request that securitygroup and securityrule items get pushed to ODL
15:37:30 <alagalah> regXboi: mestery Ok no worries, will do, thanks
15:37:40 <regXboi> alagalah: remember, you are writing the bug
15:37:45 <regXboi> write it for what you want :)
15:38:04 <alagalah> regXboi: mestery Will do, thanks all.
15:38:07 <regXboi> ok - any other open topics ?
15:38:11 * regXboi counts to 10
15:38:28 <regXboi> going twice?
15:38:34 * regXboi counts to 10
15:39:07 <regXboi> #topic chocolate chip muffins (to be different)
15:39:13 <regXboi> thanks all!
15:39:16 <regXboi> #endmeeting