14:59:45 <regXboi> #startmeeting neutron_northbound
14:59:45 <odl_meetbot> Meeting started Fri Apr 17 14:59:45 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:45 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
14:59:52 <regXboi> #chair edwarnicke flaviof
14:59:52 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
14:59:52 <edwarnicke> #info edwarnicke
14:59:58 <regXboi> #info regXboi
15:00:00 <flaviof> #info flaviof
15:00:12 <regXboi> #topic agenda bashing (folks can info in)
15:00:29 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
15:00:33 <regXboi> #undo
15:00:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19d7d10>
15:00:43 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in the usual place
15:00:43 <Bhavesh> #info Bhavesh
15:00:59 <regXboi> edwarnicke: I moved your topic down in the list, but we will get to it
15:01:11 <regXboi> any changes to the agenda?
15:01:18 * regXboi counts to 10
15:01:34 <regXboi> going twice?
15:01:41 * regXboi counts to 10 again
15:02:07 <regXboi> ok hten
15:02:15 <regXboi> #topic action items from last meeting
15:02:24 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-April/000110.html
15:02:32 <mestery> #info mestery
15:02:38 <regXboi> #info above link floated the minihackathon trial balloon
15:02:40 <regXboi> no takers
15:02:51 <regXboi> #info no takers yet, so I doubt it will happen
15:03:14 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/18356/ WIP patch for E2E testing
15:03:25 <regXboi> #info jenkins has +1'd it *BUT* see
15:03:38 <regXboi> #link http://pastebin.com/vT3hfGhy for why I'm not happy
15:04:02 <regXboi> #info we aren't resolving the northbound-api dependencies correctly and I'm struggling with how to make pax exam happy
15:04:17 <regXboi> adetalhouet: you around?
15:04:22 <flaviof> regXboi: I know shague has done a bunch of work on ovsdb to make pax-exam work
15:04:36 <adetalhouet> #info adetalhouet
15:04:38 <flaviof> regXboi: mavenBundles are a pain
15:04:42 <regXboi> flaviof: ack
15:04:54 <adetalhouet> regXboi: Yes right there :)
15:05:02 <regXboi> adetalhouet: hi, any update on documentation action item?
15:05:10 <edwarnicke> regXboi: Are you using features?
15:05:30 <regXboi> edwarnicke: yes, and that error is in the feature-parent single feature tests as well
15:05:42 <edwarnicke> Ah
15:05:49 <edwarnicke> regXboi: OK then, our features are broken, what's the error?
15:06:03 <regXboi> edwarnicke: see the pastebin link
15:06:08 <adetalhouet> regXboi: for now I haven't done much thing on the documentation as I need a little help and how to start, regarding what you expect
15:06:20 <flaviof> edwarnicke: java.lang.ClassNotFoundException: org.eclipse.jetty.servlets.CrossOriginFilter not found by org.opendaylight.neutron.northbound-api [159]
15:07:04 <edwarnicke> regXboi: Are you getting that error on master?
15:07:14 <regXboi> adetalhouet: if you look at the other half of the documentation, it covers basic on what to do to make a provider for the I*Aware interfaces
15:07:27 <regXboi> adetalhouet: we need the same for what is listening to the YANG models
15:07:32 <adetalhouet> regXboi: yes I've seen it
15:07:37 <regXboi> edwarnicke: yes, that pastebin is from master
15:07:49 <edwarnicke> regXboi: The reason I ask
15:07:50 <regXboi> edwarnicke: wait
15:08:02 <edwarnicke> regXboi: Is its complaining about lack of a filter that should be provided by aaa
15:08:07 <edwarnicke> And we have the correct aaa feature
15:08:50 <adetalhouet> regXboi: I'm not sure I understand you well. What do you mean by "for what is listening to the YANG models" ? you're referring to the transaction that can be made?
15:09:13 <edwarnicke> regXboi: Master builds clean for me
15:09:18 <regXboi> sorry folks, browser is thrashing
15:09:20 <edwarnicke> regXboi: No SingleFeatureTest errors
15:09:32 <regXboi> edwarnicke: I cry BS
15:09:37 <regXboi> #link https://jenkins.opendaylight.org/releng/job/neutron-verify-master/jdk=openjdk7,nodes=dynamic_verify/138/consoleFull
15:09:38 <flaviof> edwarnicke: can you elaborate on how you concluded that it is "lack of a filter that should be provided by aaa" ?
15:09:45 <edwarnicke> flaviof: Sure
15:09:47 <regXboi> "java.lang.ClassNotFoundException: org.eclipse.jetty.servlets.CrossOriginFilter not found by org.opendaylight.neutron.northbound-api [158]"
15:10:32 <regXboi> adetalhouet: for a SB provider to use the YANG models, it needs to listen for notifications on the elements that the transcriber is going to write
15:10:34 <edwarnicke> flaviof: I did the feature packaging for restconf
15:10:41 <edwarnicke> flaviof: That file is mentioned in the web.xml
15:10:47 <regXboi> adetalhouet: we need to talk about how to do that
15:10:54 <edwarnicke> flaviof: And I happen to know from that experience that it is provided by the aaa-authn feature
15:11:10 * flaviof looking for web.xml
15:11:11 * regXboi checks merge-master
15:11:18 <edwarnicke> regXboi: That error is a runtime error though, and in my experience harmless (except it means you have no aaa... which is bad)
15:11:25 <adetalhouet> regXboi: ok
15:11:31 <edwarnicke> flaviof: Did that answer your question?
15:11:47 <regXboi> edwarnicke: except that when you are trying to test E2E
15:11:49 <regXboi> it's not so good
15:11:59 <edwarnicke> regXboi: I agree that its not so good
15:12:02 <regXboi> and yes, the problem is in merge master
15:12:05 <edwarnicke> regXboi: But I don't understand how it would break your testing
15:12:07 <regXboi> https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-merge-master/77/consoleFull
15:12:32 <regXboi> edwarnicke: simple, the test didn't run after that
15:12:47 <edwarnicke> regXboi: Wait
15:12:49 <edwarnicke> flaviof: Wait
15:12:51 <edwarnicke> I am wrong
15:12:55 <edwarnicke> That's the CrossOriginFilter
15:12:57 <edwarnicke> Not the aaa filter
15:13:05 <edwarnicke> So it is not causing us to not have aaa
15:13:07 <flaviof> edwarnicke: partially; I need to look at aaa-auth feature to see if I understood what you said. Thanks.
15:13:11 <edwarnicke> But its lack will break CORS :(
15:13:30 <edwarnicke> regXboi: Did you just start noticing this?
15:13:33 <regXboi> folks, we've raised the issue, let's move on
15:13:35 <edwarnicke> regXboi: In the last couple of days?
15:13:46 <regXboi> edwarnicke: ack, I noticed when I tried to fill in E2E
15:13:50 <edwarnicke> regXboi: Because if so, that filter might have been moved to a new feature in karaf 3.0.3 and we need to find out where
15:14:09 <regXboi> edwarnicke: I'll action you with that :)
15:14:13 <edwarnicke> LOL
15:14:27 <regXboi> #action edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from
15:14:37 <regXboi> #action adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
15:14:46 <regXboi> adetalhouet: we'll pull your action forward
15:14:54 <flaviof> regXboi: I manually triggered build #25. I think the issue was external, and has been resolved. (https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-integration-master/)
15:14:58 <adetalhouet> regXboi: no problem
15:15:08 <regXboi> flaviof: I'll look later
15:15:30 <regXboi> Bhavesh and co have finished the NB classes - I merged them this morning
15:15:35 <regXboi> and lastly
15:15:48 <regXboi> #edwarnicke to scare up a resource to code transcriber to talk to YANG model
15:15:57 <regXboi> heh
15:15:59 <Shreshtha> what can we contribute for next week
15:16:07 <regXboi> #action edwarnicke to scare up a resource to code transcriber to talk to YANG model
15:16:15 <regXboi> Shreshtha: we'll get there
15:16:25 <regXboi> something I forgot from last week:
15:16:33 <regXboi> #topic Trello Board
15:16:34 <Shreshtha> regXboi: sure
15:16:47 <regXboi> #info we have a trello board at https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound
15:17:10 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound the new trello board
15:17:27 <regXboi> #info send email to regXboi to be added
15:17:42 <regXboi> I'm trying to get everything in these meetings onto cards, but ...
15:17:59 <edwarnicke> adetalhouet: Shreshtha Ping me on IRC on Monday and we'll get you going on transcriber
15:18:02 <regXboi> #topic Bug Squashing
15:18:21 <regXboi> #link https://bugs.opendaylight.org/buglist.cgi?list_id=27656&product=neutron&query_format=advanced&resolution=---  our outstanding bug list
15:18:40 <regXboi> #info we have a bunch of Tempest errors from OpenStack - mestery is rerunning them and will update
15:18:50 <regXboi> #action mestery to update Tempest bugs based on reruns
15:19:07 <edwarnicke> #info some of those may be related to not getting all the neutron objects from the driver... more on that later :)
15:19:12 <regXboi> we also have the following two patches outstanding that were rebased from controller
15:19:24 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/18268/ patch #1
15:19:38 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/18272/ patch #2
15:19:45 <regXboi> sorry, I don't remember the bugs for them :(
15:19:59 <regXboi> IIRC, one is already +2'd and the other needs a nit change
15:20:02 <regXboi> er changed
15:20:10 <odp-gerritbot> A change was merged to neutron: Fix for Bug 2396  https://git.opendaylight.org/gerrit/18268
15:20:21 <regXboi> #topic M4 (what is missing)
15:20:27 <regXboi> #undo
15:20:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1c3e3d0>
15:20:29 <odp-gerritbot> A change was merged to neutron: Fix for bug 2648  https://git.opendaylight.org/gerrit/18272
15:20:44 <regXboi> #info the individual bugs have trello cards if folks want to pick them up
15:20:51 <flaviof> regXboi: are the tempests run on jjb? Are they this one:  https://wiki.opendaylight.org/view/OVSDB:Tempest_Tests_daily_Results ?
15:21:09 <regXboi> flaviof: ask mestery, I'm not involved
15:21:16 <regXboi> #topic M4 Status
15:21:16 <flaviof> regXboi: ack.
15:21:27 <regXboi> #info last time for this topic, we're folding it all over into M5
15:21:30 <regXboi> and so
15:21:35 <regXboi> #topic M5 Status
15:21:39 <mestery> regXboi flaviof: I was going to just manually re-run some of them
15:21:45 <regXboi> #info M5 for us is 4/30!
15:22:20 <regXboi> #info we still need the transcriber to work with YANG (thanks to edwarnicke for working with Shreshtha and co to work on that)
15:22:30 <regXboi> #info we'll talk about the stability branch next week
15:22:33 <flaviof> mestery: sounds good. My experience is that ymmv when doing it on jjb; and it works on my local vm
15:22:34 <edwarnicke> adetalhouet: Shreshtha *Do* ping me on IRC
15:22:43 <edwarnicke> adetalhouet: Shreshtha I am very helpful... but also very interupt driven :)
15:22:44 <Shreshtha> edwarnicke: sure
15:23:08 <adetalhouet> edwarnicke: I will
15:23:12 <regXboi> #info documentation, edwarnicke, I have to look to you to help adetalhouet because I know nothing of writing code to listen to Yang changes
15:23:35 <regXboi> #info integration and system test - if we can get the E2E test working, then I think I'm happy with this
15:23:47 <regXboi> and that brings us to
15:23:52 <regXboi> #topic Other Topics
15:24:03 <regXboi> #topic Broken integration JJB job
15:24:17 <regXboi> flaviof: is that what you were talking about with the manual trigger message?
15:24:20 <edwarnicke> regXboi: Could we run tempest tests again the dummy provider (or a subset of them) so we can catch getting/not getting messages from neutron?
15:24:34 <flaviof> regXboi: yes.
15:24:41 <regXboi> flaviof: please #info that now
15:24:49 <regXboi> edwarnicke: that is part of the plan
15:25:06 <flaviof> #info: flaviof manually triggered build #25. I think the issue was external, and has been resolved. (https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-integration-master/)
15:25:11 <regXboi> edwarnicke: I wasn't going to do that automagically
15:25:12 <edwarnicke> #info set up tempest testing for the dummyprovider to insure we get messages from neutron
15:25:15 <regXboi> yet
15:25:29 <flaviof> #link https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-integration-master/ neutron integration master jjb
15:25:40 <regXboi> edwarnicke: shouldn't that be an action?
15:25:45 <regXboi> #undo
15:25:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x17aa650>
15:25:46 <regXboi> #undo
15:25:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3ed90>
15:25:52 <regXboi> #link https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-integration-master/ neutron integration master jjb
15:25:55 <edwarnicke> regXboi: Not until we can stick someone on it :)
15:26:09 <regXboi> #action resource to be identified to set up tempest testing for the dummyprovider to insure we get messages from neutron
15:26:17 <regXboi> now we know we need to find someone next time :)
15:26:36 <regXboi> flaviof: thanks
15:26:39 <regXboi> and lastly:
15:26:52 <regXboi> #topic switching from ML2 to plugin for ODL
15:26:52 <flaviof> regXboi: add me to that. This is a small variation of what we do
15:26:59 <regXboi> #undo
15:26:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1c3ead0>
15:27:00 <regXboi> #undo
15:27:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1c3ed90>
15:27:13 <regXboi> #action flaviof to set up tempest testing for the dummyprovider to insure we get messages from neutron
15:27:14 <flaviof> regXboi: the only diff is that it uses the dummy instead of feature:install odl-ovsdb-openstack
15:27:29 <regXboi> #topic switching from ML2 to plugin for ODL
15:27:48 <regXboi> #info ML2 mechanisum driver doesn't provide security group/rule data without mixin
15:27:50 <edwarnicke> So... we discovered this week that we were not getting from the neutron ML2 driver:
15:27:52 <regXboi> #info plugin does
15:28:04 <regXboi> mestery: how hard would this be to get done in a week?
15:28:09 <edwarnicke> routers, router_interfaces, floatingips, security_groups, security_group_rules
15:28:21 <flaviof> wow...
15:28:36 <edwarnicke> #info So... we discovered this week that we were not getting from the neutron ML2 driver: routers, router_interfaces, floatingips, security_groups, security_group_rules
15:28:54 <edwarnicke> #info mohnish figured out how to fix routers/floatingips (our L3 driver wasn't being loaded)
15:29:39 <regXboi> #info regXboi says mestery wasn't against replacement, but is looking for confirmation here :)
15:29:39 <mestery> regXboi: Convert to a plugin from an ML2 driver?
15:29:56 <mestery> regXboi: Well, for now, I'd like to remain as an ML2 MechanismDriver
15:30:10 <mestery> But, if someone wanted to propose a plugin into stackforge/networking-odl alongside the existing stuff, I'd be ok with that.
15:30:15 <mestery> At least to see it
15:30:24 <edwarnicke> #info https://review.openstack.org/#/c/174184/ <- Kyle's fix for router_interfaces... which needs to be tested
15:30:30 <regXboi> mestery: ok, now you've confused me, I thought you were on board with this?
15:30:39 <mestery> edwarnicke: We're blocked on the ODL NB side now for that /cc regXboi
15:30:44 <flaviof> regXboi: edwarnicke: to go away from ml2 is a big step. it means only one plugin can be used at the time.
15:30:46 <mestery> regXboi: With moving to a plugin?
15:30:46 <edwarnicke> #info and we have pointers on how to get SG and SGR working
15:31:07 <flaviof> whereas ml2 is made to allow multiple users concurrently.
15:31:37 <regXboi> so frankly, ml2 for SDN *makes no sense*
15:31:42 <regXboi> hasn't to me from the very beginning
15:31:52 <regXboi> ml2 is trying to make OpenStack the SDN
15:32:00 <regXboi> and that's (imho) a bridge to far
15:32:03 <regXboi> er too far
15:32:08 * regXboi sighs
15:32:09 <mestery> regXboi: ++
15:32:31 <edwarnicke> #link https://wiki.opendaylight.org/view/Notes_on_fixing_SG_in_OS_Neutron_ML2_Driver <- notes on fixing SG and SGR in our ML2 driver
15:32:40 <regXboi> edwarnicke: thanks
15:32:54 * edwarnicke has dumped all he knows
15:33:03 <regXboi> I don't think we can solve for Lithium, but I think we should look at it *hard* for Be
15:33:10 <edwarnicke> regXboi: mestery flaviof I would like us to look at how to make sure we don't miss issues like this in the future via testing :)
15:33:21 <regXboi> edwarnicke: ++
15:33:32 <flaviof> edwarnicke: ack
15:33:40 <regXboi> edwarnicke: so that is what I would call our integration tests
15:34:39 <mestery> edwarnicke: I'm actually ticked off at that comment
15:34:45 <mestery> edwarnicke: Because *I've* been trying to push testing for 6+ months
15:34:54 <mestery> And no one showed up
15:34:56 <mestery> other than flaviof
15:34:57 <flaviof> mestery: I imagine this is a common theme (using plugin instead of ml2)... at least that is what I hear from Contrail.
15:35:02 * mestery grumbles
15:35:16 <regXboi> mestery: that's why I moved the tempest failures to where I could see them
15:35:28 * regXboi doesn't look in ovsdb for NN problems :(
15:35:32 <edwarnicke> mestery: Please do not read any accusations into that comment
15:36:00 <edwarnicke> mestery: I just want to close the barn door, I don't give a shit why its open, and I am unsurprised that you have been pointing at it (and honestly, to my recollection working on closing it) for a while now
15:36:01 <mestery> I've had bugs open since December 31 for all these things
15:36:31 <edwarnicke> mestery: I am just calling out that there is a set of fundamental testing of of the OS -> neutron NB that is different from testing any given implementation that we need to do :)
15:36:50 <edwarnicke> mestery: Again, please do not read any accusation in here... that's not what I'm doing *at all*
15:37:19 <regXboi> folks, let's pull this back
15:37:28 <regXboi> we *need* to fix the tempest tests
15:37:45 <flaviof> regXboi: we come frm a long way. not too long ago Neutron was part of controller...
15:37:46 <regXboi> we also *need* to get SG/SR working via ML2 for Lithium
15:38:06 <flaviof> so let's not beat so hard on this.
15:38:23 <regXboi> flaviof: I'm trying to end the meeting
15:38:49 <alagalah> regXboi: If it helps, we have refactored our neutron-mapper so that even though we get SG/SR from port, we are going to be using our impl that listens on the neutron*aware API, so if they come in, we will see them.
15:38:51 <flaviof> regXboi: lol. fine with me. just don;t want to end it in a bad note.
15:39:07 <regXboi> flaviof: to that point
15:39:24 <regXboi> #topic dark chocolate bars with guiness stout
15:39:32 <regXboi> #info yes, the are made by guiness
15:39:41 <alagalah> +1 choc -1 guiness -10000 together
15:39:49 <regXboi> alagalah: heathen
15:39:50 <flaviof> alagalah: +1
15:40:01 <regXboi> anything else?
15:40:05 <regXboi> going once?
15:40:07 <alagalah> regXboi: A nice lowland peaty whiskey and choc....
15:40:15 * regXboi does the count to 10
15:40:29 <regXboi> going twice?
15:40:42 <regXboi> gone
15:40:45 <regXboi> #endmeeting