15:00:26 <regXboi> #startmeeting neutron_northbound
15:00:26 <odl_meetbot> Meeting started Fri Apr 24 15:00:26 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:26 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:43 <regXboi> #topic roll call + agenda bashing
15:00:45 <adetalhouet> #info adetalhouet
15:00:58 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.284.2F24.29 agenda in usual place
15:01:02 <regXboi> #info regXboi
15:01:13 <Bhavesh> #info Bhavesh
15:01:28 <regXboi> edwarnicke: you here?
15:01:41 <alagalah> #info alagalah
15:01:52 <regXboi> btw folks, the infos aren't committer only :)
15:02:16 <regXboi> let's give a few minutes for folks to read the agenda and suggest topics
15:02:24 <alagalah> regXboi: FYI I was just informed we have a firedrill at some random time :(
15:02:30 <regXboi> and we can hopefully gather up
15:02:35 <regXboi> alagalah: um
15:02:50 <regXboi> I've been in a two-week random firedrill already, how would I know the diff?
15:03:15 <alagalah> regXboi: LOLZ, you and me both, but unfortunately this is a literal one with folks in orange vests and loud hailers
15:03:27 <regXboi> #info if folks have additional agenda items, they can #info them in I'll add them
15:03:40 <regXboi> alagalah: my eyes and ears hurt on that one
15:03:59 <regXboi> anybody know where flaviof is?
15:04:30 <adetalhouet> regXboi: I think i read something in the ovsdb channel that he won't be there today
15:04:41 <regXboi> adetalhouet: ack
15:04:45 <edwarnicke> regXboi: here :)
15:04:48 <adetalhouet> * flaviof will be out tomorrow. Wish y'all a great weekend
15:04:56 <regXboi> #chair edwarnicke
15:04:56 <odl_meetbot> Current chairs: edwarnicke regXboi
15:05:08 <regXboi> while I'm at it, anybody else want "chaired"??? :)
15:05:36 <regXboi> ok, if there are no agenda item changes.... we'll start with ...
15:05:43 <regXboi> #topic action items from last meeting
15:06:04 <regXboi> on number 1, have we had any luck on that missing CORS class?
15:06:13 <regXboi> I've not seen anything in email, but I'll admit that I haven't looked
15:06:27 <regXboi> edwarnicke?
15:06:29 <edwarnicke> regXboi: not yet
15:06:37 <regXboi> ok we pull that forward
15:06:48 <regXboi> #action edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from
15:06:56 <odp-gerritbot> James Gregory Hall proposed a change to neutron: Import-Package jaxb.rs version eclipse.persistence.version to avoid importing an older version.  https://git.opendaylight.org/gerrit/19025
15:07:11 <regXboi> number 2 - how are we doing on documentation ?
15:07:27 * regXboi wonders what *that* change set is about
15:07:33 <adetalhouet> Regarding the doc I haven't do anything yet. And regarding writing support for YANG model to transcriber, I'll start right after the meeting
15:07:46 <regXboi> adetalhouet: ack
15:07:51 <regXboi> we'll pull that one forward too
15:07:58 <regXboi> #action  adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
15:08:12 <regXboi> number 3 - we've got resources, so we can pull that one down :)
15:08:23 <regXboi> number 4 - mestery, are the tempest bugs updated?
15:08:29 <mestery> regXboi: No
15:08:39 <regXboi> ok, we pull that one forward :)
15:08:46 <regXboi> #action mestery to update Tempest bugs based on reruns
15:09:02 <edwarnicke> adetalhouet: shreshtha how are you guys doing with the transcriber to mdsal?
15:09:06 <regXboi> and the last one, flaviof isn't here, but I have seen patches
15:09:15 <regXboi> so, we'll leave it off
15:09:21 <adetalhouet> edwarnicke: didn't start yet, will do right after the meeting
15:09:22 <shreshtha> edwarnicke:  we have submitted a patch today itself for subnet
15:09:30 <regXboi> edwarnicke: there are patches to review and approve, so it's not too bad
15:09:34 <edwarnicke> :)
15:09:36 <regXboi> so...
15:09:43 <regXboi> #topic M5 Status
15:09:53 <edwarnicke> regXboi: have you reviewed mine on which they are based?
15:10:04 <regXboi> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:neutron open patches
15:10:11 <regXboi> speak of patches...
15:10:18 <regXboi> edwarnicke: I have a question on the first
15:10:47 <regXboi> do we really want to embed yang classes in the git commit?
15:11:55 <regXboi> #info regXboi has question about embedding yang generated classes in the git commit of https://git.opendaylight.org/gerrit/#/c/18659/
15:12:29 <edwarnicke> That's for configure subsystem wiring, and yes we do
15:12:47 <regXboi> ok... I wanted to confirm
15:12:54 <odp-gerritbot> A change was merged to neutron: Prep work for transcriber writing yang model:  https://git.opendaylight.org/gerrit/18659
15:12:58 <regXboi> ok, that one is in
15:13:09 <regXboi> the network transcribing was waiting for that
15:13:14 <odp-gerritbot> A change was merged to neutron: Example of MD-transcribing for network  https://git.opendaylight.org/gerrit/18778
15:13:18 <regXboi> so there it goes
15:13:27 <odp-gerritbot> A change was merged to neutron: Added a Postman collection for neutron testing  https://git.opendaylight.org/gerrit/18779
15:13:34 <regXboi> and that patch can go in
15:13:39 <regXboi> and now let's look at the subnet patch
15:13:55 <regXboi> #info https://git.opendaylight.org/gerrit/#/c/19000/1 subnet transcriber patch
15:14:10 <regXboi> edwarnicke, I have no problems with this, other than tabs
15:14:14 <regXboi> over whitespace
15:14:35 <regXboi> and in the interests of time... can you do the honors of either merging or fixing the whitespace?
15:15:22 <regXboi> if not, I'll try and get to it, but it may fall off my table
15:15:29 <regXboi> other patch that just came in:
15:15:45 <regXboi> #info https://git.opendaylight.org/gerrit/#/c/19025/1 jax.rs version patch
15:15:48 <regXboi> er
15:15:51 <edwarnicke> regXboi: I'm with you on the tabs thing
15:15:53 <regXboi> #undo
15:15:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b98550>
15:16:01 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/19025/1 jax.rs version patch
15:16:14 <regXboi> this last one seems pretty innocuous
15:16:22 <regXboi> and generally a good thing
15:16:56 <edwarnicke> regXboi: Looking
15:17:06 <edwarnicke> regXboi: So this is my concern
15:17:16 <edwarnicke> regXboi: That moxy bundle has a version coming from some parent upstream
15:17:17 <regXboi> #action regXboi to fix tabs/whitespace on subnet patch and merge
15:17:34 * regXboi listens
15:17:37 <edwarnicke> regXboi: If we really should be using that version... we should find that parent and fix it there
15:17:45 <edwarnicke> regXboi: I suspect the fix belongs in odlparent...
15:18:06 <regXboi> ok, I'm going to do something I prefer not to do
15:18:11 <regXboi> but in this case it is justified
15:18:52 <regXboi> yes, I see
15:19:06 <regXboi> the jaxb.rs version should also be changed up north
15:19:52 <regXboi> ok, I've -1'd the patch with the question of why it isn't being fixed in parents
15:20:10 <regXboi> I don't like to do that, but here it is justified
15:20:11 <regXboi> ok...
15:20:23 <regXboi> Stability branch
15:20:33 <regXboi> we need to cut one by M5 (4/30)
15:20:50 <odp-gerritbot> James Gregory Hall proposed a change to neutron: Import-Package jaxb.rs version eclipse.persistence.version to avoid importing an older version.  https://git.opendaylight.org/gerrit/19025
15:20:55 <regXboi> but I don't think we are in any position to actually *do* that
15:21:47 <regXboi> ok, so ed, can you go find this guy and help him?
15:22:28 <edwarnicke> Find which guy and help him with what?
15:22:43 <regXboi> ghall@brocade.com
15:22:52 <regXboi> and the reason for the 19025 patch
15:22:58 <regXboi> Another core bundle loads version 2.5.0 ( I think a config bundle ) and if you later "feature:install" neutron it wires to this older version instead of the version 2.5.2 which neutron requires. If you try to POST to the neutron REST with version 2.5.0 wired you get class not found exception. Apparently ODL doesn't get this feature:install approach to building a controller, but my party needs this feature for our controlle
15:23:05 <regXboi> that's from the commit message
15:23:18 <edwarnicke> Sure
15:23:24 <regXboi> thanks
15:23:50 <regXboi> so, I think we want to shade M5 and cut the stability branch on 5/1
15:24:07 <regXboi> unless people think we are going to be in shape to do it before then
15:24:47 <edwarnicke> Ack
15:25:07 <regXboi> the rest of the M5 list we are working on and have covered in the action item list
15:25:12 <regXboi> so...
15:25:26 <regXboi> #info reminder to all that we do have a trello board going forward
15:25:38 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board
15:26:04 <regXboi> #info we also need to get to work on bug squashing
15:26:24 <regXboi> #topic change variables stripped from incoming objects
15:26:35 <regXboi> mestery: I added this to the list last minute
15:26:42 <regXboi> because
15:27:03 <regXboi> #info regXboi thinks that the plugin should not strip anything and let ODL ignore and process as it sees fit
15:27:32 <regXboi> my reasoning is that if the plugin is completely transparen, adding support for new attributes is a one step process
15:27:40 <regXboi> any cons to that?
15:28:09 * regXboi gives a few minutes for folks to react
15:29:34 <edwarnicke> Responded... The bug should be fixed where it actually is... Not here
15:29:46 <regXboi> k
15:30:16 <regXboi> if I don't get cons, I'm going to remark that last info as agreed :)
15:31:11 <regXboi> going twice :)
15:31:55 <regXboi> #agreed the ODL plugin should not strip anything and let ODL NN ignore and process as it sees fit
15:32:19 <regXboi> ok, switching order
15:32:24 <regXboi> or actually not
15:32:37 <regXboi> #info regXboi has seen patches about getting SG southbound to NN
15:32:44 <regXboi> #undo
15:32:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x17d1110>
15:32:58 <regXboi> #info regXboi has seen openstack patches about getting SG southbound to NN
15:33:06 <regXboi> I don't have an update beyond that
15:33:15 <regXboi> ugh
15:33:18 <regXboi> #undo
15:33:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1953a10>
15:33:18 <edwarnicke> Have they landed?
15:33:31 <regXboi> #topic supporting passing SG information to NN
15:33:43 <regXboi> #info regXboi has seen openstack patches about getting SG southbound to NN
15:33:50 <regXboi> #info unknown if they have landed or not
15:33:55 <regXboi> I don't know
15:34:03 * regXboi looks to mestery for that answer
15:34:19 <regXboi> last topic (no I don't have cookies today :( )
15:34:33 <regXboi> #topic Ericsson request for L3BGP in Lithium
15:34:45 <regXboi> #info ericsson is asking for L3BGP support in Lithium
15:34:55 <regXboi> I'm inclined to say no
15:35:07 <regXboi> we said no before and I'm *still* inclined to say no
15:35:14 <edwarnicke> Pointer to the request?
15:35:42 * regXboi looks
15:36:04 <regXboi> it's not public
15:36:10 <regXboi> it was not sent to the mailing list
15:36:10 <edwarnicke> Ack
15:36:28 * regXboi notes he is not happy about that
15:37:03 <regXboi> They are offering to write the code for it
15:37:22 <regXboi> but this would require an API exception
15:37:45 <regXboi> and frankly, if the OS BP changes we have code that isn't really all that useful
15:38:18 <regXboi> hey mestery: ping?
15:39:31 <regXboi> so... I'm inclined to listen politely and say next release
15:39:59 <edwarnicke> Ack
15:40:12 <regXboi> but with OpenStack going to the "big tent" model, we are going to have to deal with things like this going forward
15:40:37 * regXboi shudders to think about that
15:40:54 <odp-gerritbot> James Gregory Hall proposed a change to neutron: Import-Package jaxb.rs version eclipse.persistence.version to avoid importing an older version.  https://git.opendaylight.org/gerrit/19025
15:40:55 <regXboi> #topic Open Discussion
15:41:33 * regXboi apologizes for not being around or helpful
15:41:53 <regXboi> we're dealing with a series of short term fires here and my time has been seriously pre-empted :(
15:42:20 <regXboi> the floor is open now ... "bring out your topics!"
15:44:01 <regXboi> going twice?
15:44:09 <Bhavesh> regXboi: edwarnicke  How can we contribute more :)
15:44:24 <Bhavesh> I mean, I and shreshtha
15:44:24 <regXboi> keep the model transcriber classes coming !
15:44:47 <edwarnicke> There's a lot of work to do on transcriber, friends to work with, and I think it's now straight forward :)
15:45:20 <regXboi> ok folks - I have to run to a scrum meeting to find out what the new fires are today :(
15:45:25 <regXboi> #endmeeting