15:00:10 <regXboi> #startmeeting neutron_northbound
15:00:10 <odl_meetbot> Meeting started Fri May  1 15:00:10 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:20 <regXboi> #chair flaviof edwarnicke
15:00:20 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:00:21 <flaviof> #info flaviof
15:00:26 <regXboi> #info regXboi
15:00:29 <adetalhouet> #info adetalhouet
15:00:33 <regXboi> all, please #info in
15:00:52 <adetalhouet> hi all :)
15:01:04 <regXboi> while folks #info in
15:01:09 <regXboi> #topic agenda bashing
15:01:32 <edwarnicke> #info edwarnicke
15:01:33 <regXboi> #info agenda is in its usual place
15:01:44 <edwarnicke> regXboi: Could you #link it for posterity?
15:01:48 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.285.2F1.29 meeting agenda
15:01:57 <regXboi> edwarnicke: was already working on that :)
15:02:17 <edwarnicke> :)
15:02:19 <regXboi> anybody want to add any topics?
15:02:57 * regXboi gives a few minutes for agenda additions and others to #info in
15:03:10 <adetalhouet> yes, maybe the transcriber stuff ?
15:03:37 <regXboi> adetalhouet: isn't that covered under Code Freeze part of M5 items?
15:04:05 <regXboi> or are you asking about docs or test?
15:04:16 <adetalhouet> no yes ok, this is in the code freeze part
15:04:30 <regXboi> no worries - is good to ask
15:04:45 <flaviof> regXboi: I would like to give an update on https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/
15:04:51 <edwarnicke> flaviof: :)
15:05:01 <edwarnicke> flaviof: How do we stand with the case of the missing messages?
15:05:23 <flaviof> edwarnicke: messages?
15:05:49 <regXboi> flaviof: so added as an "other topic"
15:05:52 <edwarnicke> flaviof: Last I heard we were not getting CRUD for router_interface, security_group, or security_group_rule objects
15:05:55 <regXboi> anybody else?
15:06:02 <edwarnicke> flaviof: But folks were working furiously on them
15:06:09 <edwarnicke> flaviof: So I was curious were we are :)
15:06:10 <regXboi> if not...
15:06:18 <flaviof> edwarnicke: oh right.
15:06:18 <edwarnicke> flaviof: Though that may be more a question for mestery
15:06:25 <regXboi> #topic action items from last meeting
15:06:36 <edwarnicke> Because without them we can't do L3 or secgroups correctly...
15:06:43 <regXboi> #info item 1: reminder that we have a trello board
15:06:52 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound
15:06:54 <regXboi> #undo
15:06:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b88b10>
15:07:12 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound neutron northbound trello board
15:07:24 <flaviof> edwarnicke: sg issue is being worked on: https://review.openstack.org/#/c/178325/ . mestery is the best one to talk on that.
15:07:41 <regXboi> #info we also have a link on the front page with a mailto link for folks who want access (i.e. contanct me)
15:07:47 <edwarnicke> flaviof: And router_interface?
15:08:04 <regXboi> #info item 2: edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from
15:08:20 <regXboi> #link http://pastebin.com/vT3hfGhy CORS error in karaf
15:08:23 <edwarnicke> regXboi: I tentatively think https://git.opendaylight.org/gerrit/#/c/19037/ fixes it...
15:08:23 <flaviof> edwarnicke: that needs to be merged on stable/helium: https://git.opendaylight.org/gerrit/#/c/19181/
15:08:33 <regXboi> edwarnicke: can you #info that in?
15:08:53 <regXboi> flaviof: I believe that check finally passed jenkins first stage
15:08:56 <edwarnicke> I am testing that it fixes the moxy issue now
15:08:58 <regXboi> and *can* now be merged in
15:09:07 <flaviof> regXboi: ack.
15:09:14 <regXboi> edwarnicke: it is which?
15:09:41 <regXboi> #info edwarnicke thinks https://git.opendaylight.org/gerrit/#/c/19037/ might address this item
15:09:54 <edwarnicke> regXboi: Yes... testing post 19037 merge
15:10:00 <edwarnicke> regXboi: Building integration
15:10:04 <edwarnicke> regXboi: So I can control load order
15:10:05 <regXboi> cool
15:10:08 <regXboi> #info item 3: adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
15:10:23 <regXboi> do we have an update on this (given that M5 was [cough] yesterday)?
15:10:56 <adetalhouet> I've haven't done it yet. I was busy with writing the transcriber stuff, and now I got something else, I think I could to that early next week
15:11:20 <regXboi> ok, we'll carry it forward
15:11:37 <regXboi> #action all reminder that we have a trello board
15:11:47 <regXboi> #action adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
15:12:03 * edwarnicke worries about a world in which he is expected to provide intelligence
15:12:08 <regXboi> item 4: mestery to update Tempest bugs based on re-runs
15:12:12 <regXboi> mestery, you here?
15:12:44 <adetalhouet> for the doc, no need for intel and guidance anymore, I think I know what to do now that I wrote a part of the transcriber
15:12:52 <flaviof> regXboi: w/out mestery here, I can say that we have been having issues
15:12:54 <edwarnicke> adetalhouet: :)
15:12:57 <regXboi> #undo
15:12:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x17aabd0>
15:12:58 <edwarnicke> adetalhouet: And that was the point of the exercise :)
15:13:03 <flaviof> with the devstack-ci
15:13:06 <regXboi> #action detalhouet to write documentation for how to write a consumer of the neutron yang model.
15:13:14 <flaviof> this is not about ubuntu, btw...
15:13:15 <adetalhouet> edwarnicke: thanks :)
15:13:30 <regXboi> #info flaviof says in mestery's absense, there are issues with the devstack-ci
15:13:48 <regXboi> flaviof: do we have an email thread in neutron-dev to point to?
15:13:56 <regXboi> and if not, shouldn't we have one ?
15:14:19 <edwarnicke> flaviof: You were going to talk about the status of: https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/8/
15:14:21 <flaviof> #info the way we deploy devstack-jenkins needs to mode to nodepool, so changes by the openstack comunity is automatically reflected in the vms used by jenkins
15:14:24 * edwarnicke is interested :)
15:14:45 <regXboi> isn't this topic the one we added later?
15:15:13 <flaviof> edwarnicke: yes; actually it is the same issue in that the stack portion is failing. affecting all these; including ci and tempests
15:15:42 <regXboi> #info item 5: regXboi to fix tabs/whitespace on subnet patch and merge (done)
15:15:44 <flaviof> regXboi: yes; 2 topics but common issue
15:15:56 <regXboi> ok, then I ask that we bring it back up later
15:16:17 <regXboi> i.e. (let's get through the other stuff as quickly as possible so that we devote more time to it)
15:16:28 <regXboi> #topic M5 status
15:16:35 <flaviof> regXboi: ack
15:16:41 <regXboi> #info M5 deadline for us was 4/30 (yesterday), so where are we?
15:17:00 <regXboi> #info no patches related to functionality in the open patch list
15:17:14 <regXboi> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:neutron open patches
15:17:23 <regXboi> so have we achieved code freeze?
15:17:32 <regXboi> #info so have we achieved code freeze?
15:17:51 <regXboi> adetalhouet: this is your cue :)
15:17:57 <edwarnicke> regXboi: Tests would indicate that https://git.opendaylight.org/gerrit/#/c/19037/ has fixed the moxy issue
15:18:08 <regXboi> that's worth an issue
15:18:09 <edwarnicke> regXboi: Turns out he problem was controller was overriding the version for odlparent
15:18:10 <regXboi> er info
15:18:17 <edwarnicke> LOL
15:18:28 <edwarnicke> #link https://git.opendaylight.org/gerrit/#/c/19037/ <- appears to have fixed the moxy issue
15:18:33 <adetalhouet> there are still of with classes to cover here https://trello.com/c/cxsEMMyV/5-and-support-for-yang-model-to-transcriber but i think Shreshtha and Bhavesh are doing it
15:18:44 <regXboi> #info and there was much rejoicing
15:18:53 <edwarnicke> #info It looks like the moxy issue as caused by controller improperly overriding odlparent for the eclipse.persistence.version
15:19:19 <regXboi> #info there are still of with classes to cover here https://trello.com/c/cxsEMMyV/5-and-support-for-yang-model-to-transcriber
15:19:37 <regXboi> adetalhouet: ok, then we haven't achieved code freeze
15:19:38 <adetalhouet> the transcriber writing to mdsal stuff is 81% achieve
15:19:39 <regXboi> it is what it is
15:20:01 <regXboi> #info we need a volunteer to cut the stable branch
15:20:07 * regXboi looks at edwarnicke
15:20:41 <regXboi> edwarnicke, you want to help me tackle that on Monday? I want to give the mdsal stuff a chance to reach 100%
15:21:22 <regXboi> going once?
15:22:02 <regXboi> going twice?
15:22:27 <regXboi> #action edwarnicke and regXboi to cut the stability branch once the transcriber is 100% coded
15:22:46 <regXboi> #info documentation isn't complete, we know that
15:23:14 <regXboi> adetalhouet, when you work the documentation, please send the doc patch link to the mailing list
15:23:22 <regXboi> er link(s)
15:23:35 <adetalhouet> regXboi: yes sure
15:23:35 <regXboi> #info integration and system test
15:23:41 <regXboi> #undo
15:23:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c42310>
15:24:06 <regXboi> #info integration and system test is also incomplete, but it looks like we may be able to move forward again on getting that done
15:24:38 <regXboi> #topic bug squashing
15:24:48 <regXboi> #link https://bugs.opendaylight.org/buglist.cgi?list_id=27656&product=neutron&query_format=advanced&resolution=--- open bugs
15:25:16 <regXboi> #info we're going to need volunteers to help pick up and work on the outstanding bugs, so we'll likely start devoting more time to this going forward
15:25:25 <regXboi> and that brings us to
15:25:38 <regXboi> #topic update on https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/ (openstack CI job)
15:25:49 <regXboi> flaviof: the floor is yours
15:25:59 <flaviof> regXboi: thanks
15:26:07 <flaviof> #info AndyG is looking into adding pip to devstack and that will hopefully fix the issue, for now
15:26:17 <flaviof> #link https://git.opendaylight.org/gerrit/#/c/19434/ adding pip to devstack slave in Jenkins
15:26:27 <flaviof> #info real fix is to use nodepool, so the vms used as devstack slave in Jenkins are closely coupled with the images used by openstack folks.
15:26:53 <flaviof> #info using that, it matters not what distro is used
15:27:25 <regXboi> I don't see any action items for NN spinning out of this (so far)
15:27:27 * flaviof personally has no pref on the distro
15:27:37 <edwarnicke> flaviof: Could you say a few words about nodepool... I'm curious :)
15:27:51 <flaviof> edwarnicke: sure. I can do better.
15:27:59 * edwarnicke is unsurprised :)
15:28:10 <flaviof> edwarnicke: https://gist.github.com/9afc3fd1d6d4088bb3ff
15:28:43 <edwarnicke> flaviof: Cool :)
15:29:12 <flaviof> as you can see, this has been eating a bunch of my time and mestery's
15:29:56 <flaviof> I'm very hopeful that one that is in place, we will get much better env for openstack-ci, tempest, et all
15:30:05 <edwarnicke> flaviof: Cool :)
15:30:14 <edwarnicke> flaviof: It should make things better for *everyone*
15:30:19 <edwarnicke> flaviof: Many thanks :)
15:30:20 <regXboi> can we pound link that?
15:30:49 <regXboi> #link https://gist.github.com/9afc3fd1d6d4088bb3ff background on nodepool
15:30:59 <flaviof> it is my understanding that this is on top of Andy's list, but the ongoing unrelated Jenkins issues have derailed it a bit.
15:32:09 <regXboi> so folks, we're going to have to say that we are distinctly yellow with respect to M5
15:32:21 <regXboi> and possibly red, so the pressure will be on to finish items
15:32:43 <regXboi> other than that, I don't have anything else
15:32:48 * edwarnicke feels more goldenrod
15:33:26 <regXboi> so...in the great tradition
15:33:28 <regXboi> #topic cookies
15:33:31 <regXboi> #endmeeting