15:00:07 <regXboi> #startmeeting neutron_northbound
15:00:07 <odl_meetbot> Meeting started Fri May  8 15:00:07 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:15 <regXboi> #chair flaviof edwarnicke
15:00:15 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:00:16 <adetalhouet> #info adetalhouet
15:00:24 <regXboi> #topic roll call and agenda bashing
15:00:37 <flaviof> mestery: need a hand on that. I know I need to edit requirements.txt, right?
15:00:40 <flaviof> mestery: https://bugs.launchpad.net/devstack/+bug/1448376
15:00:48 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.285.2F8.29 agenda in the usual place
15:00:57 <regXboi> #info regXboi
15:01:10 <regXboi> anybody have additional topics?
15:01:50 * regXboi waits a few minutes
15:02:02 <regXboi> oh yes, attendees, please #info in
15:02:19 <flaviof> #info flaviof
15:02:34 * regXboi looks pointedly at mestery
15:02:46 <regXboi> regXboi looks for edwarnicke
15:02:48 <mestery> #info mestery (lurking)
15:03:24 <edwarnicke> #info edwarnicke
15:03:43 <regXboi> last call for agenda topics
15:04:21 <regXboi> #topic action items from last meeting
15:04:22 <edwarnicke> regXboi: Do we have status of the odl-neworking driver in OS and secgroups/secgroup_rules/router_interfaces ?
15:05:05 <regXboi> edwarnicke: sorry for being very blunt - but given that M5 was a week ago and we've not (afaik) done anything for it - can I afford to care?
15:05:18 <mestery> lol
15:05:32 <edwarnicke> regXboi: We sort of need to
15:05:47 <edwarnicke> regXboi: Because we still aren't getting necessary objects from OS
15:05:55 <edwarnicke> regXboi: We have code to handle them
15:05:59 <edwarnicke> regXboi: We just aren't getting it
15:06:15 <edwarnicke> regXboi: And without those we can't even do L2 secgroups correctly
15:06:16 <regXboi> so - I understand that SB projects may care
15:06:22 <edwarnicke> regXboi: Much less L3 correctly
15:06:36 <edwarnicke> regXboi: So we either get them... or we bump real neutron support that works correctly to Be
15:06:39 <regXboi> but *at this precise moment* - that isn't the top of my priority list
15:06:53 <edwarnicke> regXboi: We actually do need to care
15:07:03 <edwarnicke> regXboi: Because we need to test and fix bugs in the code that catches that stuff
15:07:23 <edwarnicke> regXboi: But lets file that down agenda, don't want to disturb your flow :)
15:07:34 <regXboi> no... you've already blown up the meeting
15:07:38 <regXboi> I'd I'm not in the mood for it
15:07:40 <regXboi> so ....
15:07:46 <edwarnicke> ?
15:07:59 <regXboi> you are essentially saying that we can't declare any M5 items as closed?
15:08:05 <regXboi> that's what I'm hearing
15:08:13 <edwarnicke> regXboi: I don't think *precisely* that
15:08:22 <edwarnicke> regXboi: We *do* have code for those things to 'catch' on the ODL side
15:08:38 <edwarnicke> regXboi: So if there are issues where we don't match up with the OS side
15:08:42 <edwarnicke> regXboi: Those *are* bugs
15:08:58 <edwarnicke> But I think we should call out for M5 clearly what we do and don't have the capacity to test against OS
15:09:10 <edwarnicke> mestery: Were do we stand on getting those objects from OS?
15:09:16 <edwarnicke> Where
15:09:31 <mestery> edwarnicke: We can't *test* this stuff, so the patch isn't passing jenkins on the OpenStack side, thus it's not gonna merge anytime soon.
15:09:49 <mestery> flaviof and I have been working on it
15:09:58 <edwarnicke> mestery: I'm confused
15:10:18 <edwarnicke> mestery: So do we have a patch that sends us secgrp, secgrp_rule, and router_interface?
15:10:38 <mestery> edwarnicke: We have one proposed, yes, but it's not passing our Jenkins on the OpenStack side yet.
15:10:50 <edwarnicke> mestery: OK... I am now unconfused :)
15:10:51 <flaviof> edwarnicke: https://review.openstack.org/#/q/status:open+project:stackforge/networking-odl,n,z
15:11:04 <edwarnicke> mestery: What is failing?
15:11:19 <mestery> edwarnicke: Lets not go down that rathole here and side-track regXboi's fancy meeting
15:11:30 <regXboi> #link https://review.openstack.org/#/c/178325/ patch for passing security groups to OS
15:11:37 <regXboi> no actually - this is the last topic
15:11:37 <edwarnicke> mestery: Could you at least point to the failing tests?
15:11:41 <regXboi> and we might as well cover it
15:11:44 <edwarnicke> mestery: I might break free some cycles to help
15:11:51 <edwarnicke> mestery: And I have a history of unblocking things ;)
15:11:56 <mestery> edwarnicke: ODL doesn't like to run in the OpenStack gate
15:12:03 <regXboi> #info (note: this is *not* action items, this is other topics)
15:12:03 <mestery> Hell, I can't get it to run on my systems either lately
15:12:08 <mestery> flaviof is likely more help as he has it working
15:12:23 <edwarnicke> mestery: Ah... OK... so that's something I am much more likely to be helpful on
15:12:44 <regXboi> #action edwarnicke, mestery, flaviof to work on ODL running in the OS gate so that we can unblock OS patches
15:12:54 * regXboi delegating
15:13:07 <edwarnicke> mestery: flaviof Got time right after this to jump on a hangout and kill this issue dead?
15:13:17 <regXboi> #info and maybe back to the regularly scheduled agenda
15:13:18 <mestery> Not me
15:13:29 <edwarnicke> mestery: OK.  When?
15:13:41 <flaviof> edwarnicke: other than mestery and I think nobody is doing much on OS with ODL... this is the biggest issue, imo
15:13:42 <edwarnicke> mestery: Because historically, I'm pretty good at solving this sort of problem :)
15:13:48 <mestery> flaviof: ++
15:13:54 <edwarnicke> flaviof: That's not actually true
15:14:10 * mestery grumbles
15:14:10 <edwarnicke> flaviof: But I would say its accurate you guys are the only ones trying to get it running in OS CI
15:14:24 <edwarnicke> flaviof: And in CI at ODL currently
15:14:39 <edwarnicke> But I know quite a few folks who stack against ODL at least daily :)
15:15:06 <regXboi> so - that statement (while true) - is not really a helpful one
15:15:09 <edwarnicke> mestery: So when would be a good time to get on a hangout and kill the 'not running' issues you are seeing
15:15:19 <flaviof> edwarnicke: I'd like to hear more about that.... this has proven to be a bit fragile.
15:15:28 <flaviof> right now I can't stack.
15:15:28 <edwarnicke> flaviof: I feel ya
15:15:57 <regXboi> ok folks
15:16:06 <edwarnicke> OK... so flaviof can't stack, and mestery can't get ODL to run, correct?
15:16:09 <regXboi> I'm taking back the meeting - you all can work on that afterwards
15:16:17 * edwarnicke yields
15:16:29 <regXboi> #topic action items from last meeting (for real this time)
15:16:42 <flaviof> regXboi: ack. sorry for the sidetrack
15:16:42 <regXboi> #info item 1: trello board reminder
15:17:06 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board
15:17:26 <regXboi> #info item 2: documentation - do we have a patch for this?  we desparately need it for M5
15:17:35 <adetalhouet> yes: MdsalUtils#getOtherConfig(Node node, Type type, String key)
15:17:39 <adetalhouet> oops
15:17:46 <adetalhouet> there we go: https://git.opendaylight.org/gerrit/#/c/19850/
15:17:48 * regXboi understands
15:17:59 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/19850/ documentation patch
15:18:06 <regXboi> adetalhouet: thanks
15:18:09 <adetalhouet> I started something, needs to be updated
15:18:35 <regXboi> #action all to review documentation patch at https://git.opendaylight.org/gerrit/#/c/19850/ and provide updates
15:18:43 <regXboi> #item 3: stability branch
15:18:45 <adetalhouet> So feedback are welcome on this, due to lack of inspiration from my part
15:18:56 <regXboi> #info item 3 stability branch
15:19:06 <regXboi> #info noe: this bleeds into the next topic so...
15:19:11 <regXboi> #topic M5
15:19:21 <regXboi> #info we are > week behind on this so...
15:19:28 <regXboi> can we declare code freeze?
15:19:50 <regXboi> modulo the possibility of bugs that have to be fixed w.r.t to OS?
15:19:58 <regXboi> er s/possibility/probability/
15:20:12 <edwarnicke> regXboi: How is the open patch queue?
15:20:16 * edwarnicke goes to look
15:20:30 <regXboi> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:neutron open patch queue
15:20:38 <regXboi> #info only one "do not merge" patch for testing
15:21:01 <edwarnicke> regXboi: Yep
15:21:01 <regXboi> note: we *need* that patch, but I have zero time to work on it for the next week :(
15:21:12 <edwarnicke> Guys, how are we doing on the neutron mdsal stuff?
15:21:26 <edwarnicke> regXboi: Do we just declare what we have is what we have at this point?
15:21:28 * regXboi checks trello board
15:21:50 * edwarnicke is distinctly *not* putting his thumb on that scale, just wants us to go into M5 eyes open
15:22:23 <regXboi> other than the NeutronTranscriberProvider and FW stuff it looks like it is all complete
15:22:28 <adetalhouet> Missing this one: NeutronTranscriberProvider on all the NeutronFirewall*
15:22:53 <regXboi> who can take those last four?
15:23:05 <adetalhouet> Hang on, I added the Provider but might be a mistake
15:23:12 <edwarnicke> regXboi: Could you #link in the trello board
15:23:27 <regXboi> edwarnicke: scan back - already did
15:23:32 <adetalhouet> Ok, I'll end this card
15:23:47 <adetalhouet> Just regarding the NeutronFirewall*, what do we do?
15:23:56 <regXboi> afaik nobody is using it
15:23:59 * edwarnicke is apparently not quite awake yet
15:24:11 <regXboi> I'm inclined to not do it
15:24:13 <adetalhouet> nothing has been implemented yet as it is deprecated
15:24:20 <adetalhouet> alright
15:24:38 <adetalhouet> https://trello.com/c/cxsEMMyV/5-and-support-for-yang-model-to-transcriber
15:24:41 <regXboi> any objections to closing the card?
15:24:46 <edwarnicke> Nope
15:24:55 <regXboi> #agreed declaring code freeze
15:25:02 <regXboi> adetalhouet: go ahead and close the card
15:25:14 <regXboi> so... that means we can cut a stability branch
15:25:36 <regXboi> edwarnicke: you and I were on the hook for that - when do you have time?
15:26:09 <flaviof> regXboi: about https://trello.com/c/U2awRdUs/1-feature-based-testing-of-dummy-provider ...
15:26:18 <flaviof> regXboi: did you see the errors in https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/ ?
15:26:42 <regXboi> flaviof: I've had no time to look at any of this stuff
15:26:51 <flaviof> regXboi: ack.
15:26:53 <regXboi> I'm stealing time just to review patches
15:27:08 <flaviof> i hear ya
15:27:51 <regXboi> flaviof: the "do not merge" patch was an attempt to test the dummy provider without OS
15:27:52 <edwarnicke> regXboi: Going to look for instructions for pulling the stable/lithium branch
15:28:02 <edwarnicke> (I know how to do it... but I may not know the *best* way to do it :) )
15:28:29 <regXboi> edwarnicke: what time zone are you in today?
15:28:38 <edwarnicke> regXboi: PST
15:28:49 <edwarnicke> regXboi: I'm in Portland until the OpenStack Summit
15:28:54 <edwarnicke> Then in Vancouver, BC
15:28:57 <edwarnicke> Then back to Seattle
15:29:07 <regXboi> edwarnicke: I have a scrum call at the top of the hour - but will find you when its done and we can get this branch cut
15:29:19 <edwarnicke> regXboi: Sure
15:29:24 <regXboi> note: this call could go as long as 90 minutes - that's how bad it is
15:29:41 <regXboi> ok... we've covered documentation
15:29:50 <regXboi> and integration and test was earlier as well
15:30:08 <regXboi> so... I can fill out the M5 template by the end of the day (warts and all)
15:31:10 <regXboi> at this point, *now* the dev stack comments from earlier are front and center because we need to fix them so that we have I&ST
15:31:39 <regXboi> #topic Working Session on Openstack CI issues
15:31:46 <edwarnicke> regXboi: Ack
15:32:15 <regXboi> are we working off the errors in https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/ ?
15:32:49 <regXboi> flaviof, mestery - is that a reasonable link to add for the minutes?
15:33:04 <mestery> I'll defer to flaviof, but it looks ok
15:33:06 <flaviof> regXboi: I'd think not. I think that is related to dummy_neutron
15:33:29 <regXboi> #link https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master current job has errors
15:33:40 <regXboi> #info flaviof thinks they are related to the dummy provider
15:33:59 <flaviof> regXboi: actually, that is not a bad place to start, because it is 100% neutron.
15:34:02 <regXboi> ok... I'll try and take a look in this next week
15:34:29 <regXboi> #action regXboi to do best effort to look at issues neutron-daily-openstack-master is having
15:34:44 <flaviof> as for sg, mestery is relentlessly working on https://review.openstack.org/#/c/178325/
15:35:07 <regXboi> #info flaviof and mestery continue to work on https://review.openstack.org/#/c/178325/
15:35:27 <regXboi> flaviof: that gist above - is it the current issue with respect to SG?
15:36:11 <flaviof> #link  https://wiki.opendaylight.org/view/OVSDB:Running_Tempest_Tests a good place for folks to look in order to help testing OS+ODL
15:36:33 <regXboi> yes, but do we have the list of issues on the trello board?
15:36:43 <regXboi> *should* we have the list of issues on the trello board?
15:36:46 <regXboi> :)
15:37:09 <flaviof> regXboi: yes: https://trello.com/b/ddIvDQE0/ovs-openstack
15:37:24 <regXboi> um
15:37:29 <flaviof> they are at the bottom of the "to do"
15:37:49 <regXboi> imho, those should really be moved to the neutron board, shouldn't they?
15:38:01 <flaviof> it is hard to separate ovsdb net-virt from neutron. my gut tells me 99% is pure neutron issues
15:38:10 <flaviof> regXboi: absolutely.
15:38:24 <flaviof> I'd think they should be 'updated' and moved to neutron.
15:38:30 <regXboi> can I action you to do that?
15:38:32 <flaviof> it is a very moving target.
15:38:55 <flaviof> now that openstack ci moved to Li, the tests results are very different.
15:39:13 <regXboi> #action flaviof to update OS issues and move from https://trello.com/b/ddIvDQE0/ovs-openstack to https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound
15:39:16 <flaviof> #link https://jenkins.opendaylight.org/releng/view/ovsdb/job/ovsdb-daily-openstack-master/46/artifact/logs/testr_results.html latest tempest results
15:39:23 <flaviof> regXboi: ack
15:39:28 <regXboi> flaviof: thanks
15:40:23 <flaviof> one more link....
15:40:34 <flaviof> #link https://wiki.opendaylight.org/view/OVSDB:Tempest_Tests_daily_Results   OVSDB:Tempest Tests daily Results
15:41:27 <regXboi> flaviof: thanks
15:41:29 <regXboi> (again)
15:41:34 <flaviof> regXboi: np!
15:41:42 <regXboi> ok... anything else?
15:42:01 <flaviof> that is all from me.
15:43:36 <regXboi> anybody else - going once?
15:44:13 <regXboi> going twice?
15:44:34 <regXboi> #action regXboi to update the meeting page today :)
15:44:52 <regXboi> and sold...
15:44:56 <regXboi> #endmeeting