15:01:20 <regXboi> #startmeeting neutron_northbound
15:01:21 <odl_meetbot> Meeting started Fri May 15 15:01:20 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:21 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:29 <regXboi> #chair flaviof edwarnicke
15:01:29 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:01:35 <regXboi> #topic roll call
15:02:05 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.285.2F15.29 agenda in its usual place
15:02:09 <regXboi> #undo
15:02:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1aa8bd0>
15:02:13 <regXboi> #info regXboi
15:02:20 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.285.2F15.29 agenda in its usual place
15:03:01 <regXboi> attendees - please #info in :)
15:03:13 <edwarnicke> #info edwarnicke
15:03:16 <odlcasey> #info Casey
15:04:19 * regXboi gives a few more minutes for roll call and gather up
15:04:19 <flaviof> #info flaviof
15:04:43 <adetalhouet> #info adetalhouet
15:05:05 <regXboi> #topic agenda bashing
15:05:16 <regXboi> #info any new topics or order rearrangement?
15:05:26 <regXboi> I'm looking for short items to the front
15:05:30 <regXboi> longer items to the back :)
15:06:11 <edwarnicke> regXboi: So we are lining agenda items up by height? :)
15:06:20 <regXboi> expected length of discussion
15:07:11 <flaviof> anybody going to the openstack summit? would like to get together.
15:07:39 <regXboi> I'm not - I'm headed an orthogonal direction
15:07:48 <flaviof> regXboi: too bad.
15:07:57 <edwarnicke> flaviof: I am :)
15:08:02 <flaviof> edwarnicke: nice!
15:08:36 <regXboi> #topic action items from last meeting
15:08:52 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board
15:08:59 <regXboi> #info that's item 1
15:09:16 <regXboi> #info items 2 and 3 are status items - so they are done :)
15:09:26 <regXboi> #info item 4
15:09:39 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/19850/ documentation patch
15:09:59 <regXboi> #info regXboi added text to it and thinks its ready for colindixon to look at
15:10:12 <regXboi> colindixon: you here :-) ?
15:10:51 <colindixon> hey
15:10:51 <colindixon> sorry
15:11:03 <regXboi> do me a favor and #info in
15:11:12 <colindixon> #info colindixon is mostly around :p
15:11:12 * edwarnicke would like the record to reflect that no one who reviews as much docs as colindixon does need apologize ;)
15:11:26 <regXboi> then #info that edwarnicke :)
15:11:53 <regXboi> colindixon: I know you are busy, but I think that the above #linked doc patch is as ready as it is going to be
15:11:59 <regXboi> modulo editing of course :)
15:12:26 * regXboi returns colindixon to regularly scheduled insanity
15:12:31 <regXboi> #info item 5
15:12:51 * colindixon starts to review this patch because you guys are good
15:13:01 <regXboi> #info regXboi has looked at neutron-daily-openstack-master and believes there is a problem with ODL not listening on proper ports
15:13:10 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-May/000151.html first impressions in email
15:13:38 <regXboi> #info however, neutron-daily-openstack-master now appears to be dieing on neutron being generally wedged
15:13:44 <edwarnicke> regXboi: Why would messages be sent to us on 8087
15:13:54 <edwarnicke> We've never listened on 8087
15:14:09 <regXboi> edwarnicke: because that's how it's all configured - beyond that I'll let flaviof explain
15:14:23 <regXboi> edwarnicke: the problem *isn't* the 8087 - that's configured to work
15:14:36 <regXboi> edwarnicke: the problem is the redirect to 8443 - nothing is listening there
15:14:40 <flaviof> the issue has to do with the way the tests are run
15:15:02 <flaviof> when doing it  'allinone', odl is co-located with the rest of openstack services
15:15:13 <regXboi> I have a vague memory that mlemay was going to look at this, but I never heard back
15:15:14 <flaviof> swift uses 8080, so odl had to be moved
15:15:41 <edwarnicke> regXboi: Reading your email more carefully... is neutron trying to hit us on https?  Because I know that our normal, non-munged, jetty config does *not* redirect folks to ssl
15:15:53 <flaviof> i do not understand what is redirecting neutron-nb to 8443
15:16:06 <edwarnicke> flaviof: I'm pretty sure its not ODL...
15:16:17 <regXboi> so... look at the jetty.xml configuration?
15:16:30 <regXboi> let me get you a link
15:16:32 * edwarnicke hits our restconf interface pretty much daily and has never been redirected
15:16:40 <regXboi> because the recent jobs are really hosed
15:17:04 <regXboi> #link https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/19/artifact/logs/opendaylight/etc/jetty.xml the jetty xml in question
15:17:18 <flaviof> regXboi: how can you tell that it is hosed due to that?
15:17:22 <regXboi> that configuration *looks* like a redirect
15:17:29 <regXboi> flaviof: see above
15:17:46 <regXboi> the "confidentialPort" attribute is suspicious
15:18:00 <edwarnicke> regXboi: Our stock jetty also sets confidential ports, and doesn't redirect
15:18:21 <regXboi> edwarnicke: I remain unconvined
15:18:28 <regXboi> er unconvinced even :)
15:18:32 <edwarnicke> So this is the stock jetty file:
15:18:33 <flaviof> regXboi: can you correlate that with the failure in the job itself [1] ?
15:18:41 <flaviof> #link https://jenkins.opendaylight.org/releng/view/ovsdb/job/ovsdb-daily-openstack-master/54/console failing stack
15:18:41 <flaviof> [1]
15:18:57 <edwarnicke> https://www.irccloud.com/pastebin/RaUszhnF
15:19:11 <regXboi> fflaviof: no I can't
15:19:19 <regXboi> because I'm looking at the ECONNREFUSED
15:20:43 <regXboi> in the neutron server log
15:20:53 <flaviof> regXboi: ack. I wonder if there are different problems, and they are getting merged into the same topic.
15:21:13 <regXboi> well - for *one* thing - we aren't even hitting this problem anymore
15:21:20 <regXboi> devstack won't even run now
15:21:33 <flaviof> oh... ok.
15:21:50 <flaviof> you are ahead of me; I'm just looking at making the stack work again.
15:21:59 <regXboi> #link https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/19/artifact/logs/screen-q-svc.txt where to find ECONNREFUSED
15:22:26 <regXboi> we'll have to put this back on the action list
15:23:00 <regXboi> #action all to continue to look at why neutron-daily-openstack-master is hosed
15:23:09 <regXboi> #info item 6
15:23:21 <regXboi> flaviof: any update on moving items between the trello boards?
15:23:43 <flaviof> regXboi: no. I'm stuck in trying to run tempests.
15:23:56 <flaviof> regXboi: trouble it, it touns out that is very hard to do when Icannot stack. :)
15:24:06 <regXboi> ok.. we'll move that one forward
15:24:10 <flaviof> ack
15:24:18 <regXboi> #action flaviof to update OS issues and move from https://trello.com/b/ddIvDQE0/ovs-openstack to https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound
15:24:23 <regXboi> #info item 7
15:24:41 <regXboi> I suspect we are all talking about this problem (getting ODL to run in the gate)
15:24:59 <regXboi> can I hope that folks in Vancouver find time to create some magic?
15:25:40 <flaviof> regXboi: i hope so.
15:26:04 <regXboi> ok we'll pull that one forward
15:26:09 <edwarnicke> flaviof: As mentioned last week... if folks want to jump on a hangout... I have a history of unwedging this class of issue
15:26:09 <flaviof> I see that now the 'create_initial_net' attempts to create an ipv6 router.
15:26:23 <regXboi> #action all to work on ODL running in the OS gate so that we can unblock OS patches
15:26:45 <regXboi> #topic Integration&System Test (Bug Squashing)
15:26:51 <flaviof> edwarnicke: yes!
15:27:06 <regXboi> we are missing a big piece of M5 - testing
15:27:31 <regXboi> we need system test complete for each user-facing feature ... does anybody have time to work on this?
15:28:11 <regXboi> and then once we have that, we need to link it into various jjb jobs (but I think this is pretty much already done for us)
15:28:36 <edwarnicke> flaviof: Can you scare up mestry ?
15:28:41 <edwarnicke> mestery
15:28:50 <flaviof> edwarnicke: unlikely.
15:29:26 <flaviof> I'd think mestery is not among us until May/25
15:30:19 <edwarnicke> flaviof: OK... correct me if I'm wrong, he's the one who can run stuff in the OS gate, correct?
15:30:33 <flaviof> edwarnicke: correct.
15:32:14 <flaviof> edwarnicke: I think the reality is that maintaining
15:32:17 <flaviof> edwarnicke: https://jenkins.opendaylight.org/releng/view/ovsdb/job/ovsdb-openstack-gerrit/
15:32:47 <edwarnicke> flaviof: Go on
15:32:57 <flaviof> edwarnicke: has proven to be extremely high maint.
15:33:12 <flaviof> edwarnicke: I'm not convinced this is about Ubuntu vs Centos;
15:33:18 <edwarnicke> flaviof: I have gotten that impression from the outside
15:33:22 <flaviof> it is more about nodePool, as we talked earlier.
15:33:29 <edwarnicke> flaviof: I think nodepool would help
15:33:37 <regXboi> so...
15:33:55 <flaviof> ack. until then, it is just very hard to keep up with the changes in openstack test vms.
15:33:57 <regXboi> this isn't really an answer to my question
15:33:59 <edwarnicke> flaviof: But I think fundamentally trying to maintain OS on centos (which runs way behind the times) when OS tends to run against the bleeding edge and is moving fast is a fools errand
15:34:31 <edwarnicke> flaviof: My guess is, once we get nodepool, we are going to constantly find ourselves having to recompile more recent versions of stuff for centos as its way behind
15:34:33 <flaviof> edwarnicke: devstack gate will not 'bless' anything until it passed ubuntu and centos builds.
15:34:40 <edwarnicke> flaviof: Ah
15:34:46 <edwarnicke> flaviof: So they've moved that pain upstream :)
15:34:54 <flaviof> edwarnicke: ack.
15:34:59 <regXboi> folks - we're digressing again
15:35:08 * edwarnicke feels sorry for the guy on the sharp pointy end of that
15:35:33 * edwarnicke considers starting a thread about the etymology of 'digress' ;)
15:35:38 <flaviof> lol
15:36:08 <regXboi> the question is still out there - does anybody have time to work on the patch for e2e system test
15:36:26 <regXboi> so that we can check that off - the devstack gate is our integration test, yes, but ...
15:37:02 <regXboi> that patch will also make me more confident in ticking of bugs
15:37:07 <regXboi> and we are collecting them
15:37:46 <edwarnicke> regXboi: I do not right now
15:37:57 <flaviof> regXboi: I do not right now
15:38:17 <mlemay> Is it the karaf https thing?
15:38:31 <regXboi> mlemay: no
15:38:37 <regXboi> this is something different
15:38:40 <regXboi> sigh ok
15:39:27 <mlemay> Sorry was out of conversation .. I was looking at the ECONN thing if that is what you mentioned
15:39:29 <odp-gerritbot> A change was merged to neutron: Bug3165 : Added implementation for FIXME3165 in NeutronSecurityRuleInterface  https://git.opendaylight.org/gerrit/20351
15:39:40 <regXboi> #action regXboi to make best effort to move https://git.opendaylight.org/gerrit/#/c/18356/ forward
15:39:50 <regXboi> #topic next meeting
15:40:21 <regXboi> #info regXboi is out on 5/22 and that is the openstack meet in Vancouver - do we want to meet next week?
15:40:47 <regXboi> I think we should take a pass and reconvene on 5/29
15:40:54 <flaviof> regXboi: +1
15:41:00 <regXboi> edwarnicke:?
15:41:13 <edwarnicke> +1
15:41:25 <regXboi> #agreed 5/22 meeting is cancelled fro Vancouver Openstack and vacation - will meet again on 5/29
15:41:32 <regXboi> #topic open mike
15:41:37 <regXboi> any other topics?
15:41:42 * edwarnicke begins singing freebird
15:41:58 * regXboi picks up air guitar
15:42:04 <edwarnicke> flaviof: How do we stand on the OS driver passing all the objects?
15:42:13 <edwarnicke> flaviof: Which ones are we getting and which are we not?
15:42:20 <flaviof> edwarnicke: that is
15:42:35 <flaviof> #link https://review.openstack.org/#/c/181578/ my changes on SG groups
15:43:13 <flaviof> edwarnicke: I'm working off of mestery changes, but there is a discrepancy in the way the db stores sg, and the way the
15:43:20 <flaviof> url/json body expects it.
15:44:08 <flaviof> with that, the cannot use the existing code, which simply maps the neutron obj to the json msg sent to neutron-nb
15:44:26 <edwarnicke> flaviof: So are you basically saying that what we are passing in port is wrong?
15:44:34 <flaviof> so, to answer your question, sg is not done.
15:44:38 <edwarnicke> flaviof: Because the db is storing something different than the call
15:45:16 <flaviof> edwarnicke: well, openstack's neutron db has no mapping of what it has stored and what the api expects.
15:45:21 <flaviof> that is for SG.
15:45:53 <flaviof> so we end up with '_' when expecting '-', and a list when we expect a singleton.
15:46:06 <edwarnicke> flaviof: And we are hacking that data out of the DB on the port response... so I presume that means our stuff 'catching' SG on the ODL side is wrong then because of that influence?
15:46:23 <flaviof> correct
15:46:31 <edwarnicke> flaviof: If we can get the messages to pass, we can fix the catcher
15:47:02 <edwarnicke> flaviof: So are the messages being passed to us by the OS driver now?
15:47:10 <flaviof> edwarnicke: yeah; im just confused that I expected the msgs to comply with what is in the doc:
15:47:26 <flaviof> #link http://developer.openstack.org/api-ref-networking-v2-ext.html#createSecGroup sg
15:48:15 <regXboi> folks - i need to run to another meeting - please close the meeting when you are done :)
15:48:17 <flaviof> edwarnicke: not until this (at least) is merged:
15:48:49 <flaviof> #link  https://review.openstack.org/#/c/178325/ sg wip
15:49:35 <flaviof> edwarnicke: that is the only missing work in the msgs, iirc
15:50:14 <flaviof> edwarnicke: I have not tested the floating ip stuff; that was definitely broken until recently.
15:50:57 <edwarnicke> flaviof: How does it differ from the docs?
15:51:26 <regXboi> are we essentially done here?
15:51:58 <flaviof> edwarnicke: on the sync up the sec group is a list, not a singleton
15:52:10 <edwarnicke> regXboi: I think so.. flaviof and I will probably continue to chat though
15:52:12 <flaviof> regXboi: yes; just wanted to ask u one thing
15:52:42 <flaviof> regXboi: in the marsh, I see secgroup and secgroups
15:52:49 <flaviof> the later expects a list, ofc.
15:52:49 <regXboi> yep
15:52:58 <regXboi> that's typicall neutron for bulk configuration
15:53:02 <flaviof> right.
15:53:09 <edwarnicke> flaviof: Yep, that's what I would expect, a list
15:53:12 <regXboi> but it's not used everywhere :)
15:53:33 <flaviof> for the bulk config does the ml2 side need to be made smart to use it?
15:54:09 <regXboi> huh?
15:54:12 * flaviof hoping there was a way for the soec to handle list and sigleton using the same 'secgroup' key
15:54:20 <mlemay> Count me in for openstack hacking next week
15:54:32 <regXboi> you can't do that
15:54:45 <flaviof> regXboi: ack. that is what I suspected.
15:54:50 <regXboi> the bulk op is for multiple sec groups
15:55:07 <regXboi> that need to go in atomically
15:55:12 <flaviof> and that has to use the 's' variation explicitly, right?
15:55:19 <regXboi> yes
15:55:23 <flaviof> cool. gotcha.
15:55:26 <flaviof> mlemay: ack!
15:55:27 <regXboi> as to what the ML2 passes to us?
15:55:36 * regXboi has no idea on that one
15:55:56 <flaviof> yeah, that is where the issue is right now. it seems a bit inconsistent
15:56:12 <regXboi> heh - Neutron itself is inconsistent
15:56:20 <regXboi> anyway
15:56:21 * alagalah regXboi shocking
15:56:37 <regXboi> #topic cinnamon muffins
15:56:38 <flaviof> regXboi:lol. ack.
15:56:40 <regXboi> #endmeeting