14:59:44 <regXboi> #startmeeting neutron_northbound
14:59:44 <odl_meetbot> Meeting started Fri Jun 12 14:59:44 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:44 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
14:59:55 <regXboi> #info regXboi pulls the trigger a little early
15:00:04 <regXboi> #topic roll call and agenda bashing
15:00:19 <regXboi> #info folks who are attending, please #info in
15:00:26 <edwarnicke> #info edwarnicke
15:00:27 <regXboi> #info regXboi
15:00:31 <regXboi> #chair edwarnicke
15:00:31 <odl_meetbot> Current chairs: edwarnicke regXboi
15:00:42 <regXboi> #info regXboi apologizes for missing last week
15:00:56 <regXboi> #info proposed agenda is in the usual place
15:01:15 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting page with proposed agenda
15:02:04 <regXboi> #info short agenda this week folks - bug triage (and CfV) and integration doc CfV
15:02:10 <regXboi> #info CfV = call for volunteers
15:02:48 <edwarnicke> regXboi: I believe we also need someone to test the RC candidates
15:02:49 <regXboi> edwarnicke: is spectrometer showing NN statistics?
15:02:57 <edwarnicke> regXboi: Or at least report on the testing we do
15:03:01 <regXboi> edwarnicke: good catch, let's add that
15:03:04 <edwarnicke> regXboi: I don't know (goes to look)
15:03:43 <edwarnicke> regXboi: Right now spectrometer appears to not have search options by module :(
15:04:17 <regXboi> edwarnicke: true - *but*
15:04:24 <regXboi> #link http://spectrometer.opendaylight.org/?metric=commits&release=all&project_type=all&module=neutron this looks promising
15:05:28 <regXboi> although I think it might be out of date
15:06:07 <edwarnicke> regXboi: Could be
15:06:14 <regXboi> anyway - other agenda items to be added?
15:06:29 <regXboi> (I've put the RC CfV first because that is most important)
15:07:47 <flaviof> #info flaviof
15:07:52 <regXboi> #chair flaviof
15:07:52 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:08:01 <regXboi> ok... let's get started
15:08:13 <regXboi> #topic RC testing CfV
15:08:37 <regXboi> we need someone to step up and volunteer to test the RCs - AFAIK, we haven't tested RC0 ...
15:08:55 <edwarnicke> regXboi: What do we think we need to do for RC testing?
15:09:07 <edwarnicke> (not objecting, just trying to put a fine point on it ;) )
15:09:32 <regXboi> edwarnicke: I *think* we need to stand up the RC and run through enough sanity testing to believe it works
15:09:43 <regXboi> the question is  what is "enough sanity testing" :)
15:10:16 <regXboi> the minimum would be our IT piece
15:10:41 <edwarnicke> regXboi: OK... we should be able to run our IT piece by just setting the versions locally in the POM file and running it, correct?
15:11:32 <regXboi> if by that you mean, branch, change dependcies/versions, and run through maven, yes I believe that *should* do the trick
15:12:17 <edwarnicke> Why branch?
15:12:39 * regXboi is paranoid about code leaking out
15:12:47 <regXboi> so branch locally only
15:13:18 <regXboi> i.e. regXboi doesn't want to see any paperwork (to quote monster's inc)
15:14:18 <alagalah> regXboi: :)
15:14:23 <alagalah> #info alagalah
15:14:29 <alagalah> Sorry, my other meeting just finished
15:15:32 <regXboi> alagalah: no worries, mate - we are talking about RC testing
15:15:36 <regXboi> so only on the first topic
15:16:00 <regXboi> anyway - anybody have cycles?
15:16:27 <regXboi> if not, I think I'll have some time this weekend to test RC0 (we are behind on that one)
15:17:40 <regXboi> going once?
15:18:08 <regXboi> going twice?
15:18:52 <regXboi> #action regXboi to set up and test RCs
15:18:56 <regXboi> ok next topic
15:19:07 <regXboi> #topic bug triage
15:19:13 <regXboi> #link https://bugs.opendaylight.org/buglist.cgi?list_id=27656&product=neutron&query_format=advanced&resolution=--- Bugs
15:19:34 <regXboi> we're going to go through *all* of these, and I'm looking for folks to step up to help with the neeed added tests/code to fix
15:20:10 <regXboi> so... based on the order that query returns them:
15:20:49 <regXboi> #info bug3533: edwarnicke - I marked this as external because I think that is in controller - is there a controller defect for this as well?
15:22:12 <regXboi> edwarnicke: hello?
15:22:29 <edwarnicke> regXboi: Apologies, was trying to run integation tests against RCs ;)
15:22:32 <edwarnicke> Looking
15:22:53 <regXboi> edwarnicke: cool :)
15:22:59 <edwarnicke> regXboi: It really *is* a neutron bug
15:23:05 <edwarnicke> regXboi: CrossOrigin filters are fine for Restconf
15:23:13 <edwarnicke> I still don't know why they bork for us
15:23:23 <regXboi> hmm
15:23:28 <regXboi> ok, I'm going to assign it to you
15:23:37 <regXboi> because you know more about it than I do at this point :)
15:24:15 <edwarnicke> LOL
15:24:18 <edwarnicke> armax: Welcome :)
15:25:02 <regXboi> #info bug3368 - do we have a OpenStack bug that we can put in the comments?
15:25:34 <regXboi> and edwarnicke: this is a defect against our ML2 driver
15:25:55 <regXboi> if neutron isn't filling the information in to the ML2 driver, the ML2 driver is responsible for filling it in before passing to us
15:26:27 <edwarnicke> regXboi: No... not sure if its a bug or a misuse
15:26:48 <regXboi> ok, can somebody take the action item of filing an openstack defect against the ML2 driver
15:26:55 <regXboi> and updating this bug with that URL?
15:26:58 <edwarnicke> armax: We are seeing an issue where we are not getting the tenantId on a port for a floating IP... I traced it down to: https://bugs.opendaylight.org/show_bug.cgi?id=3368#c2
15:27:14 <edwarnicke> armax: Any thoughts on how to poke it harder to find out if its a neutron bug or we are just doing something wrong?
15:27:19 <regXboi> yes, I read that - that is why I say it is a ML2 bug
15:27:50 <edwarnicke> armax: I've verified at least that its not us, its not our driver, and it appears to not be ML2 either... looks like we are either doing something wrong with the CLI or there's a bug in the CLI
15:28:00 <armax> edwarnicke: I’ll look into it…I am firefighting with some bigger fire right now :)
15:28:05 <edwarnicke> regXboi: I traced through to the point I don't think its ML2
15:28:10 <edwarnicke> armax: Many thanks :)
15:28:17 <armax> edwarnicke: bear with me
15:28:45 * edwarnicke is quite patient, because he understands how fires go ;)
15:28:51 <regXboi> edwarnicke, armax: my reasoning goes like this
15:28:59 <yamahata> If armax is busy, I'm willing to take it
15:29:18 <regXboi> yamahata: welcome as well
15:29:19 <armax> yamahata: sure thing, thanks for helping out…keep me posted if you need
15:29:33 <armax> as soon as I am putting out the fire for https://bugs.launchpad.net/neutron/+bug/1464612
15:29:39 <armax> then I’ll back
15:29:53 <regXboi> ok, if we've got folks looking at it, we can move on
15:29:57 <regXboi> that's what I'm looking for
15:30:39 <regXboi> next: bug3304 - Ed, can you add the OpenStack commit to this defect?
15:31:16 <edwarnicke> regXboi: Sure, one moment
15:31:17 * regXboi notes that the commit has not been merged yet :(
15:32:08 <regXboi> edwarnicke, have we updated the blocking bugs list with these?
15:32:14 * regXboi isn't sure
15:32:50 <edwarnicke> regXboi: added the OpenStack commit to the defect
15:33:04 <edwarnicke> regXboi: its in the blocking bugs, though for some odd reason under 'to verify'
15:33:14 <regXboi> confirming
15:33:21 <regXboi> ok, we need to change that back
15:33:29 <regXboi> it's not "to verify" it's still "awaiting merge"
15:34:20 <regXboi> next - bug 2088 - I've not had a chance to add test code for this one yet
15:34:32 <regXboi> although it's on my "when I have time list"
15:34:44 <edwarnicke> regXboi: fixed in blocking bug spreadsheet
15:35:05 <regXboi> er wait - which one - 3304?
15:35:10 <regXboi> oh ok
15:35:11 <regXboi> thanks
15:35:11 <regXboi> :)
15:35:19 * regXboi misread that last statement
15:35:49 <regXboi> a side note: while we have working E2E code, our code coverage statistics are b0rked and I'm not sure why
15:36:05 <regXboi> if somebody with knowledge can unb0rk them, that would be .... nice :)
15:36:52 <regXboi> next, bug #2540 - I've asked mestery to add specific JSON so that we can replicate in our E2E tests and see what is causing this problem
15:37:49 <regXboi> that last statement is also true for #2541, #2542, #2543, #2544, and #2550 (i.e. the tempest bugs)
15:38:14 <regXboi> next #3423 - edwarnicke - this looks pretty serious, have you had a chance to look at it?
15:38:26 <edwarnicke> regXboi: Lookig
15:39:32 <edwarnicke> regXboi: I have not
15:39:39 <edwarnicke> regXboi: Looks like we are missing many objects :(
15:39:44 <edwarnicke> regXboi: In the MD-SAL store :(
15:39:56 <regXboi> can I task you with working with alagalah to trace down what is causing this?
15:40:52 <regXboi> otherwise, I'll take it
15:41:35 <edwarnicke> If you could take it
15:41:45 <edwarnicke> I am currently working on the offline startup issue
15:41:55 <regXboi> ok, I'm wondering if this is related to the last two though
15:42:06 <edwarnicke> regXboi: How so?
15:42:28 <regXboi> #3169 and #3111 - both are failures from the yang code
15:42:37 <regXboi> one is in security groups
15:43:07 <regXboi> and the other is in routers
15:43:30 <regXboi> so I expect that while looking at #3423, we'll trip over the other two if they are still there
15:43:40 <regXboi> and if not, then :)
15:44:03 <regXboi> ok... alagalah: I'm not around today :(, but I'll find you Monday morning and we can work on #3423
15:44:07 <edwarnicke> regXboi: Ah... yes
15:44:07 <regXboi> sounds good?
15:44:40 <regXboi> ok... last topic
15:44:45 <regXboi> #topic integration documentation
15:44:48 <edwarnicke> regXboi: I'd recommend posting a comment on the bug asking if he has a POSTMAN of the sorts of calls he's making (he often does) because from that you should be self sufficient ;)
15:45:13 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-June/000177.html Interworking documentation
15:45:54 <regXboi> so noted and done
15:46:40 <regXboi> flaviof: do you have any experience with the request in that email and can help write some of the needed documentation?
15:47:18 * flaviof looking at link
15:47:22 <edwarnicke> regXboi: In particular, it would be nice to have docs that would explain how to stand up things like dummy-provider, because it makes it massively easier to test issues in message passing between the systems
15:48:21 <flaviof> regXboi: edwarnicke: my experience is related with using devstack.
15:48:49 <regXboi> ok, well, I'm not going to promise anything this week
15:49:06 <regXboi> :)
15:49:14 <regXboi> anything else?
15:49:23 <regXboi> otherwise
15:49:27 <regXboi> #topic cookies
15:49:47 <regXboi> #endmeeting