15:00:43 <regXboi> #startmeeting neutron_northbound
15:00:43 <odl_meetbot> Meeting started Fri Jun 19 15:00:43 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:43 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:45 <flaviof> regXboi: https://review.openstack.org/#/c/177257/  is merged. I expect issues unless 'vlan_transparent', 'mtu' is handled.
15:00:50 <flaviof> #info flaviof
15:01:01 <regXboi> #chair edwarnicke, flaviof
15:01:01 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:01:14 <regXboi> flaviof: feel free to add the attributes to the POTS
15:01:27 * regXboi is chasing other things
15:01:33 <flaviof> regXboi: ack.
15:01:46 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.286.2F19.29 agenda in the usual place
15:01:53 <regXboi> #topic agenda bashing
15:01:54 <edwarnicke> #info edwarnicke
15:01:58 <regXboi> anything to add here?
15:02:05 <regXboi> to the agenda?
15:02:29 <regXboi> going once
15:02:46 * regXboi counts to 10 slowly
15:03:07 <regXboi> going twice
15:03:11 * edwarnicke suggests deep cleansing breaths
15:03:31 * regXboi notes probably not a bad idea, his blood pressure already spiked this morning
15:03:56 <regXboi> #topic RC candidate report
15:04:12 <regXboi> #info we are green on RC1 - RC2 will be tested when it comes out later today
15:04:37 <regXboi> #info regXboi has *almost* a canned testing setup and is thinking of moving it to jenkins to be really lazy
15:05:19 * regXboi thinks it would be cool to have an RC jenkins job kicked off when an RC candidate is cut
15:05:33 * edwarnicke agrees :)
15:05:43 <regXboi> anyway...
15:05:50 <regXboi> #topic interworking documentation
15:06:11 <regXboi> #info we were looking for a volunteer on this - but I don't think anybody has stepped up
15:06:43 <regXboi> anybody have cycles?
15:06:52 <regXboi> if not I'm likely going to move it to the Berrylium list
15:08:06 <regXboi> #info interworking documentation moved to Berrylium list for lack of volunteers
15:08:12 <regXboi> #topic bugs
15:08:41 <regXboi> #link https://bugs.opendaylight.org/buglist.cgi?bug_status=__open__&list_id=35143&product=neutron open bugs
15:08:57 <regXboi> couple of points here
15:09:14 <regXboi> edwarnicke: I think you are down as verifying that 3368 is fixed
15:09:27 <regXboi> can you also get 3304 while you are at it?
15:10:27 <regXboi> while I wait for edwarnicke to come back, we have a new bug: 3812
15:11:03 <yamahata> I'm willing to take some bugs.
15:11:18 <yamahata> which one is higher priority?
15:11:22 <edwarnicke> regXboi: What were you waiting for from me?
15:11:35 <regXboi> verification of 3368 and 3304, edwarnicke
15:11:57 <regXboi> yamahata - those two are the highest because they are stable/lithium
15:12:01 <flaviof> yamahata: how about https://bugs.opendaylight.org/show_bug.cgi?id=3824 ?
15:12:21 <flaviof> I'm pretty sure Li is broken with that one now.
15:12:39 <yamahata> Sure.
15:12:42 <regXboi> well
15:13:01 <regXboi> that should have been higher than regular
15:13:09 <regXboi> because I was going to point at 3423
15:13:15 <regXboi> which is a serious problem as well
15:13:17 <regXboi> but that's ok
15:13:42 <regXboi> #action regXboi to write up wiki page on what information is needed when a bug is filed
15:13:58 <regXboi> armax: is bug 3812 from you?
15:14:11 * flaviof is bad with priorities. I respectfully defer to regXboi on what is most important.
15:14:11 <regXboi> er ... specifically: https://bugs.opendaylight.org/show_bug.cgi?id=3812
15:14:23 <regXboi> we'll bump 3824 up
15:15:00 <regXboi> btw folks, we have multiple versions too
15:15:12 <regXboi> so please mark the version appropriately: stable/li, master, multiple
15:15:38 <armax> regXboi: yes
15:16:03 <regXboi> armax: can you do me a favor?  specifying the neutron cli commands isn't *really* all that useful
15:16:18 <armax> regXboi: do you need the rest calls?
15:16:26 <regXboi> that would be much more helpful
15:16:29 <armax> ok
15:16:33 <armax> regXboi: no problem
15:16:36 <regXboi> because what I'm worried about are the hidden calls
15:16:39 <regXboi> armax: thanks
15:16:48 <armax> regXboi: yes that’s true
15:17:00 <armax> regXboi: would providing the neutron log snippet suffice?
15:17:10 <armax> regXboi: because calls are traced there
15:17:17 <regXboi> armax: if it has *all* of the calls, yes, that would be enough
15:17:27 <armax> regXboi: yes, ok, on its way
15:17:32 <regXboi> armax: thx!
15:17:47 <regXboi> #action regXboi to triage bug 3812
15:17:59 <regXboi> #action yamahata to triage bug 3824
15:18:10 <armax> regXboi: btw, I’d be happy to fix it too..but I would need guidance as I am a newbie on the ODL side
15:18:18 <regXboi> #action edwarnicke to verify 3368 and 3304
15:18:28 <regXboi> armax: that would be great
15:19:20 <regXboi> the way I was going to go about it was to replicate the REST stream as a function in the E2E java class - and then go fix where it broke
15:19:49 <regXboi> er E2E IT java classes (integration/test/src/test/....)
15:20:05 <regXboi> that way we have the test case build in for the future
15:20:31 <edwarnicke> regXboi: I think both 3368 and 3304 where reported by alagalah_ and thus he should probably verify
15:21:02 <regXboi> ok... then
15:21:03 <edwarnicke> armax: Ping me anytime for pointers on anything you want to work on the ODL code side :)
15:21:04 <regXboi> #undo
15:21:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1944750>
15:21:05 <regXboi> #undo
15:21:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19d7510>
15:21:06 <regXboi> #undo
15:21:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19d7dd0>
15:21:18 <armax> edwarnicke: will do
15:21:18 <edwarnicke> armax: I can either help you directly, or I will know who to hook you up with :)
15:21:21 <regXboi> #action armax to work with regXboi and edwarnicke on fixing bug 3812
15:21:29 <regXboi> #action yamahata to triage bug 3824
15:21:46 <regXboi> #action edwarnicke to work with alagalah on verifying 3368 and 3304
15:21:53 * regXboi rewrites history again
15:22:18 <edwarnicke> git: where history is both immutable and ephemeral :)
15:22:19 <regXboi> we've got more bugs, but if we get those taken care of, we can look at more as we go...
15:22:55 <regXboi> #info folks - please take ownership of your bugs
15:23:12 <regXboi> and also feel free to create trello board cards - if you need access to the trello board, ping me
15:23:26 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound Trello Board
15:23:37 <regXboi> anything else on bugs?
15:23:46 <regXboi> if not, I'd like to spend the rest of today on the future
15:23:55 <regXboi> going once?
15:24:06 * regXboi takes more deep cleansing breaths
15:24:15 <regXboi> going twice?
15:25:23 <regXboi> #topic Planning for Berrylium
15:25:39 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:FutureReleaseWishList Future Release Wish List
15:26:02 <regXboi> I created that page this morning to collect some thoughts that I've been mulling over
15:26:43 <regXboi> I *think* that the Berrylium list is enough work for the next cycle
15:26:55 <regXboi> there is a lot hidden in those bullets
15:27:22 <regXboi> especially the "catch up with neutron head apis" and the "solve the 'start up problem'..."
15:27:47 <regXboi> #action me to send email to neutron-dev to publicize this list
15:27:55 <regXboi> #undo
15:27:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1944650>
15:28:14 <regXboi> #action regXboi to send email to neutron-dev to publicize the future release wish list
15:28:25 <regXboi> any comments folks?
15:28:40 <regXboi> any other items to be added?
15:28:53 <regXboi> any items to be deferred to beyond Be?
15:29:23 * flaviof cannot think beyond Li... sorry
15:29:52 <regXboi> flaviof: that's ok - we at least have a list to work from
15:30:05 <regXboi> and that's why I put it down - so I wouldn't forget it
15:30:11 <flaviof> ack. thanks for doing it.
15:30:56 <regXboi> edwarnicke: is the description of the startup problem sufficiently granular?
15:31:54 * edwarnicke has lost context, regXboi please provide context for startup problem
15:32:10 <regXboi> right now the ODL ML2 agent dumps the entire neutron DB to ODL controller on a openstack control node restart - this won't scale
15:32:38 * regXboi hopes that is sufficient context
15:33:26 <regXboi> although (come to think of it) I'm assuming something that isn't true
15:34:13 <regXboi> before we can do that we need to have a persistent record of things
15:34:25 <regXboi> right now, our record is only emphermeal
15:34:38 <regXboi> er ephermeal even
15:35:20 * regXboi adds adding persistence to Be "to do" list, which adds another big bubble :)
15:35:54 <regXboi> #action everybody look for regXboi's email and start a future work item discussion on the ML
15:36:13 <regXboi> #topic open mike
15:36:35 <regXboi> #info other topics today folks?  If not, I'll give back ~20-25 minutes of time
15:37:10 <regXboi> going once?
15:37:42 <regXboi> going twice?
15:38:16 <regXboi> gone....
15:38:18 <regXboi> #topic cookies (oatmeal chocolate chip)
15:38:20 <regXboi> #endmeeting