15:01:14 <regXboi> #startmeeting neutron_northbound
15:01:14 <odl_meetbot> Meeting started Fri Jun 26 15:01:14 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:14 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:20 <regXboi> #chair flaviof
15:01:20 <odl_meetbot> Current chairs: flaviof regXboi
15:01:20 <flaviof> #info flaviof
15:01:28 <regXboi> #topic roll call and agenda
15:01:32 <regXboi> #info regXboi
15:02:08 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in the usual place
15:02:18 <regXboi> anybody want to add anything to the agenda?
15:02:57 <edwarnicke> #info edwarnicke
15:03:04 <regXboi> ok, if not
15:03:09 <regXboi> #topic action item update
15:03:38 <regXboi> #info 1. regXboi to write up wiki page on what information is needed when a bug is filed
15:03:52 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Bugs:_Help_Us_Help_You wiki page
15:03:55 <regXboi> so that one is done
15:04:04 <flaviof> nice
15:04:19 <regXboi> armax to work with regXboi and edwarnicke on fixing bug 3812
15:05:02 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/23180/ patch set handling bug 3812
15:05:15 <regXboi> #info that patchset will be merged to stable/lithium today
15:05:28 <edwarnicke> regXboi: Is stable/lithium unblocked for us?
15:05:42 <regXboi> edwarnicke: yes - I've been merging patches all morning
15:05:48 <regXboi> edwarnicke: where I can
15:06:16 <edwarnicke> mestery: Welcome :)
15:06:17 <regXboi> I think we have 5 patches left to merge
15:06:27 <regXboi> and stable/lithium will be caught up
15:06:30 <flaviof> regXboi: if you think that is useful, I caould tweak the wiki page to include a example way of cappturing the nn packets
15:06:41 <regXboi> flaviof: please
15:06:50 <AnkurGupta> please. Thank you
15:07:05 <flaviof> regXboiL AnkurGupta: ack.
15:07:12 <regXboi> #info 3. yamahata to triage bug 3824
15:07:22 <regXboi> yamahata: welcome - any progress?
15:07:25 <yamahata> I put a comment on it.
15:07:44 <yamahata> I agree with flaviof for lowering the priority
15:08:06 <yamahata> Given those two are ignored by ODL, neutron side works fine
15:08:22 <regXboi> so, we have a bunch of model updates to do for Be
15:08:29 <regXboi> I think this goes on the list
15:08:33 <yamahata> I'll continue to work on it as background task.
15:08:38 <regXboi> o
15:08:42 <regXboi> er ok - thanks
15:09:04 <regXboi> #info 4. edwarnicke to work with alagalah on verifying 3368 and 3304
15:09:12 <regXboi> edwarnicke: you around for an update?
15:09:36 <regXboi> I see that 3368 is closed and 3304 is *better* but still not perfect
15:09:46 <regXboi> because we have a bunch of cruft to clean up in Be related to it :(
15:09:58 <flaviof> yamahata: thanks for jumping in!
15:10:25 <regXboi> #info 3368 is closed and 3304 is *better* but still not perfect as there is more cruft to clean up in Be related to it
15:10:45 <regXboi> #info 5. regXboi to send email to publicize the future release work list
15:10:53 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-June/000196.html future release wish list announcement
15:10:57 <regXboi> I hope folks read it :)
15:11:09 <regXboi> because that was item numbre 6
15:11:22 <flaviof> #action flaviof to elaborate a little on getting the info mentioned in https://wiki.opendaylight.org/view/NeutronNorthbound:Bugs:_Help_Us_Help_You
15:11:31 <regXboi> but we'll talk more about it later
15:11:35 <regXboi> #topic Lithium
15:11:50 <regXboi> #info Lithium is out, the stable/lithium branch is unfrozen
15:12:05 <regXboi> #action regXboi to finish merging patches from master into it
15:12:17 <regXboi> any other Lithium items?
15:12:31 <regXboi> #info regXboi believes there are 5 more patches to merge to catch up
15:12:55 <regXboi> #info there is a current problem with the IT in VM running correctly, but regXboi has an idea for how to address that
15:13:15 <regXboi> going once on other Li items?
15:13:26 * regXboi waits 15 seconds
15:13:34 <regXboi> going twice on other Li items?
15:13:50 * regXboi waits another 15 seconds
15:14:01 <regXboi> #topic planning for Be and beyond
15:14:19 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:FutureReleaseWishList wiki page of future tasks
15:14:42 <regXboi> If folks want to go to that page, that is what I'm going to be talking from
15:14:43 <AnkurGupta> '
15:14:55 <regXboi> AnkurGupta: yes?
15:15:05 <AnkurGupta> accident sorry
15:15:20 <regXboi> no worries :)
15:15:34 <regXboi> so... the main things I think we need to do are at the top of the Be list
15:15:55 <edwarnicke> regXboi: I think we also need to prioritize HA and scaling for NN and our OS driver.
15:16:19 <regXboi> edwarnicke: note: that list isn't in an order as of yet
15:16:26 <flaviof> regXboi: I see HA being a big part of Be. In openstack terms, I expect that to percolate into neutron ml2.
15:16:53 <edwarnicke> flaviof: HA *and* scalability... you can do both together, or you can do HA in a way that scales poorly... I think we'd like to do both :)
15:17:06 <flaviof> edwarnicke: 100% agree.
15:17:11 <regXboi> folks, please do the unconference thing and edit the page and add +1's under topics that you are willing to work on
15:17:12 <edwarnicke> flaviof: I strongly suspect from a preliminary look at the problem that it breaks into these pieces:
15:17:17 <edwarnicke> 1)  HA within NN
15:17:31 <edwarnicke> 2)  Enabling HA for the Providers
15:17:52 <edwarnicke> 3)  Improved mechanisms and algorithms for communicating from OS to us
15:18:26 <edwarnicke> I think #1 mostly comes down to the MD-SAL migration
15:18:35 <regXboi> edwarnicke,flaviof,others: ^^^^^^^ on marking items you are willing to work on
15:18:41 <edwarnicke> I think for #2 we need to figure out our asks to clustering in partnership with our consumers
15:18:48 <regXboi> or better yet
15:18:56 <edwarnicke> #3 is going to involve a lot of collaboration upstream
15:19:02 <regXboi> can somebody take the action item of making trello cards for all of these?
15:19:05 <regXboi> and we can vote there?
15:19:11 <edwarnicke> flaviof: Do you have any ideas on #3 yet (or armax ? )
15:20:28 <yamahata> Regrading to #3, it basically comes down to synchronize two databases.
15:20:29 <flaviof> edwarnicke: i do not yet. but you are right in saying that it involves a lot of collaboration with the neutron community.
15:20:39 <odp-gerritbot> Ryan Moats proposed a change to neutron: Run jacoco in UT VM and report to sonar  https://git.opendaylight.org/gerrit/23428
15:20:46 <edwarnicke> yamahata: You are correct
15:21:01 <edwarnicke> yamahata: The tricky part is that sinking two DBs in an HA world gets more complicated
15:21:01 <yamahata> I suspect modification to db schema is inevitable
15:21:11 <edwarnicke> yamahata: Especially when events keep coming while you try to sync :)
15:21:21 <edwarnicke> yamahata: Please say more, I'd love to hear your ideas :)
15:22:23 <yamahata> one possibility is to throw away one of two db
15:22:34 <yamahata> I'm not sure it's feasible
15:22:36 <flaviof> yamahata: if odl is not behind a load-balancer; I also think ml2 metworking-odl will need to accommodate more than one OLD_IP_MGR.
15:22:49 <flaviof> s/OLD/ODL
15:23:20 <odp-gerritbot> Ryan Moats proposed a change to neutron: Clean up IT and address Bug 3812  https://git.opendaylight.org/gerrit/23433
15:23:50 <edwarnicke> flaviof: I agree, we need to accomodate more than one ODL_IP_MGR for HA
15:24:25 <edwarnicke> yamahata: I don't think we will get reasonable performance and scalability if we throw away one of the two dbs
15:24:31 <regXboi> so, that's a definite change to the ODL ML2 agent
15:24:53 <edwarnicke> regXboi: Yes, and then we need to decide what to *do* with multiple IPs
15:25:09 <edwarnicke> Do we round robin, have a way to figure out where the shards are mastered and talk to that?
15:25:09 <regXboi> edwarnicke: I'd probably vote for RR
15:25:19 <regXboi> as a first step
15:25:25 <flaviof> regXboi: +1
15:25:31 <edwarnicke> How do we handle join/leave from the cluster... if someone adds a new ODL cluster node, then clearly static IPs are not going to be enough
15:25:34 <regXboi> if we can figure out shard masters, great
15:26:04 <edwarnicke> regXboi: flaviof Agreed... its just been my experience if you *think* a little about where you are going, you can leave archetectual 'Whitespace' for the things you know are coming
15:26:06 <regXboi> and now you've introduced something that is borderline NN (imho)
15:26:12 <edwarnicke> (as opposed to painting yourself into a corner ;) )
15:26:49 <regXboi> so, honestly, telling upstream systems about ODL cluster IP addresses is something for controller, I would think
15:26:53 <regXboi> we should piggyback on it
15:28:07 <edwarnicke> regXboi: Yes, but if we want to have clustering expose some of that via restconf, we need to ask them to do so :)
15:28:20 <edwarnicke> regXboi: Basically, ask them to keep an operational model folks can access :)
15:28:30 <regXboi> so... you *KNOW* my opinion on restconf for anything northbound
15:29:04 <regXboi> but
15:29:05 <edwarnicke> regXboi: One way or the other... we would need to tunnel info from ODL to OS to find out about our cluster nodes
15:29:14 <edwarnicke> regXboi: If we are using rest, that means we need a rest API
15:29:14 <regXboi> can we come back out of the weeds for a minute?
15:29:25 * edwarnicke likes the weeds, but assents
15:29:48 * alagalah surfaces now folks emerge from weed induced frenzy :D
15:29:56 <regXboi> so... (1) do we have a volunteer to create trello cards for the tasks in the wiki page? and to create new ones for other tasks?
15:30:18 <regXboi> (2) will people please put their IRC handles and a +1 under the cards so that we can see what folks are willing to work on ?
15:30:33 <regXboi> (3) then we can come back in a week or two and see what Be looks like?
15:30:41 * edwarnicke is very bad at trello (as shague and flaviof they can attest ;) )
15:31:10 * regXboi looks towards alagalah and flaviof/shague as having most experience with 1 :)
15:31:51 <alagalah> regXboi: I'll make cards
15:31:57 <alagalah> action me oh keeper of the chair
15:32:13 <alagalah> Due: Wed next week
15:32:14 * flaviof is probably worse than edwarnicke on trello cards :(
15:32:25 <flaviof> #chair alagalah
15:32:25 <odl_meetbot> Current chairs: alagalah flaviof regXboi
15:32:26 * edwarnicke is not sure how that is physically possible ;)
15:32:34 <alagalah> flaviof: niiiiiiice
15:32:36 <regXboi> #action alagalah to kindle create trello cards for the Be items with a deadline of Wed next week
15:32:42 <regXboi> #undo
15:32:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1942cd0>
15:32:56 <regXboi> #action alagalah to kindly create trello cards for the Be items with a deadline of Wed next week
15:33:10 * regXboi doesn't want to see flaming trello cards :)
15:33:14 * alagalah not sure I can do anything kindly, since I mash at my keyboard at best but yes....
15:33:32 <regXboi> #action everybody to +1 cards they are willing to work on
15:33:56 <regXboi> #action regXboi to add agenda item to check status of interest in Be items
15:34:06 <regXboi> ok... now that we've got *that* out of the way
15:34:14 <regXboi> edwarnicke is welcome to partake of weeds again
15:34:45 * edwarnicke *is* in Colorado after all ;)
15:35:10 <alagalah> edwarnicke: flaviof So with HA, are we looking at a mechanism as well for DB sync between ODL and OS ?
15:35:22 <alagalah> edwarnicke: flaviof i.e. What did YOU do whilst I was gone ?
15:35:47 <flaviof> edwarnicke: lol
15:35:54 <alagalah> Who made changes to neutron, and who made changes to ODL ? (note "changes" could be operational as well as configuration)
15:36:10 <edwarnicke> alagalah: For HA and Scalability we need a way of both keeping in sync with the OS DB *and* receiving events in the correct order
15:36:24 <edwarnicke> alagalah: No major shift was made yet in how we are doing it
15:36:27 <alagalah> Thats one direction, no thought as to the other ?
15:36:45 <edwarnicke> alagalah: Not opposed to the other, just hadn't thought about it as much
15:36:55 <edwarnicke> alagalah: The thing we currently face I believe is this:
15:36:58 <alagalah> flaviof: Do you?
15:37:04 <flaviof> in regards to ml2 specifically, I'd like to take a step back and learn from our neutron gurus how ha is intented to be consumed.
15:37:11 <edwarnicke> 1)  Our OS driver talks to only one ODL IP (ie, no HA)
15:37:13 <flaviof> maybe existing working models we could leverage.
15:37:13 <alagalah> flaviof: yeah
15:37:16 <odp-gerritbot> Ryan Moats proposed a change to neutron: Clean up IT and address Bug 3812  https://git.opendaylight.org/gerrit/23433
15:37:19 <alagalah> flaviof: Well more align to
15:37:33 <edwarnicke> 2)  If there are multiple control nodes, each will try to do a *full* dump of the neutron DB to ODL on startup
15:38:02 <edwarnicke> #2 doesn't scale :(
15:38:24 <edwarnicke> 3)  Each control node will try to tell ODL about each event (ie, event happens, we receive *N* events, one from each control node)
15:38:34 <edwarnicke> Which also won't scale well and is likely to be racy as shit
15:38:59 <alagalah> flaviof: regXboi edwarnicke Doesn't it make sense to step back and see where OS is going with all this? And then we can say "We align with the L release or M release of HA" ???
15:39:17 <edwarnicke> alagalah: If they are going somewhere with this, absolutely
15:39:21 <edwarnicke> (or have gone somewhere)
15:39:27 <edwarnicke> But browsing through the public ML2 drivers
15:39:31 <alagalah> edwarnicke: I don't know... thats what I mean... step back, survey the ground...
15:39:35 <edwarnicke> It looks like almost all of them have the same defects
15:39:36 <regXboi> alagalah: when it comes to HA, the story with respect to the mechanisum drivers is a bit muddy
15:39:46 <regXboi> alagalah: as in non-existent
15:39:47 * edwarnicke *has* looked at other peoples code ;)
15:40:09 <yamahata> the current ML2 design is already racy. and there are an effort with taskflow on-going
15:40:29 <edwarnicke> armax: Any word on where HA is going with ML2 drivers?  We are feeling the need for stuff, would love to learn from others :)
15:40:43 <regXboi> yamahata: +1 (in all sorts of connotations of the word "racy" (smile))
15:40:53 <edwarnicke> yamahata: Could you give some examples of where its racy? :)
15:41:27 <yamahata> the step to update is to commit neutron db, then call mechanism driver.
15:41:42 <yamahata> The order of db commit and calling mechanism driver can be reordered.
15:42:16 <odp-gerritbot> A change was merged to neutron: Clean up IT and address Bug 3812  https://git.opendaylight.org/gerrit/23433
15:42:19 <yamahata> So even what neutrno db has can be differ from what ODL has
15:42:35 <edwarnicke> :(
15:42:58 <yamahata> Usually it's quite rare to update on same resource. i.e. same network, same neutron port.
15:43:09 <yamahata> at same time
15:43:12 <alagalah> yamahata: So its semi-synchronous
15:43:37 <yamahata> Yes. So ML2 are working on synchronizing mechanism with taskflow
15:43:39 <alagalah> yamahata: The local neutron DB is committed before the ML2 message to ODL is ack'd
15:43:57 <alagalah> yamahata: nice... but it does bring up scale... but nice.
15:44:37 <alagalah> yamahata: let me restate
15:44:40 <alagalah> yamahata: So its semi-synchronous?
15:44:43 <alagalah> yamahata: The local neutron DB is committed before the ML2 message to ODL is ack'd ?
15:44:50 <alagalah> I forgot punctuation... :)
15:44:51 <yamahata> Yes.
15:45:00 <alagalah> yamahata: thank you
15:45:23 <alagalah> yamahata: So these efforts, do you have pointers to them ?
15:45:31 <yamahata> The reason why ML2 doesn't call mechanism driver during db transaction is timeout
15:45:34 <alagalah> yamahata: The ones to improve consistency of the workflow
15:45:45 * yamahata looking for the link...
15:45:49 <alagalah> yamahata: thank you.
15:46:53 <odp-gerritbot> Ryan Moats proposed a change to neutron: Run jacoco in UT VM and report to sonar  https://git.opendaylight.org/gerrit/23428
15:47:12 <alagalah> yamahata: I have to step away for another meeting, but I promise I will look when I return. I assume there is a "think" for HA on the wiki I'm to turn into a card, so I shall put your link to the card this weekend.
15:47:22 <alagalah> * "thing"
15:47:59 <regXboi> folks: are we done?
15:49:53 <yamahata> https://wiki.openstack.org/wiki/Meetings/ML2
15:49:59 <yamahata> at the agenda of June 17
15:50:12 <yamahata> But right now I couldn't find good one.
15:50:17 <flaviof> #link https://wiki.openstack.org/wiki/Meetings/ML2 Neutron ML2 meeting
15:50:18 <yamahata> Try it later
15:50:25 <flaviof> yamahata: thanks!
15:50:31 <regXboi> #topic cookies#linfo lots of discussion about HA - see the logs for the full text
15:50:35 <regXboi> #undo
15:50:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a9d890>
15:50:41 <regXboi> #info lots of discussion about HA - see the logs for the full text
15:50:53 <regXboi> again - are we done?
15:50:57 <regXboi> going once?
15:51:19 <regXboi> going twice?
15:51:31 <regXboi> #action regXboi to update meeting page for next meeting
15:51:43 <regXboi> edwarnicke: you will miss next week, yes?
15:51:53 <regXboi> if so, please info that :)
15:52:45 <regXboi> oh well
15:52:49 <regXboi> #topic cookies
15:52:55 <regXboi> thanks all!
15:52:57 <regXboi> #endmeeting