15:01:08 <regXboi> #startmeeting neutron_northbound
15:01:08 <odl_meetbot> Meeting started Fri Jul 10 15:01:08 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:21 <regXboi> folks who are here for the meeting please #info in
15:01:24 <regXboi> #info regXboi
15:01:35 <regXboi> #topic roll call and agenda bashing
15:01:49 <regXboi> #info edwarnicke is on holiday
15:02:02 <regXboi> #info flaviof is on channel but has a family commitment
15:02:17 <regXboi> #info therefore we don't have quorum of committers and so this is an info only meeting
15:03:24 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in its usual place mid page
15:03:57 <regXboi> anybody have any items to add?
15:04:52 <regXboi> #topic action items from last meeting
15:05:21 <regXboi> #info flaviof has added to the bug wiki page on how to capture packets
15:05:54 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Bugs:_Help_Us_Help_You bug wiki page - look for the section on "Capturing packets using tcpdump"
15:05:58 <regXboi> #info thanks flaviof
15:06:57 <regXboi> #info regXboi to finish merging patches into stable/lithium - this is done - at this point when a patch gets merged to master, the committer who merges it has the responsibility of cherry picking to stable/lithium if it applies there
15:07:16 <regXboi> #info alagalah to kindly create trello cards for Be items
15:07:26 <regXboi> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound Be Trello Cards
15:07:44 <regXboi> that's done - if folks need access to the trello board, please PM me with your email address and I'll add you
15:08:08 <regXboi> #info if folks need access to the trello board, please PM regXboi with the email address to add and he'll take care of it
15:08:23 <regXboi> #info everybody to +1 cards they are willing to work on in Be
15:08:34 <regXboi> I've done this, but I don't see much other evidence, so...
15:08:53 <regXboi> #action everybody to +1 trello cards for Be items they are willing to work on
15:09:12 <regXboi> my plan is to only pull in items that have people that will devote time to making them happen
15:09:35 <regXboi> which brings us to...
15:09:40 <regXboi> #topic planning for Be
15:10:41 <regXboi> besides the trello wish list of features/tasks, we need to decide on two things - do we need a new PTL and who volunteers to be the various contacts we will need
15:11:00 <regXboi> since we don't have quorum, we can't decide on either of these, so...
15:11:28 <regXboi> #action everybody to think about whether they want to volunteer to be a contact
15:11:49 <regXboi> #action regXboi, flaviof, edwarnicke to decided who will be PTL for Be
15:12:02 <regXboi> sigh
15:12:03 <regXboi> #undo
15:12:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ce0750>
15:12:04 <regXboi> #undo
15:12:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ce00d0>
15:12:14 <regXboi> #action everybody to think about whether they want to volunteer to be a contact for Be
15:12:26 <regXboi> #action regXboi, flaviof, edwarnicke to decided who will be PTL for Be
15:12:37 <regXboi> leaving us with
15:12:44 <regXboi> #topic open mike/discussion
15:12:57 <regXboi> anybody have anything they want to discuss?
15:13:35 <yamahata> Hi. Is the build currently broken?
15:13:43 <yamahata> It didn't build last night.
15:13:45 <regXboi> yamahata: not that I know of
15:14:04 <yamahata> regXboi: Okay, maybe my environment issue.
15:14:22 <regXboi> yamahata: not quite - if you set -DskipTests or -DskipITs it *is* broken
15:14:45 * regXboi is currently working out how to fix that and will update the patch set
15:15:06 <yamahata> regXboi: Oh, I see. I also tried mvn clean install without -Dxxx
15:15:22 <regXboi> yamahata: mvn clean install without -Dxxxx does work
15:15:34 <regXboi> that's how jenkins and I both run it
15:15:53 <regXboi> yamahata: so for that, I would say it is an environment issue
15:16:13 <yamahata> regXboi: thanks. I'll look into my environment.
15:16:58 <regXboi> yamahata: be on the lookout for an updated patch set
15:17:14 <regXboi> yamahata: and then see if it works for you
15:17:23 <yamahata> regXboi: sure
15:17:24 * regXboi running one more test
15:17:32 <regXboi> yamahata: and thanks
15:18:25 <yamahata> Regarding to bug 3968, any opinions?
15:18:43 <yamahata> What's the point to have two similar interfaces bool isXXX() and Bool getXXX()?
15:18:46 <regXboi> yamahata: ah yes
15:19:06 <regXboi> so the isXXX was there for legacy purposes
15:19:15 <yamahata> Ruijing is hitting it in the context of GBP
15:19:32 <yamahata> so isXXX is deprecated?
15:19:36 <regXboi> I need more context there, because AFAIK GBP shouldn't be calling that method directly
15:20:29 <regXboi> yamahata: once we have the context, we can make a decision, but I fully expect to either pull isXXX() completely out of Be or mark it deprecated
15:20:37 <yamahata> TBO, I don't have details. It's up to ruijing.
15:21:02 <regXboi> #info discussion of potential build breakage
15:21:03 <yamahata> That makes sense.
15:21:05 <regXboi> #undo
15:21:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b94c10>
15:21:13 <regXboi> #info  discussion of potential build breakage see log for details
15:21:21 <regXboi> #info discussion of bug 3968, see log for details
15:21:28 <regXboi> sorry, just getting things into the minutes
15:22:03 <regXboi> #action regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly
15:22:35 <odp-gerritbot> Ryan Moats proposed a change to neutron: build failure of neutron  https://git.opendaylight.org/gerrit/23969
15:22:56 <regXboi> yamahata: try that patch update ^^^^^^ out and see if it helps your build issues
15:23:23 <regXboi> anything else folks?
15:23:51 <regXboi> going once?
15:24:03 * regXboi waits 30 seconds
15:24:30 <regXboi> going twice?
15:24:39 * regXboi waits another 30 seconds
15:25:15 <regXboi> gone - sold to somebody...
15:25:24 <regXboi> #action regXboi to update meeting minutes/agenda for next week
15:25:28 <regXboi> #topic cookies
15:25:30 <regXboi> #endmeeting