15:00:21 <regXboi> #startmeeting neutron_northbound
15:00:21 <odl_meetbot> Meeting started Fri Jul 24 15:00:21 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:32 <regXboi> #topic roll call and agenda bashing
15:00:47 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.287.2F24.29 agenda in the usual place
15:00:55 <edwarnicke> #info edwarnicke
15:01:09 <regXboi> #info regXboi
15:01:18 <regXboi> #chair edwarnicke flaviof
15:01:18 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:01:31 <flaviof> #info flaviof
15:01:49 <regXboi> #action regXboi to send out reminder email on Thursdays with link to draft agenda
15:01:59 <regXboi> that's just to remind me to do something I keep forgetting
15:02:20 <regXboi> #info any additions to the agenda?
15:03:12 <regXboi> ok.... if not....
15:03:23 <regXboi> #topic action items from last meeting
15:03:35 <regXboi> #info 1. everybody to +1 trello cards for Be items they are willing to work on
15:04:25 <regXboi> #info it looks like we've got items +1'd there which is good - we can pull them into the release plan and update trello board with what we are working on in Be :)
15:04:38 <regXboi> #info 2.  everybody to think about whether they want to volunteer to be a contact
15:04:54 <regXboi> #info we'll cover this more under Be :)
15:05:03 <regXboi> #info 3. regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly
15:05:14 <regXboi> I admit, I haven't done this, so...
15:05:21 <regXboi> #action regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly
15:05:46 <flaviof> regXboi: on that note
15:05:55 <regXboi> yes?
15:05:58 <flaviof> you mentioned something that caught my ear
15:06:11 <flaviof> if it is not in the interface, it is not in the 'contract'.
15:06:30 <flaviof> so, how is it that public functions are visible outside nn ?
15:06:30 <regXboi> yes
15:06:56 * flaviof surprised that ovsdb net-virt was able to use a public function that was not in the contract
15:07:15 <regXboi> ah well, that's sort of the java way - if you have the object, you have it's methods
15:07:38 <flaviof> ack... but we could use interface to mask that, no?
15:07:56 <regXboi> that's sort of what I'm thinking for Be
15:08:05 <regXboi> implement new interfaces for the objects that are the contracts
15:08:30 <regXboi> and items in the contract (while public) aren't guaranteed outside of the project
15:08:32 <flaviof> yeah, just to keep 'intruders' out, as well as more freedom to remove stuff w/out worrying about breakeage.
15:08:38 <regXboi> er items *not* in the contract
15:08:49 <regXboi> flaviof: ack
15:09:01 <regXboi> although: honestly
15:09:07 <flaviof> ok... if the contract is embodied as an interface and that interface is all users can see, then it is 'self' enforcing.
15:09:13 <regXboi> downstream projects should be pulling from MD-SAL
15:09:28 <regXboi> and using the MD-SAL objects, as *that* will be the SB contract
15:09:45 <flaviof> yeah, ack. that sounds like a good way going forward.
15:09:53 <regXboi> because to rev the model requires reversioning, so you know what you get
15:10:15 <flaviof> cool beans; i think that will work.
15:10:20 <regXboi> so I'm going to back up and say I'd rather just say "don't use anything that isn't model or interface"
15:11:00 <regXboi> we can talk more in Be, but for now...
15:11:02 <regXboi> #info 4. regXboi to update meeting minutes/agenda for next week  (done or we wouldn't have our agenda now would we :)"
15:11:07 <regXboi> #undo
15:11:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cd4950>
15:11:10 <regXboi> #info 4. regXboi to update meeting minutes/agenda for next week  (done or we wouldn't have our agenda now would we :)
15:11:22 <regXboi> #info 5. NN to finalize Be feature set at 7/24 meeting
15:11:32 <regXboi> actually, I misread the schedule - we don't *have* to do that today
15:11:43 <regXboi> so let's leave the door open a bit longer
15:12:06 <regXboi> #info regXboi realizes he misread the schedule, so that is a false action item and dropped
15:12:11 <flaviof> yeah, we may come up with good ideas for that during the Summit
15:12:19 <regXboi> #info 6. regXboi to update Trello Board bug list
15:12:23 <regXboi> I still need to do that, so
15:12:42 <regXboi> #action regXboi to update Trello Board bug list
15:12:45 <regXboi> ok...
15:13:00 <regXboi> #topic Beryllium (which I keep misspelling)
15:13:06 <regXboi> #undo
15:13:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1cd4f50>
15:13:12 <regXboi> #topic Beryllium
15:13:24 <regXboi> #info M1 deadline is 7/30
15:13:36 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium_Release_Plan draft project plan
15:13:49 <regXboi> #info we will add items from Trello board during M1-M2
15:13:59 <regXboi> #info but... we *need* a testing contact
15:14:02 <regXboi> volunteers?
15:14:48 * regXboi notes, be really scared about that release plan - I am doing it "by the book" to point out how incredibly painful it really is
15:15:44 <yamahata> regXboi: Give me a day or two. I can't answer it right now, though.
15:16:04 <regXboi> #undo
15:16:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cd4b90>
15:16:25 <regXboi> #info but... we *need* a testing contact by 7/30... any volunteers
15:16:29 <regXboi> yamahata: ack
15:16:49 <regXboi> my plan is to request the system test exemption because running ST with NN makes *NO* sense
15:17:01 <regXboi> our automatic IT functions as our system test
15:17:54 <regXboi> in fact, I think we are pretty good as far as the IT/UT infra goes now - we just need to add new tests, and I certainly plan on spending cycles on it during Be
15:18:27 <regXboi> anybody have comments on the draft release plan?
15:18:39 <regXboi> other than it's incredibly pedantic?
15:18:54 <edwarnicke> You are missing dependencies on controller ;)
15:19:20 <regXboi> edwarnicke: so actually, if you look at our dependencies, we don't *depend* on controller
15:19:24 <regXboi> we depend on odlparent
15:19:30 <regXboi> and that brings in dependencies on controller
15:19:33 <edwarnicke> Look at the feature for transcriber
15:19:42 <edwarnicke> controller dependencies are not in odlparent
15:20:01 <regXboi> ok, you just won an action :)
15:20:15 <regXboi> #action edwarnicke to add feature dependencies to draft release plan
15:20:55 <flaviof> heh... what is it in the conroller that nn needs?  web server?
15:20:59 <regXboi> but you did answer my "TBD" in that section, so thank you very much
15:21:15 <regXboi> flaviof: actually, through features, we depend on controller and aaa
15:21:18 <regXboi> the second is that nasty one
15:21:49 <flaviof> ack; make sense (both statements).
15:22:23 <regXboi> #action regXboi to verify jjb dependencies to controller , odlparent, yangtools so that we know if/when controller breaks us
15:22:28 <regXboi> #undo
15:22:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1b6f8d0>
15:22:38 <regXboi> #action regXboi to verify jjb dependencies to controller , odlparent, yangtools so that we know if/when upstream projects break us
15:22:44 <regXboi> that's better
15:23:13 <regXboi> and I gave myself another action as well
15:23:45 <regXboi> #info to folks reading this that don't see the new APIs in the draft plan - not to worry, we have until M2 to finalize, so we'll be adding APIs as we go
15:24:03 * regXboi doesn't want folks who are working on new things to think we've forgotten them
15:24:35 <edwarnicke> flaviof: transcriber is using the MD-SAL
15:24:57 <regXboi> edwarnicke: transcriber right now is straddling the divide
15:25:09 * regXboi is in process of making transcriber MD-SAL only
15:25:26 * regXboi notes: two concurrent hash maps down, X to go
15:25:47 <regXboi> #topic Deprecate GET methods
15:25:51 <flaviof> edwarnicke: cool. how about : <repository>mvn:org.opendaylight.controller/features-restconf/${mdsal.version}/xml/features</repository> ?
15:26:01 <flaviof> who uses that?
15:26:30 <edwarnicke> flaviof: I suspect that's there out of habit
15:26:32 <regXboi> flaviof: since you know the downstream stuff better than I, can I task you with finding out if we *can* just remove the northbound GET methods?
15:26:55 <regXboi> #action flaviof to find out what deprecating the northbound GET methods would break
15:26:59 <flaviof> regXboi: yes
15:27:03 <regXboi> flaviof: ty
15:27:11 <regXboi> that's all I had on that one
15:27:22 <regXboi> #topic should we remove checks on incoming items
15:27:33 <regXboi> #info status: In process of removing what we can, and deprecating what breaks downstream for removal in Boron
15:27:46 <regXboi> flaviof: this is our earlier discussion during the action items
15:27:54 <flaviof> ack
15:28:03 <regXboi> #info for backstory, see logs of discussion between regXboi and flaviof during action items
15:28:29 <regXboi> the bottom line is we are going to do it and tell folks that starting in Be they should use the model and not the POJOs
15:29:05 <regXboi> #action regXboi to update API section of release plan with statement that in Be, model should be used rather than POJOs as POJOs are not part of any contract
15:29:24 <regXboi> #info or won't be after I*Aware goes away
15:29:34 <regXboi> #topic Bugs
15:29:44 <flaviof> regXboi: qq
15:29:49 <flaviof> #undo
15:29:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x18cdad0>
15:29:50 <regXboi> flaviof: go ahead
15:30:03 <flaviof> once iware goes away, how will nn know if there are any providers?
15:30:16 <regXboi> flaviof: at that point nn won't care
15:30:30 <flaviof> regXboi: ack.
15:30:34 <flaviof> #topic Bugs
15:30:40 <regXboi> flaviof: nn will put information into md-sal and that's it
15:31:04 <regXboi> #info see action item above - once regXboi gets things updated, we can review and parcel out
15:31:12 <regXboi> that's all for that one
15:31:20 <regXboi> #topic should we meet 7/31 or not?
15:31:28 <flaviof> regXboi: understood. the 'canXXX' api is going away with that; so there is not need for 'providers'
15:31:30 <regXboi> #info summit is next week, so should we meet?
15:31:36 <regXboi> flaviof: exactly
15:31:46 <regXboi> so folks, that's the question on the table
15:31:55 <edwarnicke> regXboi: I vote no... or rather, we should substitute this session: https://wiki.opendaylight.org/view/Events:Be_Dev_Forum#ODL_Neutron_in_Beryllium
15:32:06 <edwarnicke> flaviof: Speaking of which, would you mind if I also listed you here: https://wiki.opendaylight.org/view/Events:Be_Dev_Forum#ODL_Neutron_in_Beryllium
15:32:13 <regXboi> edwarnicke: when is that scheduled for?
15:32:15 <flaviof> my vote goes for skip next week. at least I will be flying for most of that day
15:32:27 <edwarnicke> flaviof: You are skipping the last day of the design summit?
15:32:39 <flaviof> edwarnicke: yes and yes...
15:32:40 <regXboi> ok, how about we take edwarnicke's substitution?
15:32:44 <flaviof> need to head out on Fri am.
15:33:22 <regXboi> edwarnicke: you can always find philrobb and have one of the ipads - I'll join remote then
15:33:31 <edwarnicke> regXboi: Will do :)
15:33:32 <flaviof> edwarnicke: btw, that is in sched.org now.
15:33:33 <regXboi> er phrobb (sigh)
15:33:58 <flaviof> edwarnicke: ... and I did sign up for it.
15:33:59 <regXboi> #agreed 7/24 meeting will be replaced with session at https://wiki.opendaylight.org/view/Events:Be_Dev_Forum#ODL_Neutron_in_Beryllium
15:34:14 <regXboi> #link https://wiki.opendaylight.org/view/Events:Be_Dev_Forum#ODL_Neutron_in_Beryllium replacement session for 7/24 mtg
15:34:23 <regXboi> that makes sense to me :)
15:34:27 <regXboi> and now
15:34:30 <regXboi> #topic open mike
15:34:48 <regXboi> one thing I have is extensions
15:35:02 <regXboi> #info how to add extensions into the project
15:35:14 <regXboi> #info regXboi has looked at this and doesn't see a good solution
15:35:18 <edwarnicke> regXboi: http://sched.co/3ybm  - neutron session
15:35:19 <regXboi> here's my problem:
15:35:40 <regXboi> edwarnicke: ack
15:36:10 * regXboi notes - he's taking flex fridays now, so he should have that slot wide open (assuming it is PDT)
15:36:21 <regXboi> anyway - here's my problem with extensions
15:36:38 <regXboi> changes to pojos and the model pretty much have to be part of the neutron-spi and model bundles respectively
15:36:54 <regXboi> which means if we split the rest of the extension, we have a "half in, half out" model
15:37:01 <regXboi> which makes me go "ewww"
15:37:36 <regXboi> so, while I'm thinking that extensions need to define their own feature
15:37:48 <regXboi> the code/tests/et.al. lives in the NN project
15:37:58 <regXboi> comments?
15:38:54 <regXboi> note: I'm not saying anything about package names
15:39:04 <regXboi> those I expect to be different
15:40:04 <edwarnicke> I think the tricky part is going to be figuring out the JAXB bindings
15:40:52 <regXboi> I suspect those will be lifted straight from the OS neutron extension, although I shudder to see what we'll get
15:42:49 <regXboi> anything else folks?
15:42:59 <regXboi> or can we wander away for the week?
15:43:08 * regXboi queues up cookies topic
15:44:17 * edwarnicke waits for cookies
15:44:36 <regXboi> ok then
15:44:40 <regXboi> #topic cookies
15:44:43 <regXboi> #endmeeting