#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 15:00:35 UTC (full logs).

Meeting summary

    1. flaviof (flaviof, 15:00:37)

  1. roll call and agenda bashing (regXboi, 15:00:52)
    1. regXboi (regXboi, 15:00:54)
    2. edwarnicke (edwarnicke, 15:01:00)
    3. mestery in lurk mode (mestery, 15:01:10)
    4. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in its usual place (regXboi, 15:01:21)
    5. regXboi left the agenda light because we need more discussion time on itema (regXboi, 15:01:38)
    6. yamahata (yamahata, 15:02:12)

  2. action items from last meeting (regXboi, 15:02:16)
    1. regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly (regXboi, 15:02:31)
    2. regXboi has consulted and is not convinced bug 3968 is real (regXboi, 15:03:26)
    3. regXboi, edwarnicke, flaviof to find a document contact vict.... volunteer (regXboi, 15:03:36)
    4. ACTION: regXboi, edwarnicke, flaviof to find a document contact vict.... volunteer (regXboi, 15:04:10)
    5. regXboi to kick off threads on networking-ODL (regXboi, 15:04:24)
    6. https://lists.opendaylight.org/pipermail/neutron-dev/2015-August/000275.html plugin or ML2 (regXboi, 15:04:43)
    7. https://lists.opendaylight.org/pipermail/neutron-dev/2015-August/000276.html where should it live (regXboi, 15:04:53)
    8. https://lists.opendaylight.org/pipermail/neutron-dev/2015-August/000277.html two projects or one (regXboi, 15:05:02)

  3. Beryllium/Open Mike (regXboi, 15:05:21)
    1. flaviof to talk about stable/kilo networking-odl issue (regXboi, 15:05:56)
    2. https://lists.opendaylight.org/pipermail/neutron-dev/2015-August/000284.html stable/kilo issue (flaviof, 15:06:37)
    3. problem is we need the proposal bot syncing accurate stable/kilo changes into networking-odl (regXboi, 15:10:40)
    4. this is a +1 for leaving networking-odl at openstack (regXboi, 15:10:58)
    5. changing the wire protocol (regXboi, 15:12:27)
    6. https://wiki.opendaylight.org/images/8/8d/Experiences_with_Neutron.pdf Dec's summit talk (regXboi, 15:13:13)
    7. current openstack ml2 odl driver is single threaded and blocks neutron server (post-commit) until ODL responds (regXboi, 15:16:21)
    8. AGREED: this observation should be bundled as a consideration/requirement for the rewrite ML discussion (regXboi, 15:22:46)
    9. second observation: db synchronization issue (regXboi, 15:23:14)
    10. regXboi thinks this is a bit of a bogus observation (at least as presented in the slide) (regXboi, 15:23:56)
    11. AGREED: tabling this observation for a week to get clarity of assumptions (regXboi, 15:28:54)
    12. observation: current ML2 ODL driver sync mechanism only runs when triggered by a new Neutron event (regXboi, 15:29:44)
    13. https://www.youtube.com/watch?v=CL70MNgFeQs Dec's presentation on youtube (regXboi, 15:31:24)
    14. lots of discussion about observation 3 - see the logs (regXboi, 15:45:14)
    15. observation 4: no switch type independent configuration for mapping of neutron physical networks to physical interfaces (regXboi, 15:52:47)
    16. ACTION: edwarnicke to launch neutron-dev ML thread on observation #4 from Dec's talk (regXboi, 15:59:10)
    17. ACTION: regXboi to update ML thread on rewrite with notes from this meeting (regXboi, 16:00:25)

  4. cookies (regXboi, 16:00:28)


Meeting ended at 16:00:31 UTC (full logs).

Action items

  1. regXboi, edwarnicke, flaviof to find a document contact vict.... volunteer
  2. edwarnicke to launch neutron-dev ML thread on observation #4 from Dec's talk
  3. regXboi to update ML thread on rewrite with notes from this meeting


Action items, by person

  1. edwarnicke
    1. regXboi, edwarnicke, flaviof to find a document contact vict.... volunteer
    2. edwarnicke to launch neutron-dev ML thread on observation #4 from Dec's talk
  2. flaviof
    1. regXboi, edwarnicke, flaviof to find a document contact vict.... volunteer
  3. regXboi
    1. regXboi, edwarnicke, flaviof to find a document contact vict.... volunteer
    2. regXboi to update ML thread on rewrite with notes from this meeting


People present (lines said)

  1. regXboi (148)
  2. flaviof (51)
  3. edwarnicke (41)
  4. yamahata (25)
  5. mestery (13)
  6. armax (12)
  7. vthapar (11)
  8. viveknarasimhan (6)
  9. odl_meetbot (6)
  10. yapeng (2)


Generated by MeetBot 0.1.4.