#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 15:01:19 UTC (full logs).

Meeting summary

  1. agenda bash and roll call (regXboi, 15:01:27)
    1. regXboi (regXboi, 15:01:31)
    2. yamahata (yamahata, 15:01:42)
    3. apologies for no meeting last week, there were a dirth of committers (regXboi, 15:01:56)
    4. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda from last week, which we'll start with (regXboi, 15:02:26)
    5. edwarnicke (edwarnicke, 15:02:43)

  2. action items (regXboi, 15:03:16)
    1. ACTION: edwarnicke, flaviof, regXboi to look at bug 3990 (regXboi, 15:05:36)
    2. ACTION: yamahata to check and comment on bug 4026 (regXboi, 15:06:45)
    3. https://git.opendaylight.org/gerrit/#/c/26266/ PS for 4043 (regXboi, 15:07:55)
    4. https://git.opendaylight.org/gerrit/#/c/26266/ looks good to me, any idea why flaviof didn't merge? (edwarnicke, 15:09:16)
    5. ACTION: yamahata to add test cases to PS 26266 and 26267 (regXboi, 15:11:16)
    6. ACTION: regXboi to review and merge 26266 and 26267 once test cases are in place (regXboi, 15:11:29)
    7. ACTION: yamahata to fix up https://git.opendaylight.org/gerrit/#/c/25500/ (regXboi, 15:14:46)
    8. ACTION: regXboi to look at adding out of order IT tests to catch other issues like bug 4188 (regXboi, 15:15:07)

  3. Berylliym (regXboi, 15:17:23)
    1. we have dependencies from the following downstream groups (so far): VTN, OVSDB, BGPVPN, LispFlowMapping, GBP (regXboi, 15:18:10)
    2. BGPVPN and GBP need to configure their jjb correctly so that the dependency appears in our merge (regXboi, 15:18:28)
    3. ACTION: edwarnicke to work with BGPVPN and GBP projects about getting their dependency on NN into their JJB configs so that integration on merge is handled correctly (regXboi, 15:22:28)

  4. Other patch sets (regXboi, 15:22:47)
    1. https://git.opendaylight.org/gerrit/#/c/26128/ northbound: return 404 when deleting unexisting uuid (regXboi, 15:25:36)
    2. https://git.opendaylight.org/gerrit/#/c/26127/ northbound: introduce a base class (regXboi, 15:27:46)
    3. https://git.opendaylight.org/gerrit/#/c/25332/ BUG #4143 : Transation failed with OptimisticLockFailedException (regXboi, 15:29:29)
    4. https://git.opendaylight.org/gerrit/#/c/26551/ (regXboi, 15:31:18)
    5. https://git.opendaylight.org/gerrit/#/c/26554/ (regXboi, 15:31:26)
    6. https://git.opendaylight.org/gerrit/#/c/26577/ (regXboi, 15:31:36)
    7. https://git.opendaylight.org/gerrit/#/c/26581/ (regXboi, 15:31:43)
    8. https://git.opendaylight.org/gerrit/#/c/26578/ (regXboi, 15:31:53)
    9. https://git.opendaylight.org/gerrit/#/c/26711/ BGPVPN: Added yang, api and transcriber for BGPVPN. (regXboi, 15:38:26)
    10. https://git.opendaylight.org/gerrit/#/c/23594/ Proposed Neutron network to device map model (regXboi, 15:47:10)
    11. ACTION: regXboi to schedule network to device map patch set at top of list for 9/18 meeting (regXboi, 15:48:46)

  5. ML2 ODL driver rewrite (regXboi, 15:49:12)
    1. https://review.openstack.org/#/c/222409/ Opendaylight driver refactor to handle out of sync issues [WiP] (regXboi, 15:50:54)
    2. lots of discussion here - see the logs (regXboi, 16:11:37)


Meeting ended at 16:18:02 UTC (full logs).

Action items

  1. edwarnicke, flaviof, regXboi to look at bug 3990
  2. yamahata to check and comment on bug 4026
  3. yamahata to add test cases to PS 26266 and 26267
  4. regXboi to review and merge 26266 and 26267 once test cases are in place
  5. yamahata to fix up https://git.opendaylight.org/gerrit/#/c/25500/
  6. regXboi to look at adding out of order IT tests to catch other issues like bug 4188
  7. edwarnicke to work with BGPVPN and GBP projects about getting their dependency on NN into their JJB configs so that integration on merge is handled correctly
  8. regXboi to schedule network to device map patch set at top of list for 9/18 meeting


Action items, by person

  1. edwarnicke
    1. edwarnicke, flaviof, regXboi to look at bug 3990
    2. edwarnicke to work with BGPVPN and GBP projects about getting their dependency on NN into their JJB configs so that integration on merge is handled correctly
  2. regXboi
    1. edwarnicke, flaviof, regXboi to look at bug 3990
    2. regXboi to review and merge 26266 and 26267 once test cases are in place
    3. regXboi to look at adding out of order IT tests to catch other issues like bug 4188
    4. regXboi to schedule network to device map patch set at top of list for 9/18 meeting
  3. yamahata
    1. yamahata to check and comment on bug 4026
    2. yamahata to add test cases to PS 26266 and 26267
    3. yamahata to fix up https://git.opendaylight.org/gerrit/#/c/25500/


People present (lines said)

  1. regXboi (128)
  2. edwarnicke (54)
  3. yamahata (47)
  4. asomya (23)
  5. john_a_joyce (16)
  6. vthapar (9)
  7. odp-gerritbot (6)
  8. odl_meetbot (4)
  9. colindixon (1)


Generated by MeetBot 0.1.4.